image_speed virou um inútil?

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

image_speed virou um inútil?

Mensagem por Markituh em Dom 25 Abr 2010, 11:31

Olá pessoal. Tava aqui mechendo no GM 7... Quando coloquei no Create do objeto o image_speed,quando fui rodar,o image_speed não causou nenhum efeito. A sprite ficou com a speed da room...

___________

"Não deixe para amanhã o que se pode fazer hoje"

Links úteis:
Índice de Tutoriais
Manual online do GMS

Markituh

Ranking : Sem avaliações
Número de Mensagens : 2183
Data de inscrição : 11/10/2009
Reputação : 106
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Cainã em Dom 25 Abr 2010, 11:34

Markituh escreveu:Olá pessoal. Tava aqui mechendo no GM 7... Quando coloquei no Create do objeto o image_speed,quando fui rodar,o image_speed não causou nenhum efeito. A sprite ficou com a speed da room...

Você fez algo errado por que a função com certeza ainda funciona! Que velocidade você colocou? Lembre-se que 1 é a velocidade da Room, menos que isso é uma velocidade menor que a da Room.

Cainã

Número de Mensagens : 1335
Idade : 22
Data de inscrição : 07/03/2010
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://cai.na.tl/

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Markituh em Dom 25 Abr 2010, 11:36

Eu coloquei 0.5 e ficou a velocidade da room...

___________

"Não deixe para amanhã o que se pode fazer hoje"

Links úteis:
Índice de Tutoriais
Manual online do GMS

Markituh

Ranking : Sem avaliações
Número de Mensagens : 2183
Data de inscrição : 11/10/2009
Reputação : 106
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Cainã em Dom 25 Abr 2010, 11:38

Markituh escreveu:Eu coloquei 0.5 e ficou a velocidade da room...

Pode ser impressão, tenta colocar uma velocidade mais baixa (ex.: 0.1) só para testar.

Cainã

Número de Mensagens : 1335
Idade : 22
Data de inscrição : 07/03/2010
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://cai.na.tl/

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Markituh em Dom 25 Abr 2010, 11:40

Infelizmente,ainda ficou na velocidade da room =X

___________

"Não deixe para amanhã o que se pode fazer hoje"

Links úteis:
Índice de Tutoriais
Manual online do GMS

Markituh

Ranking : Sem avaliações
Número de Mensagens : 2183
Data de inscrição : 11/10/2009
Reputação : 106
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Cainã em Dom 25 Abr 2010, 11:44

Você pode me passar o código só para eu ver o que pode estar acontecendo?

Cainã

Número de Mensagens : 1335
Idade : 22
Data de inscrição : 07/03/2010
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://cai.na.tl/

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Markituh em Dom 25 Abr 2010, 11:52

Ok.

Create:
Código:
image_speed=0.1
Step:
Código:
if keyboard_check_pressed(vk_enter) or keyboard_check_pressed(ord("E"))
{
global.transform=false
instance_activate_object(Omni_aliendisplay)
}
if global.transform=false
{
instance_change(Destransform,false)
}
Creio que o Step não tem nada a ver,mas mandei mesmo assim Happy

___________

"Não deixe para amanhã o que se pode fazer hoje"

Links úteis:
Índice de Tutoriais
Manual online do GMS

Markituh

Ranking : Sem avaliações
Número de Mensagens : 2183
Data de inscrição : 11/10/2009
Reputação : 106
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Cainã em Dom 25 Abr 2010, 11:56

Será que o problema não está no instance_change(Destransform,false) ?

No false que você colocou, o novo objeto não executa as ações do antigo portanto a velocidade volta ao normal.

Cainã

Número de Mensagens : 1335
Idade : 22
Data de inscrição : 07/03/2010
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://cai.na.tl/

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Markituh em Dom 25 Abr 2010, 12:14

Acho que não. Pois a ação de troca só é executada se tal variável for false. E naquela hora estava true.

Estou com esse problema no image_speed a um tempão...

___________

"Não deixe para amanhã o que se pode fazer hoje"

Links úteis:
Índice de Tutoriais
Manual online do GMS

Markituh

Ranking : Sem avaliações
Número de Mensagens : 2183
Data de inscrição : 11/10/2009
Reputação : 106
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Cainã em Dom 25 Abr 2010, 12:21

Markituh escreveu:Acho que não. Pois a ação de troca só é executada se tal variável for false. E naquela hora estava true.

Estou com esse problema no image_speed a um tempão...


Então talvez seja algum problema no Game Maker (apesar de ser difícil acontecer isso).

Cainã

Número de Mensagens : 1335
Idade : 22
Data de inscrição : 07/03/2010
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://cai.na.tl/

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Markituh em Dom 25 Abr 2010, 12:26

Beleza,vou deixar na velocidade da room mesmo. Nunca tive esse problema com o image_speed. Agora eu to tendo... Obrigado Cainã,até.

___________

"Não deixe para amanhã o que se pode fazer hoje"

Links úteis:
Índice de Tutoriais
Manual online do GMS

Markituh

Ranking : Sem avaliações
Número de Mensagens : 2183
Data de inscrição : 11/10/2009
Reputação : 106
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Jiraya em Dom 25 Abr 2010, 12:46

faz o seguinte, use image_speed=0 no step event
se a imagem nao se mecher, isso quer dizer que o oimage_speed esta funcionando.
se estiver funcionando usa image_speed no step mesmo.
se isso nao funcionar, existe uma maneira meio pesada para deixa a animaçao lenta.
Dobrar a quantidade de imagens da sprite =\[leve isso como ultimo recurso]

Jiraya

Ranking : Nota A
Número de Mensagens : 1134
Data de inscrição : 20/03/2010
Notas recebidas : A+A
Reputação : 108
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 1

https://www.facebook.com/seito.washiro.7

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Janx em Dom 25 Abr 2010, 13:11

Será que você não está modificando a velocidade em algum outro lugar? Isso pode estar dando o problema. Não tem porque o image_speed resolver "bugar" derrepente.

Janx

Número de Mensagens : 2417
Idade : 23
Data de inscrição : 24/05/2008
Reputação : 14
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 2
   : 0

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Cainã em Dom 25 Abr 2010, 13:44

Se realmente aconteceu algum problema (acho difícil ter acontecido isso, como o Janx disse), você pode fazer uma gambiarra assim:

CREATE:

Código:
{
vel=10;  //Aqui você ajusta a cada quantos Steps vem a próxima imagem.
image_single=0;
alarm[0]=vel;
}

ALARM 0:

Código:
{
if image_single=image_number{
image_single=0;
}
else{
image_single+=1;
}
alarm[0]=vel;
}

Cainã

Número de Mensagens : 1335
Idade : 22
Data de inscrição : 07/03/2010
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://cai.na.tl/

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Kyuubi em Dom 25 Abr 2010, 14:00

ahh isso já aconteceu comigo, eu acho se vc usou o instance_change os dois objetos que vc vai substituir tem que ter o mesmo image_speed se não acontece isso.
flws!!!!

Kyuubi

Número de Mensagens : 443
Idade : 23
Data de inscrição : 28/11/2009
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

http://animeworldmugen.forumeiros.com/forum

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Markituh em Dom 25 Abr 2010, 14:14

Obrigado Kyuubi,o objeto player não tinha image_speed. Quando coloquei ficou beleza! Agora,a sprite da transformação ficou lenta por causa disso :S. Mas vou dar uma editada nas indexes dela. Obrigado a todos!

___________

"Não deixe para amanhã o que se pode fazer hoje"

Links úteis:
Índice de Tutoriais
Manual online do GMS

Markituh

Ranking : Sem avaliações
Número de Mensagens : 2183
Data de inscrição : 11/10/2009
Reputação : 106
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Kyuubi em Dom 25 Abr 2010, 14:29

Por nada, prazer em ajudar amigos!!!
flws!!!

Kyuubi

Número de Mensagens : 443
Idade : 23
Data de inscrição : 28/11/2009
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

http://animeworldmugen.forumeiros.com/forum

Voltar ao Topo Ir em baixo

Re: image_speed virou um inútil?

Mensagem por Conteúdo patrocinado Hoje à(s) 12:26


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum