[ RESOLVIDO ] BUG NO COGUMELO! ME AJUDEM!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[ RESOLVIDO ] BUG NO COGUMELO! ME AJUDEM!

Mensagem por Adriel em Qui 11 Mar 2010, 18:16

Pessoal, o negócio é o seguinte, eu estou fazendo um jogo do Super Mario Bros de 1985 ( que já havia colocado uma screenshot na assinatura, mas tirei ) E, hojje, estava "incrementando" o jogo, quando eu fiz a parte do cogumelo que dá vida. Mas, quando ele colide com a caixa, cria milhares de cogumelos de vida ( ao invés de só um ), e quando sai da caixa, para de cair. Como resolvo? Existe algum código tipo : se tiver mais de um cogumelo, todos são deletados, menos um

Entenderam?


Última edição por Del em Qui 11 Mar 2010, 19:24, editado 1 vez(es)

Adriel

Número de Mensagens : 922
Idade : 18
Data de inscrição : 18/07/2009
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Re: [ RESOLVIDO ] BUG NO COGUMELO! ME AJUDEM!

Mensagem por o cara em Qui 11 Mar 2010, 18:32

explica com que codigo vc fez isso...

o cara

Número de Mensagens : 103
Data de inscrição : 27/11/2009
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: [ RESOLVIDO ] BUG NO COGUMELO! ME AJUDEM!

Mensagem por Adriel em Qui 11 Mar 2010, 18:35

Bom... eu usei no obj_vida:

No Create :

Código:
alarm[4] = 7;
vspeed = -3;

No Alarm 4 :

Código:
vspeed = 3;
hspeed = 1.5;

Adriel

Número de Mensagens : 922
Idade : 18
Data de inscrição : 18/07/2009
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Re: [ RESOLVIDO ] BUG NO COGUMELO! ME AJUDEM!

Mensagem por donte em Qui 11 Mar 2010, 19:12

cara pq não tenta fazer a caixa mudar de obj, exemplo:
tem 2 caixas 1 com algo outra vazia.
ai quando o mário colide com a caixa com algo modifica de obj(da caixa)

donte

Número de Mensagens : 1164
Idade : 18
Data de inscrição : 22/12/2009
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

http://nintendocenterbr.forumeiros.com

Voltar ao Topo Ir em baixo

Re: [ RESOLVIDO ] BUG NO COGUMELO! ME AJUDEM!

Mensagem por Adriel em Qui 11 Mar 2010, 19:23

Esqueçam, quebrei a cabeça aqui e resolvi!

Adriel

Número de Mensagens : 922
Idade : 18
Data de inscrição : 18/07/2009
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Re: [ RESOLVIDO ] BUG NO COGUMELO! ME AJUDEM!

Mensagem por Conteúdo patrocinado Hoje à(s) 19:53


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum