[pedido] To com problema no "registry"

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[pedido] To com problema no "registry"

Mensagem por tedi em Sab 09 Jan 2010, 13:16

Oi galera, eu tava tentando fazer uma engine pra mim mesmo de registry, ai eu me espelhei numa lib que tinha um codigo de criar conta parecido com isso (eu mudei um pouco)
Código:
{
{
global.user = get_string("Nome","")
global.senha = get_string("Senha","")
}
if registry_exists(global.user)
{
do
{
show_message("Novamente porfavor")
global.user=get_string("Nome","")
global.senha=get_string("senha","")
if registry_exists(global.user) show_message("Nome ja existente")
}
until
registry_exists(global.user)=false
}
}
so que quando eu digito o meu nome e senha primeiro ele diz que ja existe e depois funfa mas primeiro eu tenho que por algo nada a ver e depois o certo se nao ele diz que ja existe tambem.
como posso resolver isso???

tedi

Número de Mensagens : 110
Idade : 19
Data de inscrição : 24/07/2009
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: [pedido] To com problema no "registry"

Mensagem por dungeon333 em Sab 09 Jan 2010, 14:16

Código:

global.user = get_string("Nome","")
global.senha = get_string("Senha","")
while(file_exists(string(global.user)+".register"))
{
show_message("Nome ja existente")
show_message("Novamente porfavor")
global.user=get_string("Nome","")
global.senha=get_string("Senha","")
}
ini_open(string(global.user)+".register")
ini_write_string("Account","Account",global.user)
ini_write_string("Account","Passwordt",global.senha)
tenta esse script

dungeon333

Número de Mensagens : 351
Data de inscrição : 29/05/2009
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Re: [pedido] To com problema no "registry"

Mensagem por tedi em Sab 09 Jan 2010, 14:58

e como eu faço para loga-lo?

tedi

Número de Mensagens : 110
Idade : 19
Data de inscrição : 24/07/2009
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: [pedido] To com problema no "registry"

Mensagem por Conteúdo patrocinado Hoje à(s) 12:12


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum