Conectar-se
Quem está conectado
27 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 27 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 03/10/2014
Número de Mensagens : 1
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuário

Erro no compilamento (APK)

em Sex 03 Out 2014, 12:47
Olá. Sempre que tento criar o apk de meu aplicativo aparece este erro:BUILD FAILED
C:\Users\Ot�vio\AppData\Local\Android\android-sdk\tools\ant\build.xml:601: The following error occurred while executing this line:
C:\Users\Ot�vio\AppData\Local\Android\android-sdk\tools\ant\build.xml:542: Unable to resolve project target 'android-7'

Já instalei TODO o pacote sdk e mesmo assim continua acontecendo o mesmo erro sempre. Tentei mudar configurações mas nunca adiantou. O que faço?

vidroid.com.br escreveu:
avatar
Ranking : Nota B
Notas recebidas : B+B
Data de inscrição : 04/03/2012
Número de Mensagens : 1925
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 144

Prêmios
   : 1
   : 2
   : 0
Ver perfil do usuário

Re: Erro no compilamento (APK)

em Sex 03 Out 2014, 13:42
Isso acontece por que você está usando uma versão da steam modificada, o ideal seria comprar uma versão da yoyo games, essa versão que você usa até da para testar no dispositivo movel, mas pode não dar para criar um apk, se for realmente essa a versão que vc usa
avatar
Ranking : Nota A
Notas recebidas : B A
Data de inscrição : 20/12/2008
Número de Mensagens : 2516
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 177

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://redscreensoft.blogspot.com

Re: Erro no compilamento (APK)

em Sex 03 Out 2014, 15:07
O erro diz que tenta compilar pela API 7, o que não é possível. Então você não a tem. Basta ir onde instalou o SDK e verificar a pasta plataforms. Deveria ter várias pastas inciadas com "android-". No seu caso apontou para pasta "android-7", que representa a API 7 (Android 2.1).

A Google Play não aceita mais .apk's feitos na API 7 (Android 2.1) ou API 8 (Android 2.2). Agora a só aceita da API 10 (Android 2.3) em diante. Mas ainda é possível compilar nessas APIs com o GM.

Pra instalar as APIs necessárias, vá até onde instalou o Android SDK e execute o "SDK Manager.exe".

Selecione as APIs 7, 8, 10, 13, 15, 19 e depois clique em Install Packages.

Pra mais detalhes leia o guia:

http://gmbr.forumeiros.com/t29103-android-preparando-o-gms-para-o-android

FLWS!
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum