Objeto não ataca

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Objeto não ataca

Mensagem por BackGround em Dom 13 Jun 2010, 23:36

Estou quebrando a cabeça com isso.

Eu fiz de varios modos,vou explicar:

O objeto anda pros lados normalmente,dai tudo blz,movimentação OK

Dai eu resolvi criar o ataque,o unico problema é...o sprite NÃO MUDA
De jeito nenhum,to a horas tentando fazer mudar,ele continua com o sprite que estava na hora...tem alguma explicação?

BackGround

Número de Mensagens : 570
Data de inscrição : 24/04/2010
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: Objeto não ataca

Mensagem por Sannin Kyuubi em Seg 14 Jun 2010, 13:11

Se postar o script que fez ajudaria muito...

Sannin Kyuubi

Número de Mensagens : 192
Idade : 21
Data de inscrição : 12/02/2010
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Objeto não ataca

Mensagem por giosepeluiz em Seg 14 Jun 2010, 13:12

Desculpe, ainda não entendi... Se puder explicar melhor a situação, fica melhor para ajudarmos... Se possivel coloque screenshots ou o gmk aqui ;)

giosepeluiz

Número de Mensagens : 110
Idade : 26
Data de inscrição : 21/05/2010
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

http://www.orkut.com.br/Main#Profile?uid=12612551030963156921

Voltar ao Topo Ir em baixo

Re: Objeto não ataca

Mensagem por BackGround em Seg 14 Jun 2010, 13:53

Desculpem,tava denoite e não tive muito tempo de escrever!

Ok,eu segui o tutorial Levante e Ande do RedDrago para RE-FAZER os meus códigos,eu tinha feito de outro modo e não deu.

Step:

Spoiler:
if (keyboard_check(vk_right))
{
hspeed=3
direita = true
andando = true
}else{
if (keyboard_check(vk_left)){
hspeed=-3
direita = false
andando = true
}else{
hspeed=0;andando = false
}
}
if direita = true {
if andando = true{
sprite_index = ObiAndando
}else{
sprite_index = ObiParado
}
}else{
if andando = true{
sprite_index = ObiAndando
}else{
sprite_index = ObiParado
}
}
if (keyboard_check(vk_space) and atacando = false)
{
image_index = Atacando1
atacando = true
alarm[0]=11

E no alarm[0] eu puis Atacando = False.

Mas o comando não vai!
Não muda de sprite de jeito nenhum!

Edit:

Acho que concertei,depois eu volto e posto

BackGround

Número de Mensagens : 570
Data de inscrição : 24/04/2010
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: Objeto não ataca

Mensagem por Conteúdo patrocinado Hoje à(s) 10:47


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum