Conectar-se
Quem está conectado
21 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 21 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 07/06/2010
Número de Mensagens : 39
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Problema com sprites

em Qua 09 Jun 2010, 14:24
Não sei o problema é script ou não...

quando eu coloco uma sprite simples no personagem, ele anda normalmente,mas se eu coloco uma sub imagem na sprite ele trava. E quando eu tiro a sub imagem ele continua travado.

Me ajuda!!
avatar
Ranking : Sem avaliações
Data de inscrição : 26/04/2010
Número de Mensagens : 1217
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuáriohttp://lightsoftworks.blogspot.com/

Re: Problema com sprites

em Qua 09 Jun 2010, 14:33
tem que ter uma mask no objeto.
avatar
Data de inscrição : 21/05/2010
Número de Mensagens : 110
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Ver perfil do usuáriohttp://www.orkut.com.br/Main#Profile?uid=12612551030963156921

Re: Problema com sprites

em Qua 09 Jun 2010, 14:36
Seja bem vindo ao fórum danrau1.
Poderia nos explicar melhor o que você quer dizer com "travado"?

Ele não sai do lugar, ou a imagem (animação) que fica fixa?

Obrigado.
avatar
Data de inscrição : 07/06/2010
Número de Mensagens : 39
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problema com sprites

em Qua 09 Jun 2010, 14:52
Valeu Happy

Eu to usando mask,mas mesmo assim ta com erro.Ele "trava" no sentido de não se mexer nem pra esquerda ou direita.Mas pra pular, que é uma sprite simples,ele pula normalmente
avatar
Data de inscrição : 21/05/2010
Número de Mensagens : 110
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Ver perfil do usuáriohttp://www.orkut.com.br/Main#Profile?uid=12612551030963156921

Re: Problema com sprites

em Qua 09 Jun 2010, 14:55
@danrau1 escreveu:Valeu Happy

Eu to usando mask,mas mesmo assim ta com erro.Ele "trava" no sentido de não se mexer nem pra esquerda ou direita.Mas pra pular, que é uma sprite simples,ele pula normalmente

Hum... Porque geralmente dificilmente a sprite tem relação com erros no movimento... Poderia postar aqui o código de movimento do personagem, ou até mesmo a engine GMK para analisarmos, pode ser algo no código de movimento esquerdo e direito... Verifique também se algum objeto como o chão não está "segurando" ele... Outra pergunta, nem mesmo ao pular, e andar ao mesmo tempo, ele sai do lugar?

Estamos no aguardo.
avatar
Data de inscrição : 07/06/2010
Número de Mensagens : 39
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problema com sprites

em Qua 09 Jun 2010, 15:29
Deu um apagão aqui em casa dai a demora

Ta aqui os scripts:

Movimento das setas:

Código:

if keyboard_check(vk_right)and place_free(x+3,y)
 {
 x+=3; direita=1; caminhando=true; parado=false
 }
 
if keyboard_check(vk_left) and place_free(x-3,y)
 {
 x-=3; direita=0; caminhando=true; parado=false;
 }
 
if keyboard_check_pressed(vk_up) and( not place_free(x,y+1))
 {
 vspeed=-10; chao=false; pulando=true;
 }

Sprites:

Código:

if caminhando=true
  {
  if direita=1
        {
      sprite_index=spr_mariowalkr;
      image_speed=0.3;   
      }
  }
 
if caminhando=true
  {
  if direita=0
    {
      sprite_index=spr_mariowalkl;
      image_speed=0.3;
    }
  }

if parado=true
  {
  if direita=1
    {
      sprite_index=spr_mariostandr;
    }
  }

if parado=true
  {
  if direita=0
    {
      sprite_index=spr_mariostandl;
    }
  }

E collision obj_chao

Código:

move_contact_solid(direction,12)
vspeed=0
hspeed=0

if parado=false and y< other.y
 {
 parado=true
 }

É só
avatar
Data de inscrição : 21/05/2010
Número de Mensagens : 110
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Ver perfil do usuáriohttp://www.orkut.com.br/Main#Profile?uid=12612551030963156921

Re: Problema com sprites

em Qua 09 Jun 2010, 15:38
O código está certo... Deve ser algo na colisão da sprite...
Tem como mandar o arquivo GMK?
avatar
Data de inscrição : 07/06/2010
Número de Mensagens : 39
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problema com sprites

em Qua 09 Jun 2010, 15:51
O jogo não tem nada,eu tava começando ele quando deu o erro.

4shared.com/file/yh-YX6ZN/mario.html
avatar
Data de inscrição : 21/05/2010
Número de Mensagens : 110
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Ver perfil do usuáriohttp://www.orkut.com.br/Main#Profile?uid=12612551030963156921

Re: Problema com sprites

em Qui 10 Jun 2010, 16:31
É está normal o jogo... Não há defeitos, só um pequeno detalhe, quando soltamos o botão (left ou right) ele continua se movendo parado (moonwalker). Coloque uma sprite parada ao soltar botão.

Mas está ficando bom Smile
avatar
Data de inscrição : 07/06/2010
Número de Mensagens : 39
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problema com sprites

em Qui 10 Jun 2010, 21:08
Eu também percebi o erro e já coloquei algo que arrumou, tanto o problema das sub imagens quanto o moonwalker.
Espero colocar para a disposição de vocês o jogo completo em breve.

Valeu!!
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum