Conectar-se
Quem está conectado
17 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 17 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 14/02/2009
Número de Mensagens : 152
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuário

não to conseguindo usar o alarm

em Seg 20 Jul 2009, 14:28
eu to fazendo meu jogo do mario e tem o objeto mario pequeno e o mario grande eu quero que quando eu to com o mario grande e encosto no inimigo ele vira o mario pequeno só que na hora em que ele vira ele fica parado por 3 segundos (só o mario ) e os inimigos continuarem andando normal. mas não ta dando , eu botei assim no evento alarm 0 do objeto mario grande : start move in a direction no quadrado do meio que é parado e na colisão com o inimigo botei esse código

Código:
 alarm[0] = 4*room_speed 
        instance_change(obj_mario_p,true) 
     

mais não tem efeito nehum
avatar
Data de inscrição : 03/08/2008
Número de Mensagens : 1156
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 1
   :
   :
Ver perfil do usuáriohttp://www.ciganospictures.hd1.com.br

Re: não to conseguindo usar o alarm

em Seg 20 Jul 2009, 15:15
É que tipo, ele vai diminuindo o alarm, e o evento acontece quando o alarm chega a zero
avatar
Data de inscrição : 14/02/2009
Número de Mensagens : 152
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: não to conseguindo usar o alarm

em Seg 20 Jul 2009, 16:14
ata eu pensava que ele tinha acção imediata intão eu diminuo para 1 o valor que a ação dele vai ser quase instantania
Conteúdo patrocinado

Re: não to conseguindo usar o alarm

Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum