não to conseguindo usar o alarm

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

não to conseguindo usar o alarm

Mensagem por doug_maker em Seg 20 Jul 2009, 14:28

eu to fazendo meu jogo do mario e tem o objeto mario pequeno e o mario grande eu quero que quando eu to com o mario grande e encosto no inimigo ele vira o mario pequeno só que na hora em que ele vira ele fica parado por 3 segundos (só o mario ) e os inimigos continuarem andando normal. mas não ta dando , eu botei assim no evento alarm 0 do objeto mario grande : start move in a direction no quadrado do meio que é parado e na colisão com o inimigo botei esse código

Código:
 alarm[0] = 4*room_speed 
        instance_change(obj_mario_p,true) 
     

mais não tem efeito nehum

doug_maker

Número de Mensagens : 152
Idade : 26
Data de inscrição : 14/02/2009
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Re: não to conseguindo usar o alarm

Mensagem por Gusba em Seg 20 Jul 2009, 15:15

É que tipo, ele vai diminuindo o alarm, e o evento acontece quando o alarm chega a zero

Gusba

Número de Mensagens : 1156
Idade : 21
Data de inscrição : 03/08/2008
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   :
   :

http://www.ciganospictures.hd1.com.br

Voltar ao Topo Ir em baixo

Re: não to conseguindo usar o alarm

Mensagem por doug_maker em Seg 20 Jul 2009, 16:14

ata eu pensava que ele tinha acção imediata intão eu diminuo para 1 o valor que a ação dele vai ser quase instantania

doug_maker

Número de Mensagens : 152
Idade : 26
Data de inscrição : 14/02/2009
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Re: não to conseguindo usar o alarm

Mensagem por Conteúdo patrocinado Hoje à(s) 22:51


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum