Conectar-se
Quem está conectado
15 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 15 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 18/07/2009
Número de Mensagens : 922
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 2

Prêmios
   :
   :
   :
Ver perfil do usuário

BUILD FAILED?

em Ter 23 Jun 2015, 23:00
Acho que todos sabem o que é essa mensagem de erro, que é quando algo não deu certo, e eu entendi exatamente qual foi o problema que me foi mostrado na seguinte mensagem :

BUILD FAILED
C:\Users\(meu usuário)\AppData\Local\Temp\gm_ttt_59263\gm_ttt_78037\build.xml:83: Cannot find c:\Program Files\Android\android-sdk\tools\ant\build.xml imported from C:\Users\(meu usuário)\AppData\Local\Temp\gm_ttt_59263\gm_ttt_78037\build.xml

Beleza, ele não encontrou o que precisava para terminar de montar a executável. Mas o problema é o seguinte, como faço pra obter exatamente o que ele pede? O que devo instalar precisamente pra resolver esse problema? Porque configurei meu SDK de acordo com um tutorial que vi aqui na GMBR e na hora de montar a executável para android sempre tive problemas, o que me fez instalar tudo tudo mesmo, mas pesa muito o PC a ponto de causar muitos e graves problemas no GM e nem tudo é necessário. Então se puderem me ajudar dizendo o que falta, ficaria muito grato blz
avatar
Data de inscrição : 28/08/2010
Número de Mensagens : 599
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Ter 23 Jun 2015, 23:36
Veja esse tutorial: http://gmbr.forumeiros.com/t27119-tutoinstalando-e-configurando-o-android-para-gms

principalmente o item 2:
2- Depois de ter instalado o Android SDK você terá a opção de iniciar o Android SDK Manager. Você abra. Quando ele abrir, você seleciona os seguintes item: Android SDK Tools Platform, Android 2.1 (API 7), Android 2.2 (API Cool, Android 3.2 (API 13), Android 4.0.3(API 15) e a mais recente.

A pedido do usuário itarodrigo:
Para efetuar o download da API 13, faça o seguinte:

-Vá até a pasta onde instalou o SDK
-Clique com o direito em SDK Manager e execute como administrador
-Quando abrir o programa, marque uma caixa na parte de baixo com o texto 'Obsolete'
-Irá aparecer a API 13 para download
-Na API 13, acho que você deve desmarcar 'Google TV Addon'
-Clique em install, aceite os termos e pronto, você irá instalar a API 13

veja se resolve.

abraço.
avatar
Data de inscrição : 18/07/2009
Número de Mensagens : 922
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 2

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: BUILD FAILED?

em Ter 23 Jun 2015, 23:38
Foi exatamente esse tópico que eu vi e utilizei pra configurar meu SDK, mas vou tentar de novo e já dou EDIT aqui dizendo se deu certo, valeu desde já
avatar
Data de inscrição : 28/08/2010
Número de Mensagens : 599
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Ter 23 Jun 2015, 23:49
veja que é obrigatório ter todas as API listadas, instaladas no seu SDK (7, 13 e 15).

abraço.
avatar
Data de inscrição : 26/12/2012
Número de Mensagens : 152
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 8

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Ter 23 Jun 2015, 23:59
Se seu gms n for original, vai dar esse erro.
isso e erro do gm, se fosse o sdk ia ser xml alguma coisa.
Baixa o game maker denovo
avatar
Data de inscrição : 28/08/2010
Número de Mensagens : 599
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 00:03
Reputação da mensagem: 100% (1 votos)
Cannot find c:\Program Files\Android\android-sdk\tools\ant\build.xml

é xml sim
avatar
Data de inscrição : 26/12/2012
Número de Mensagens : 152
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 8

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 02:23
Agr vi, instala a as apis obsoletas tambem só matcar a opção obsoletes q vai aparecer.
avatar
Data de inscrição : 05/10/2012
Número de Mensagens : 47
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 3
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 08:03
qual a versão do seu gms ?
avatar
Data de inscrição : 18/07/2009
Número de Mensagens : 922
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 2

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 15:02
GMS Professional Edition, e todas as obsoletas pedidas já estavam instaladas, e agora? ._.
avatar
Data de inscrição : 28/08/2010
Número de Mensagens : 599
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 15:10
voce ja viu se esse arquivo existe: c:\Program Files\Android\android-sdk\tools\ant\build.xml
avatar
Data de inscrição : 18/07/2009
Número de Mensagens : 922
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 2

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 15:14
Então, antes de eu instalar o SDK de novo por algum motivo a pasta só ia até android-sdk, mas agora tá aparecendo sim, e fui tentar criar a executável e ele mostrou problema na API 13, tô instalando mais uma vez e vou ver no que dá
avatar
Data de inscrição : 28/08/2010
Número de Mensagens : 599
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 15:16
ve mesmo, talvez voce tenha mudado o diretorio, aí precisa fazer toda a configuracao novamente.
avatar
Data de inscrição : 18/07/2009
Número de Mensagens : 922
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 2

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 16:23
Aí, os problemas foram aparecendo e eu fui resolvendo, mas agora apareceu esse e eu não sei o que fazer com ele :
BUILD FAILED
c:\Program Files\Android\android-sdk\tools\ant\build.xml:649: The following error occurred while executing this line:
c:\Program Files\Android\android-sdk\tools\ant\build.xml:694: null returned: 1

Alguém sabe como resolve isso?
avatar
Data de inscrição : 28/08/2010
Número de Mensagens : 599
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 16:27
se voce quiser que eu acesse seu pc via teamviewer pra tentar resolver isso, me chama por MP
avatar
Data de inscrição : 18/07/2009
Número de Mensagens : 922
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 2

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 17:22
Po amigo, tem certeza que você não sabe como resolve? Porque não acho que seja um problema tão conflitante a ponto disso tlgd.. já pesquisei muito no Google e não tô achando nenhum problema referente a 649 e 694, difícil..
avatar
Data de inscrição : 28/08/2010
Número de Mensagens : 599
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 17:25
esses numeros sao referentes as linhas do arquivo que tem falha, entao existem inumeras possibilidades de falha pra cada uma das linhas.

uma vez acessei o pc de emanuel (usuario daqui tambem mas nao lembro o nick) ele tinha um erro parecido com o seu e era alguns arquivos no sdk do android que faltava e passou despercebido por ele, baixamos e resolveu.

por isso nao é facil de te ajudar sem ver teu pc.
avatar
Data de inscrição : 18/07/2009
Número de Mensagens : 922
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 2

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 17:39
No caso, eu poderia te mandar por MP o trecho que diz estar com erro? Só tem dois problemas, como são ditos 2 números diferentes, quer dizer que o erro tá da linha 649 até a 694 ou em cada uma delas em individual? E o outro problema, como faço pra contar o número das linhas? Porque ir de uma em uma é ossada rs
avatar
Data de inscrição : 28/08/2010
Número de Mensagens : 599
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 17:41
creio que seja apenas as duas linhas, mas creio ainda que deva ser configuração no SDK do android, por isso que o arquivo tá errado.

mas se quiser, pode mandar.
avatar
Data de inscrição : 18/07/2009
Número de Mensagens : 922
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 2

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: BUILD FAILED?

em Qua 24 Jun 2015, 17:46
Pensei num jeito de contar as linhas, jogando o código todo num code de GM Laughing Laughing já mando as linhas pra vc, perae..
Conteúdo patrocinado

Re: BUILD FAILED?

Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum