[Resolvido]Modo debug travando

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[Resolvido]Modo debug travando

Mensagem por Willy em Sex 27 Fev 2015, 13:34

Olá amigos!

Uma das novidades do GMS é a nova ferramenta de debug, muito útil para encontrar trechos de código que consomem muita memória ou processamento. Entretanto, estou com problemas em utilizá-la... Quando rodo o jogo no modo Debug, o desenpenho do jogo cai para 5~10 FPS, tornando o debug praticamente inutilizável. Percebi que quando eu seguro a janela do debug com o mouse (como se fosse arrastar), o jogo funciona normalmente, o que reforça a ideia que o problema é o proprio debug.

Algumas informações básicas:
GMS Professional 1.4.1514
Windows 8.1
4GB RAM
Quadcore i3 2.4GHz

Alguém sabe o que causa essa lentidão?
Aguardo respostas. blz(em especial uma do Kabeção porque sei que ele manja dos paranauê.)

___________


Engines, tutoriais e projetos? Clique no banner!



Atenção:
Comporte-se, senão você vai levar a cintada do Willy no meio da bunda! bravo


Willy

Ranking : Nota A
Número de Mensagens : 1812
Idade : 23
Data de inscrição : 08/06/2009
Notas recebidas : C + B + A + A
Reputação : 245
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 2
   : 1
   : 1

http://willy-gmbr.blogspot.com/

Voltar ao Topo Ir em baixo

Re: [Resolvido]Modo debug travando

Mensagem por chicoweb em Sex 27 Fev 2015, 16:09


Eu não gosto desse windows prefiro o 7.

A sua versão do windows e aquelas limitadas tipo starter, essas porcarias? se for pode ser isso, o desempenho dos programas ficam medíocres nessas versões "starter edition" que tem ai gratuita do windows.

chicoweb

Ranking : Nota C
Número de Mensagens : 666
Idade : 40
Data de inscrição : 15/05/2012
Notas recebidas : B+C
Reputação : 49
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: [Resolvido]Modo debug travando

Mensagem por Willy em Sex 27 Fev 2015, 16:11

Não... Se meu windows fosse do tipo Starter eu já teria colocado um belo XP nele. hehe

___________


Engines, tutoriais e projetos? Clique no banner!



Atenção:
Comporte-se, senão você vai levar a cintada do Willy no meio da bunda! bravo


Willy

Ranking : Nota A
Número de Mensagens : 1812
Idade : 23
Data de inscrição : 08/06/2009
Notas recebidas : C + B + A + A
Reputação : 245
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 2
   : 1
   : 1

http://willy-gmbr.blogspot.com/

Voltar ao Topo Ir em baixo

Re: [Resolvido]Modo debug travando

Mensagem por Kabeção em Seg 02 Mar 2015, 18:43

Já tentou em outro computador?
O jogo não depende em nada do debugger e o mesmo recebe informação de forma dessincronizada com o jogo.
É tipo uma conexão via internet (da até para rodar o jogo no android e conectar com o debugger no Windows).
Essa lentidão não faz sentido.

Kabeção

Ranking : Sem avaliações
Número de Mensagens : 2314
Data de inscrição : 08/06/2008
Reputação : 100
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 3
   : 0
   : 1

http://blackcapapps.blogspot.com.br/

Voltar ao Topo Ir em baixo

Re: [Resolvido]Modo debug travando

Mensagem por Willy em Seg 02 Mar 2015, 20:08

Sim, já tentei. Mandei o source para um amigo e ele testou sem problema algum. Percebi também que a lentidão se aplica a todos os outros projetos.

Minha versão está a algumas atualizações atrás da mais recente. Vou atualizar e ver se muda algo...
Daqui a pouco dou um edit com o resultado.

Vlw! blz

[Edit]
Não funcionou... Desabilitei antivirus, firewall, reiniciei, atualizei... Nada. A única coisa que faltou fazer (penso eu) é resinstalar o GMS. Gravei este vídeo com meu celular para demonstrar o problema:
Vídeo:

[Edit2]
Resolvi... Reinstalando o GMS. --\'

___________


Engines, tutoriais e projetos? Clique no banner!



Atenção:
Comporte-se, senão você vai levar a cintada do Willy no meio da bunda! bravo


Willy

Ranking : Nota A
Número de Mensagens : 1812
Idade : 23
Data de inscrição : 08/06/2009
Notas recebidas : C + B + A + A
Reputação : 245
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 2
   : 1
   : 1

http://willy-gmbr.blogspot.com/

Voltar ao Topo Ir em baixo

Re: [Resolvido]Modo debug travando

Mensagem por Conteúdo patrocinado Hoje à(s) 13:47


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum