Conectar-se

Esqueci minha senha

Últimos assuntos
» colisão de queda após outra colisão dando problema
Ontem à(s) 20:18 por Willy

» [Duvida] O que aprender
Seg 26 Jun 2017, 15:32 por Markituh

» BUILD FAILED: Cannot find BUILD.xml
Seg 26 Jun 2017, 14:50 por ReisBlender

» Nota de esclarecimento - GMBR voltou!
Sex 23 Jun 2017, 20:33 por Willy

» Regras do Fórum
Sex 23 Jun 2017, 19:02 por GMBR

» Retorno da GMBR!!!
Ter 24 Jan 2017, 15:43 por GMBR

» Jogo Dengue HTML
Seg 30 Nov 2015, 16:17 por guga

» Criando IA Simples para inimigos
Qua 25 Nov 2015, 19:22 por DJDAVYD

» Ordenar variavel em ordem decrescente
Sex 28 Ago 2015, 21:09 por Kodained

» Crio Trilha Sonora para Games!
Qui 27 Ago 2015, 13:50 por Isaias Malafaia

» Problema com Colisão
Qui 27 Ago 2015, 12:30 por The_Game

» Quem quer Uma Engine, e de Quê?
Qui 27 Ago 2015, 09:22 por theguitarmester

» [RESOLV]Como adicionar 2 objetos na mesma posição?
Qua 26 Ago 2015, 11:38 por Bhryenno Kelvyn Carlson

» Sistema de porta!!!
Ter 25 Ago 2015, 21:29 por theguitarmester

» Venda de objetos em Inventário - Multiplicado
Seg 24 Ago 2015, 18:33 por AG Hydra

» Atirar na direção certa
Seg 24 Ago 2015, 09:03 por theguitarmester

» Western Duels
Seg 24 Ago 2015, 07:47 por theguitarmester

» Problemas na compilação android
Dom 23 Ago 2015, 23:43 por Zero.

» Dúvida sobre strings, lendo txt
Sab 22 Ago 2015, 20:31 por Pai véi

» Como estabilizar um som
Sab 22 Ago 2015, 19:03 por Isquilo_Roedor

» Janela Modal
Sab 22 Ago 2015, 09:23 por Pai véi

» Sobre instance Creation Code
Sab 22 Ago 2015, 08:39 por Pai véi

» LudumDare #33
Sex 21 Ago 2015, 21:17 por WellingtonBecker

» Como fazer um temporizador
Sex 21 Ago 2015, 19:02 por Isquilo_Roedor

» GMS sempre salva projeto ao compilar?
Sex 21 Ago 2015, 12:32 por Pai véi

Quem está conectado
22 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 22 Visitantes

Nenhum

[ Ver toda a lista ]


O recorde de usuários online foi de 324 em Ter 05 Out 2010, 13:36

[Resolvido] background em surface bugado

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[Resolvido] background em surface bugado

Mensagem por AlexBosquin em Ter 17 Fev 2015, 08:12

Galera é o seguinte eu fiz um surface no create funcionando normal, dai eu fui no draw e usei novamente o set_target e o reset_target, pois meu background precisa mudar de posição o tempo todo:

Código:

surface_set_target(surface);
draw_background(back_littleDuna,view_xview-(view_xview/10),view_yview+135);
surface_reset_target();

funcionou blz, mas quando o personagem anda, o background comporta como se nao tivesse marcado a caixinha draw background color, ou seja fica redesenhando ele no fundo varias vezes, alguém sabe como resolver?


Última edição por AlexBosquin em Ter 17 Fev 2015, 09:49, editado 1 vez(es)
avatar
AlexBosquin

Ranking : Nota C
Notas recebidas : C
Data de inscrição : 10/07/2012
Número de Mensagens : 621
Insígnias de JAM :

Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Prêmios
   : 1
   : 0
   : 0

Ver perfil do usuário http://www.craftstudios.com.br

Voltar ao Topo Ir em baixo

Re: [Resolvido] background em surface bugado

Mensagem por Rodrigo Santiago em Ter 17 Fev 2015, 08:40

Eu simplesmente não entendi porque você usou Surfaces.

Explicando o erro:

Quando você ativa surface, nada é desenhado na tela. É como se você ativasse o desenho na surface e não mais na tela. Quando você reseta volta a desenhar normalmente na tela.
Provavelmente você não deve ter deixado um background na room e por isso ficou tudo confuso.

Resolução:

Eu não entendi muito bem o que você queria fazer mas acho que isso pode resolver. Remova esse negócio de surface e ponha isso dentro de um objeto com 1000000 de delpht.
Código:

draw_background(back_littleDuna,view_xview-(view_xview/10),view_yview);
avatar
Rodrigo Santiago

Ranking : Nota B
Notas recebidas : C + C + B
Data de inscrição : 28/07/2012
Número de Mensagens : 1281
Insígnias de JAM :

Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Prêmios
   : 3
   : 1
   : 3

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: [Resolvido] background em surface bugado

Mensagem por gabrielsch em Ter 17 Fev 2015, 09:06

Até onde eu entendi você só precisar limpar a surface antes de utilizar ela denovo, caso contrario a imagem vai se sobrepondo uma em cima da outra.
Basta utilizar a função draw_clear_alpha(), desse jeito:
Código:
surface_set_target(surface);
draw_clear_alpha(c_black, 0)
draw_background(back_littleDuna,view_xview-(view_xview/10),view_yview+135);
surface_reset_target();
avatar
gabrielsch

Ranking : Nota A
Notas recebidas : D + A + A
Data de inscrição : 06/12/2009
Número de Mensagens : 1229
Insígnias de JAM :

Insignia 1 x 1 Insignia 2 x 0 Insignia 3 x 0

Prêmios
   : 1
   : 2
   : 0

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Re: [Resolvido] background em surface bugado

Mensagem por AlexBosquin em Ter 17 Fev 2015, 09:48

@Rodrigo santiago Mano ñ quero ser arrogante, mas tu conversa comigo parecendo que não sei o que estou fazendo, agradeço pela sua ajuda, mas no caso eu realmente estou precisando usar surfaces pois nesse background que esta aplicado no surface vai usar um SHADER e pra isso eu preciso de surfaces.

@gabrielsch Mano eu ñ sabia disso ;D vlw mesmo resolveu meu problema!!!!!!!! s2 seu lindo +1 rep

Tópico Resolvido
avatar
AlexBosquin

Ranking : Nota C
Notas recebidas : C
Data de inscrição : 10/07/2012
Número de Mensagens : 621
Insígnias de JAM :

Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Prêmios
   : 1
   : 0
   : 0

Ver perfil do usuário http://www.craftstudios.com.br

Voltar ao Topo Ir em baixo

Re: [Resolvido] background em surface bugado

Mensagem por Conteúdo patrocinado


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum