[Resolvido][Dúvida]Construção Automática

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[Resolvido][Dúvida]Construção Automática

Mensagem por Limalokão em Sab 31 Jan 2015, 12:38

Vejam o script abaixo:
auto_montar:

Código:
image_index=0
image_speed=0

leste=place_meeting(x+32,y,object_index)
norte=place_meeting(x,y-32,object_index)
oeste=place_meeting(x-32,y,object_index)
sul=place_meeting(x,y+32,object_index)
lnos=leste && norte && oeste && sul
ls=leste && sul
so=sul && oeste
on=oeste && norte
nl=norte && leste
sn=sul && norte
ol=oeste && leste
lso=leste && sul && oeste
son=sul && oeste && norte
onl=oeste && norte && leste
nls=norte && leste && sul

if leste=true{
    image_index=1
}

if norte=true{
    image_index=4
}

if oeste=true{
    image_index=3
}

if sul=true{
    image_index=2
}

if lnos=true{
    image_index=5
}

if ls=true{
    image_index=6
}

if so=true{
    image_index=7
}

if on=true{
    image_index=8
}

if nl=true{
    image_index=9
}

if sn=true{
    image_index=10
}

if ol=true{
    image_index=11
}

if lso=true{
    image_index=12
}

if son=true{
    image_index=13
}

if onl=true{
    image_index=14
}

if nls=true{
    image_index=15
}

Ele seta a imagem para que forme automaticamente um muro visto de cima. Mas o problema está quando os quatro cantos se encontram, ele não forma a image_index5


e sim a nls vide imagem abaixo:


Será porque o GM só consegue trabalhar com 3 variáveis numa só linha?


Última edição por Soul Limaloko em Sab 31 Jan 2015, 22:23, editado 1 vez(es)

Limalokão

Ranking : Nota C
Número de Mensagens : 803
Idade : 24
Data de inscrição : 24/11/2009
Notas recebidas : C
Reputação : 10
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: [Resolvido][Dúvida]Construção Automática

Mensagem por gabrielsch em Sab 31 Jan 2015, 19:16

Depois de definir o image_index tente usar o exit logo  depois para interromper o script, isso deve resolver.

___________


Acesse: http://foxen.com.br/



gabrielsch

Ranking : Nota A
Número de Mensagens : 1229
Idade : 21
Data de inscrição : 06/12/2009
Notas recebidas : D + A + A
Reputação : 28
Insignia 1 x 1 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 2
   : 0

Voltar ao Topo Ir em baixo

Re: [Resolvido][Dúvida]Construção Automática

Mensagem por Limalokão em Sab 31 Jan 2015, 21:00

gabrielsch escreveu:Depois de definir o image_index tente usar o exit logo  depois para interromper o script, isso deve resolver.

Coloquei apenas no lnos, aí resolveu! Obrigado!

Limalokão

Ranking : Nota C
Número de Mensagens : 803
Idade : 24
Data de inscrição : 24/11/2009
Notas recebidas : C
Reputação : 10
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: [Resolvido][Dúvida]Construção Automática

Mensagem por Conteúdo patrocinado Hoje à(s) 14:24


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum