Conectar-se
Quem está conectado
27 usuários online :: 1 usuário cadastrado, Nenhum Invisível e 26 Visitantes

Willy

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota C
Notas recebidas : C + C
Data de inscrição : 19/10/2011
Número de Mensagens : 337
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 9

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

[Resolvido] Bug com a DS_LIST

em Sab 25 Out 2014, 20:00
Basicamente, o código é esse:
Código:
for (i = 0; i <= ds_list_size(list)-1; i += 1) {
  (ds_list_find_value(list, i)).image_index = 5;
}
Usando:
Código:
for (i = 0; i < ds_list_size(list); i += 1) {
  (ds_list_find_value(list, i)).image_index = 5;
}
Da na mesma.

Tanto no Game Maker 8.0, quanto no Game Maker Studio, AS VEZES,1 vez a cada 20 vezes que o codigo é repetido, lembrando que toda vez que esse codigo é criado, ele exclui a lista anterior, e cria uma nova, e sim, o esta organizado da maneira correta.
O mais estranho que isso só acontece quando o programa quer.

Eis o erro: "Data structure with index does not exist.".
Seria basicamente, de que o Index não existe, mas os indexs que eu requisitei foram apenas indexs existentes, sendo que eu utilizei o DS_LIST_SIZE para isso.
Mas... não foi bem assim. Alguém sabe porque isso acontece, ou alguma forma de contornar isso? É algum bug do programa? Eu duvido muito, sendo que tanto no 8.0 quanto na versão mais nova do Studio isso aconteceu.

Obrigado.

EDIT:
Criar uma variavel que tem seu valor aumentado em 1 depois de cada DS_LIST_ADD, não resolveu, isso me leva a conclusão de que o problema, ou está no FOR (mesmo utilizando de maneira correta)
Ou está no Game Maker mesmo, se tratando de um Bug.


Última edição por Black Studio em Dom 26 Out 2014, 00:34, editado 1 vez(es)
avatar
Ranking : Sem avaliações
Data de inscrição : 08/06/2008
Número de Mensagens : 2314
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 100

Prêmios
   : 3
   : 0
   : 1
Ver perfil do usuáriohttp://blackcapapps.blogspot.com.br/

Re: [Resolvido] Bug com a DS_LIST

em Sab 25 Out 2014, 21:47
Data structure with index does not exist.
O index que esse erro se refere é a própria ds list, ou seja, a própria lista não existe.
avatar
Ranking : Nota C
Notas recebidas : C + C
Data de inscrição : 19/10/2011
Número de Mensagens : 337
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 9

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

Re: [Resolvido] Bug com a DS_LIST

em Sab 25 Out 2014, 22:03
Kabeção escreveu:
Data structure with index does not exist.
O index que esse erro se refere é a própria ds list, ou seja, a própria lista não existe.

Código:
if (list != -1) { //Se existe uma lista, destroi
  ds_list_destroy(list); //Destroi a lista anterior
}

//E então cria uma nova
list = mp_grid_path_series(MPgrid,x,y,mouse_x,mouse_y,obj_waypoint,obj_solid); //Script (nao é uma funcao, obviamente :v)

//muda a imagem
with (obj_bolinhas) {
  image_index = 0;
}

//e depois muda a imagem dos selecionados (pelo mp_grid_path_series)
for (i = 0; i <= ds_list_size(list)-1; i += 1) {
  (ds_list_find_value(list, i)).image_index = 1;
}

Bem, a lista foi criada antes de pegar os valores, logo no mesmo event, então acho que não é isso.
O mais estranho é que isso só acontece quando o GM quer, então parece que o Script falha as vezes, e não executa sem razão alguma.
avatar
Ranking : Nota B
Notas recebidas : D+B+B+C+A
Data de inscrição : 24/08/2009
Número de Mensagens : 1092
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 31

Prêmios
   : 1
   : 1
   :
Ver perfil do usuário

Re: [Resolvido] Bug com a DS_LIST

em Sab 25 Out 2014, 22:07
amigo posso estar errado mas não seria
if (list != -4) { //Se existe uma lista, destroi
ou
if (list != noone) { //Se existe uma lista, destroi

lembrando que noone= -4

avatar
Ranking : Nota C
Notas recebidas : C + C
Data de inscrição : 19/10/2011
Número de Mensagens : 337
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 9

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

Re: [Resolvido] Bug com a DS_LIST

em Sab 25 Out 2014, 22:12
Thyago escreveu:amigo posso estar errado mas não seria
if (list != -4) { //Se existe uma lista, destroi
ou
if (list != noone) { //Se existe uma lista, destroi

lembrando que noone= -4


Faz sentido, mas agora toda primeira lista criada da erro, e se eu ignorar, algumas listas aleatórias ainda continuam a dar erro, e é o mesmo erro.
avatar
Ranking : Sem avaliações
Data de inscrição : 08/06/2008
Número de Mensagens : 2314
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 100

Prêmios
   : 3
   : 0
   : 1
Ver perfil do usuáriohttp://blackcapapps.blogspot.com.br/

Re: [Resolvido] Bug com a DS_LIST

em Sab 25 Out 2014, 23:34
O erro é sempre o que diz.

if (list != -1) { //Se existe uma lista, destroi
 ds_list_destroy(list); //Destroi a lista anterior
}

A lista que está tentando destruir não existe.
O valor da variável list e a ds_list existir ou não são coisas totalmente diferentes.

Código:
if ds_exists(list, ds_type_list) {
 ds_list_destroy(list);
}
avatar
Ranking : Nota C
Notas recebidas : C + C
Data de inscrição : 19/10/2011
Número de Mensagens : 337
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 9

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

Re: [Resolvido] Bug com a DS_LIST

em Sab 25 Out 2014, 23:53
Acho que agora está destruindo corretamente, porém, ainda está dando o erro que eu mencionei acima.
Ele é meio que aleatório, só acontece quando o GM quer :v

Eis a mensagem de erro completa:
Error Message:

___________________________________________
############################################################################################
ERROR in
action number 1
of Mouse Event for Glob Right Pressed
for object obj_dummie:

Data structure with index does not exist.
at gml_Object_obj_dummie_GlobalRightButtonPressed_1 (line 20) - for (i = 0; i <= ds_list_size(wplist)-1; i += 1) {
############################################################################################

E eis o codigo completo
Código:
if (ds_exists(wplist,ds_type_list)) {
  ds_list_destroy(wplist);
}

wplist = mp_grid_path_series(MPgrid,x,y,mouse_x,mouse_y,obj_waypoint,obj_solid);

with (obj_waypoint) {
  image_index = 0;
}

for (i = 0; i <= ds_list_size(wplist)-1; i += 1) {
  (ds_list_find_value(wplist, i)).image_index = 1;
}

Eu realmente não faço a minima ideia do que esta acontecendo, principalmente porque isso só acontece de vez em quando. Se eu não conseguir solucionar isso rápido, vou perder um bom tempo no CQ. D'=
avatar
Ranking : Sem avaliações
Data de inscrição : 08/06/2008
Número de Mensagens : 2314
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 100

Prêmios
   : 3
   : 0
   : 1
Ver perfil do usuáriohttp://blackcapapps.blogspot.com.br/

Re: [Resolvido] Bug com a DS_LIST

em Dom 26 Out 2014, 00:08
O que tem em mp_grid_path_series?
avatar
Ranking : Nota C
Notas recebidas : C + C
Data de inscrição : 19/10/2011
Número de Mensagens : 337
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 9

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

Re: [Resolvido] Bug com a DS_LIST

em Dom 26 Out 2014, 00:17
É um script de Pathfinding usando Waypoints criado pelo Fede-lasse (Membro da GMC americana).
Código:
/*
mp_grid_path_series(id,xstart,ystart,xgoal,ygoal,obj,blockobj)
Returns a ds_list which contains a series of instances of obj, that should lead any object (Starting at xstart,ystart) towards xgoal,ygoal using the instances addressed in the list.
Returns -1 on error.

id = Motion planning grid
xstart,ystart = Start coordinates
xgoal,ygoal = Destination coordinates
obj = Object to use as "waypoints"
blockobj = The block/wall object in your game

Script by Fede-lasse
*/
var idd,xxstart,yystart,xgoal,ygoal,obj,blockobj,path,list,curinst;
idd = real(argument0);
xxstart = real(argument1);
yystart = real(argument2);
xgoal = real(argument3);
ygoal = real(argument4);
obj = real(argument5);
blockobj = real(argument6);

path = path_add();
list = ds_list_create();

if (mp_grid_path(idd,path,xxstart,yystart,xgoal,ygoal,1)) {
  curinst = instance_nearest(path_get_point_x(path,0),path_get_point_y(path,0),obj);
  for (i=1; i<path_get_number(path); i+=1) {
    if (ds_list_find_index(list,curinst) == -1 && collision_line(curinst.x,curinst.y,path_get_point_x(path,i),path_get_point_y(path,i),blockobj,1,1) == noone) {
      ds_list_add(list,curinst);
      list_size+=1
    }
    curinst = instance_nearest(path_get_point_x(path,i),path_get_point_y(path,i),obj);
  }
} else {
  ds_list_destroy(list);
  list = -1;
}

path_delete(path);

return (list);

Ah, lembrando que outra alternativa para contornar esse problema, seria um outro script de Pathfinding a base de Waypoints. Minha prioridade não é arrumar o script, mas sim conseguir usar um sistema de Waypoints bom o suficiente, nesse caso esse foi o melhor que eu achei, mas se você tiver conhecimento de um que funcione no GMS, deixe-me saber por favor. Happy
avatar
Ranking : Sem avaliações
Data de inscrição : 08/06/2008
Número de Mensagens : 2314
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 100

Prêmios
   : 3
   : 0
   : 1
Ver perfil do usuáriohttp://blackcapapps.blogspot.com.br/

Re: [Resolvido] Bug com a DS_LIST

em Dom 26 Out 2014, 00:25
Esse script tem a chance de destruir a lista assim como as ultimas linhas mostram.
Retorna -1 porque é normalmente isso que se retorna no GM quando não foi possível realizar algo.

Você devia chegar que a lista existe ante de usar o loop for.
avatar
Ranking : Nota C
Notas recebidas : C + C
Data de inscrição : 19/10/2011
Número de Mensagens : 337
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 9

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

Re: [Resolvido] Bug com a DS_LIST

em Dom 26 Out 2014, 00:33
Kabeção escreveu:Esse script tem a chance de destruir a lista assim como as ultimas linhas mostram.
Retorna -1 porque é normalmente isso que se retorna no GM quando não foi possível realizar algo.

Você devia chegar que a lista existe ante de usar o loop for.

Omg, como não vi isso!? Anyway, obrigado man! Isso explica porque era "aleatório".
Testei aqui diversas vezes, tem alguns bugs ainda mas pelo menos nao está mais dando erro, Muito obrigado de novo. e podem fechar o tópico!
Conteúdo patrocinado

Re: [Resolvido] Bug com a DS_LIST

Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum