Problema com a sprite

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Problema com a sprite

Mensagem por AxeInLine em Dom 20 Jul 2014, 22:19

Boa dia, boa tarde ou boa noite;
O meu problema(ou duvida) é o seguinte: Eu crio minhas sprites no Adobe Illustrator e as animo no Adobe Flash, para não perder muito tempo cuidando de subimagens, eu salvo a sprite como .swf, depois somente importo para o GM:S. Mas acontece que, pela primeira vez, quando eu importei uma sprite que fiz hoje, ela ficou pixelada, bem diferente do o que eu havia exportado do Flash, o ruim é que não sei nada sobre a extensão .swf no GM, então não consegui arrumar isso.
Essas são as animações:
, dois não estão animados.

À também uma mensagem que aparece assim que eu importo as animações:
Bem, não sei se eu exportei errado, ou o meu GM está com problemas, mas pelo visto, só sei que está ocorrendo alguma coisa, caso alguém saiba sobre isso e possa me explicar, ficarei grato.
Obs: Esse não é o unico .SWF de sprites, por isso achei estranho.



Última edição por AxeInLine em Seg 21 Jul 2014, 22:54, editado 1 vez(es)

AxeInLine

Número de Mensagens : 211
Idade : 14
Data de inscrição : 23/03/2014
Reputação : 40
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: Problema com a sprite

Mensagem por 7hiagomp em Dom 20 Jul 2014, 22:22

AxeInLine escreveu:
À também uma mensagem que aparece assim que eu importo as animações:

A tradução da mensagem é;
recursos não suportados detectados em;
c:\ etc etc
(pode não ser exibido propriamente)
- modos de "multiplicação" que não "normal"


Blend modes (modos de combinação/mistura) são efeitos relacionados ao modo como a imagem se "multiplica" com as imagens abaixo.  São efeitos como por exemplo glow, multiply, drop shadow, entre outros.  Tente transformar seus objetos no flash em blend mode normal e voltar a importar para ver se o problema permance.


Última edição por 7hiagomp em Ter 22 Jul 2014, 00:52, editado 2 vez(es)

7hiagomp

Número de Mensagens : 124
Idade : 31
Data de inscrição : 21/04/2014
Reputação : 24
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: Problema com a sprite

Mensagem por AxeInLine em Seg 21 Jul 2014, 23:03

Bem, andei pesquisando um pouco sobre o formato ".swf" no GMS, e arranjei o que poderia ser a resposta para esse meu problema, o ponto ruim é que não é solução.
Achei no site da YoYo Games isso, caso alguém queira ver: Link.
O ruim é que é inglês, então de uma forma traduzida ficaria:
James Foreman escreveu:Sprites Vector contornar essas limitações, armazenando e desenhar os seus conteúdos de forma diferente. Em vez de uma grade de pixels, o que pode tornar-se em blocos ou difusa quando dimensionado, eles são desenhados como triângulos que podem ser ampliados sem perder definição. Aqui está uma comparação (bitmap à esquerda, vetor à direita):

Esta imagem mostra os triângulos que realmente estão sendo desenhadas em sprite vetor acima:

Acho que desse trecho dá para entender um pouquinho o que eu quero dizer, só achei estranho que isso só tenha acontecido com só essa mesmo, o geito vai ser usar o formato ".png" em vez de ".swf".
//edit:
O ruim de usar ''.png'' é que a sprite fica com um contorno escuro que não desenhei, mas só as vezes ele aparece '-'

AxeInLine

Número de Mensagens : 211
Idade : 14
Data de inscrição : 23/03/2014
Reputação : 40
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: Problema com a sprite

Mensagem por Conteúdo patrocinado Hoje à(s) 04:05


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum