Conectar-se
Quem está conectado
34 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 34 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota A
Notas recebidas : A
Data de inscrição : 25/02/2012
Número de Mensagens : 359
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 15

Prêmios
   : 0
   : 1
   : 1
Ver perfil do usuário

Game Maker 8 vx Game Maker Studio[BUG?]

em Qui 19 Jun 2014, 19:30
Eae galera fazendo testes para desenvolver um aplicativo e me deparei com um bug que não identifico to a tres dias congelado nesse bug,

tenho o seguinte script

Código:
yy=argument1;

for(i=1;i<=12;i+=1){

  //-- Retangulos
  draw_set_alpha(.3);
  draw_roundrect_color(argument0-6,yy-6,argument2+25,yy+string_height_ext(texto[1,i],-1,argument2)+3,1,1,0);//Interior
  draw_set_alpha(.7);
  draw_roundrect_color(argument0-6,yy-6,argument2+25,yy+string_height_ext(texto[1,i],-1,argument2)+3,1,1,1);//Borda
  draw_set_alpha(1);
 
  //-- Texto
  draw_text_ext(argument0,yy,string(i)+"- "+string(texto[1,i])+" -",-1,argument2);
 
  //-- Alinhamento yy
  yy+=string_height_ext(texto[1,i],-1,argument2);
 
  //-- Botões
  //draw_sprite(sprite0,image_index,argument0+25,yy+20)
  yy+=43;
};//fim for

esse script desenhara frases na tela uma abaixo a outra e um retangulo em baixo do texto de cada frase, o problema é que quando executo ele no game maker studio(1.3)  ele fica executando por alguns segundos e da erro de aplicacao e fecha a janela, ja no game maker 8 ele funciona perfeitamente sem travar a janela do compilador.
Eu preciso compilar com o game maker studio pois ao final ele sera exprtado para mobile.

Alguem sabe me explicar o por que desse travamento no compilador?
Sera erro de logica ou sinntaxe ou sera erro do proprio game maker?

OBS: esse script é chamado no evento draw, e ah outro script que é chamado no evento create que le as frases de um INI e salva as frases na array.
Aguardo ajuda, Obrigado!
avatar
Data de inscrição : 19/06/2014
Número de Mensagens : 4
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuário

Tenta isso.

em Qui 19 Jun 2014, 23:06
Código:

yy=argument1;
arg[0] = argument0;
arg[2] = argument2;

for(i=1;i<=12;i+=1){

  //-- Retangulos
  draw_set_alpha(.3);
  draw_roundrect_color(arg[0]-6,yy-6,arg[2]+25,yy+string_height_ext(texto[1,i],-1,arg[2])+3,1,1,0);//Interior
  draw_set_alpha(.7);
  draw_roundrect_color(arg[0]-6,yy-6,arg[2]+25,yy+string_height_ext(texto[1,i],-1,arg[2])+3,1,1,1);//Borda
  draw_set_alpha(1);
  
  //-- Texto
  draw_text_ext(arg[0],yy,string(i)+"- "+string(texto[1,i])+" -",-1,arg[2]);
  
  //-- Alinhamento yy
  yy+=string_height_ext(texto[1,i],-1,arg[2]);
  
  //-- Botões
  //draw_sprite(sprite0,image_index,arg[0]+25,yy+20)
  yy+=43;
};//fim for


Tenta o código acima e vê se funciona.
Eu estou tendo alguns problemas com as variáveis argument (argument0, argument1...) em determinadas construções que utilizam o  "for" e o "with" nas novas versões do GM 1.3x

Um grande abraço,

Ednei
avatar
Ranking : Nota A
Notas recebidas : A
Data de inscrição : 25/02/2012
Número de Mensagens : 359
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 15

Prêmios
   : 0
   : 1
   : 1
Ver perfil do usuário

Re: Game Maker 8 vx Game Maker Studio[BUG?]

em Sex 20 Jun 2014, 18:30
Continuou o mesmo problema, o jogo abre roda alguns segundos (2 ou 3) e trava, as veze mal abre e ja trava.
Agradeço a tentativa mas ainda não sei qual é o problema ://

Topico em aberto
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum