Conectar-se
Quem está conectado
32 usuários online :: 4 usuários cadastrados, Nenhum Invisível e 28 Visitantes

CRP-Max, gart30, J. Marlon, Tedi Ripper

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 10/06/2009
Número de Mensagens : 3
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Ver perfil do usuário

Não compila

em Qua 10 Jun 2009, 17:35
Olá pessoal sou novo aqui, sou professor de informática e estou com um problema que não consigo resolver, eu crio um jogo no GM 7, e quando vou "rodar" ele mostra um problema de resolução. O que pode ser? Se puderem me ajudar eu agradeço.
avatar
Ranking : Nota C
Notas recebidas : C - C
Data de inscrição : 14/11/2008
Número de Mensagens : 1166
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuáriohttp://www.programaCODM.webs.com/

Re: Não compila

em Qua 10 Jun 2009, 19:01
como assim... tem como você descrever o erro???

copie o erro que aparece e nós te ajudaremos melhor Happy

Keké Games©
avatar
Data de inscrição : 03/08/2008
Número de Mensagens : 1156
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 1
   :
   :
Ver perfil do usuáriohttp://www.ciganospictures.hd1.com.br

Re: Não compila

em Qua 10 Jun 2009, 19:02
o problema pode se a resolução né ? ¬¬, aumenta ou diminui aa resolução de sua sreen e tente rodar o jogo
avatar
Data de inscrição : 26/09/2008
Número de Mensagens : 890
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: Não compila

em Qua 10 Jun 2009, 20:50
Às vezes, quando alguma coisa no GM não está funcionando, re-instalar resolve o problema. Ou talvez o computador não tem algum dispositivo (ou coisa do tipo) que é necessário para os jogos feitos no GM rodarem...
avatar
Ranking : Nota D
Notas recebidas : D
Data de inscrição : 29/03/2009
Número de Mensagens : 927
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   :
   : 1
   :
Ver perfil do usuário

Re: Não compila

em Qua 10 Jun 2009, 20:52
mentira eu tenho o gm e sempre dá este problema basta ou você mudar a resolução ou passar os graficos de 32-bits para 12-bits (ou virse-versa)
avatar
Ranking : Sem avaliações
Data de inscrição : 08/06/2008
Número de Mensagens : 2314
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 3
   : 0
   : 1
Ver perfil do usuáriohttp://blackcapapps.blogspot.com.br/

Re: Não compila

em Qui 11 Jun 2009, 14:14
Resolução minina para o GM é 800x600 e 16-bits de cores.
avatar
Data de inscrição : 10/06/2009
Número de Mensagens : 3
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Ver perfil do usuário

Re: Não compila

em Sex 12 Jun 2009, 08:31
o erro é esse:

Failed to initialize drawing surfaces. Please check that your graphics card meets the minimum requeriments and that your drivers are up-to-date. If your graphics card has little memory, try switching your computer to a lower resolution.

Só que eu já fiz tudo isso, conferi, mudei a resolução, fiz atualização, mas continua do mesmo jeito.
avatar
Data de inscrição : 03/08/2008
Número de Mensagens : 1053
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Não compila

em Sex 12 Jun 2009, 10:19
O problema pode ser o Direct X, baixe o 9.0c, ou o 9.0a, ou qualquer um 9.0, pode resolver o problema, ou talvez o problema seja a placa de video...
avatar
Ranking : Nota D
Notas recebidas : D
Data de inscrição : 29/03/2009
Número de Mensagens : 927
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   :
   : 1
   :
Ver perfil do usuário

Re: Não compila

em Sex 12 Jun 2009, 12:02
esse é o mesmo erro meu
e o que eu fali funsiona comigo Very Happy ...
avatar
Data de inscrição : 10/06/2009
Número de Mensagens : 3
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Ver perfil do usuário

Re: Não compila

em Sex 12 Jun 2009, 16:31
Já fiz isso també e continua a mesma coisa, já instalei outra versão do java, microsoft framework, direct x9.0, ja mudei a resolução também. Já naum sei nem o que fazer mais, inclusive já testei em outros micros e faz a msm coisa.
avatar
Data de inscrição : 01/06/2008
Número de Mensagens : 1015
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   :
   :
   :
Ver perfil do usuáriohttp://supermariobrasileiro.blogspot.com

Re: Não compila

em Sab 13 Jun 2009, 10:37
Tente usar a versão 5.3 do Game Maker. Ela dá menos erros se tratando dessas coisas.
avatar
Data de inscrição : 23/09/2008
Número de Mensagens : 151
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   :
   :
   :
Ver perfil do usuáriohttp://adf.ly/IvuGb

Re: Não compila

em Sab 13 Jun 2009, 21:04
Acabou de instalar, ou ja tinha instalado a' algum tempo? Podia ser de algum programa qe tivesse instalado..
Se isso so' aconteceu agora tente restauro do sistema.
avatar
Data de inscrição : 03/01/2009
Número de Mensagens : 377
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Ver perfil do usuário

Re: Não compila

em Sab 20 Jun 2009, 21:09
O que eu já passei de raiva no Game Maker... Amigo, seu problema é relacionado à vídeo. Essa mensagem normalmente ocorre quando:

1 - O "tamanho" da memória RAM alocado para o vídeo é demasiado pequeno.
2 - Se você estiver usando versões do Windows fora da família NT.
3 - Sua placa de vídeo não suporta algum recurso do DirectX. Faça os testes do DirectX, com o Direct3D e o DirectDraw... Abra a caixa de executar e digite sem aspas "dxdiag.exe". Execute. A janela que abrirá possui todos os recursos de diagnóstico e teste.
4 - Versões do Game Maker posteriores à 6 não rodam em resoluções de vídeo muito grandes. As versões do Game Maker 4 funcionam em qualquer resolução de vídeo pois usam o DirectDraw de forma bem mais simples. A versão 5 talvez funcione também.

Esse usuário tevem um problema parecido, pode ser que resolva:

http://gmbr.forumeiros.com/perguntas-respostas-f8/error-do-nada-t2945.htm

Boa sorte.

------------ Editado ------------

Acabei de me lembrar de outra coisa... Eu tive esse problema certa vez quando usava uma placa de vídeo mais potente. Na verdade, a placa usava recursos OpenGl e não o Direct3D. Em todo caso, eu mexi nas configurações da placa e funcionou. Isso varia muito de placa pra placa...
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum