Conectar-se
Quem está conectado
13 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 13 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
Ranking : Nota D
Notas recebidas : D
Data de inscrição : 13/05/2012
Número de Mensagens : 275
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 4
Ver perfil do usuáriohttp://www.legioncrafters.tk

.ini não aparece

em Qua 01 Jan 2014, 02:07
Eai,
Eu comecei a mexer com esses arquivos .ini a pouco tempo e já não sei oque está acontecendo, tudo sai como esperado, aparentemente as variáveis são salvas e carregadas normalmente mas o arquivo.ini não está na pasta do jogo.
Eu estou usando o GMStudio e compilei o jogo como "Compressed .zip" executo ele numa pasta na área de trabalho e o arquivo simplesmente não aparece, ja usei o debug pra ver se ele realmente existia, assim: file_exists(working_directory + "save.ini") retornou 1.
Também eu já procurei ele no disco C: não achei, simplesmente ele não existe, mas o game maker age normalmente, vou deixar os códigos que eu usei para vocês verem se tem algo de errado.

Código:

//RELEASE SHIFT:
ini_open(working_directory + "save.ini");
ini_write_real("general","playerx",x);
ini_write_real("general","playery",y);
ini_close();
show_message("Data Saved");

//RELEASE SPACE:
ini_open(working_directory + "save.ini");
x = ini_read_real("general","playerx",0);
y = ini_read_real("general","playery",0);
ini_close();
show_message("Data Loaded");

Será que tem algo a ver com a menssagem que tem no manual?
WARNING! These functions may not work as you expect due to GameMaker:Studio being sandboxed! Please see the section on File System Limits for more information.

Acho que ja tentei tudo não encontro esse arquivo!!
Vlw quem puder me ajudar, feliz ano novo! computador 
avatar
Data de inscrição : 19/09/2013
Número de Mensagens : 190
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 22
Ver perfil do usuário

Re: .ini não aparece

em Qua 01 Jan 2014, 02:12
Reputação da mensagem: 100% (1 votos)
Cara o game maker: studio ele esconde o arquivo .ini para que ninguem modifique ele(trapacear no jogo).

flw
Ranking : Nota D
Notas recebidas : D
Data de inscrição : 13/05/2012
Número de Mensagens : 275
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 4
Ver perfil do usuáriohttp://www.legioncrafters.tk

Re: .ini não aparece

em Qua 01 Jan 2014, 02:15
Isso é sério? kkk passei um tempão tentando saber oque havia de errado ¬¬ fui trollado. Mas tem algum jeito de fazer ele aparecer? nas configurações talvez? vou ver se acho algo eu queria ver ele kk.

Edit:
Encontrei onde eles estão: User\AppData\Roaming\jogo
é estranho mesmo eu colocando working_directory ele foi pra esse lugar.
Eu tentei várias vezes, ai tinha lá vários arquivos interessante que o que eu estava usando ainda tava lá como .ini mas os outros antigos estavam com outro formato, nem dizia, dizia só "arquivo" parece que o prórpio GMStudio encripta os .ini sei lá.
Vlw a ajuda ai : D
Ranking : Nota C
Notas recebidas : C+B
Data de inscrição : 26/07/2008
Número de Mensagens : 6037
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 288

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: .ini não aparece

em Qua 01 Jan 2014, 12:27
working_directory + "save.ini"

Está errado. Faltou uma barra invertida:

working_directory + "\save.ini"

O mesmo para os outros paths no código.
Ranking : Nota D
Notas recebidas : D
Data de inscrição : 13/05/2012
Número de Mensagens : 275
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 4
Ver perfil do usuáriohttp://www.legioncrafters.tk

Re: .ini não aparece

em Qua 01 Jan 2014, 14:19
PedroX escreveu:working_directory + "save.ini"

Está errado. Faltou uma barra invertida:

working_directory + "\save.ini"

O mesmo para os outros paths no código.

Mas o working_directory já não retorna com a barra no final do path?

No GMStudio, la do global game settings tem "Save Data location" ai tem duas opções "AppData" "localAppData" isso é muito ruim ele obriga a salvar os arquivos todos nesse local, mas por exemplo eu quero fazer meu jogo numa pasta com as dll's e um arquivo .ini com as configurações de resolução, mas não posso porque os arquivos tem que ficar, obrigatoriamente, nesse appdata, ai fica totalmente separado.
avatar
Data de inscrição : 29/12/2013
Número de Mensagens : 56
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 1
Ver perfil do usuário

Re: .ini não aparece

em Qui 02 Jan 2014, 14:28
Você pode incluir como "external files" em seu projeto
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum