Conectar-se
Quem está conectado
30 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 30 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota A
Notas recebidas : B A
Data de inscrição : 20/12/2008
Número de Mensagens : 2516
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 177

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://redscreensoft.blogspot.com

Problema com código de movimentação...

em Ter 12 Maio 2009, 20:29
Eai pessoal!!! Fiz um código de movimentação para a esquerda:

Código:
if place_free(x-5,y){hspeed=-5}

Mas esse código faz com que ele não trave em nenhum objeto inclusive os não-sólidos. Eu queria que realizasse esse código somente para os sólidos. Eu sei fazer em Drag&Drop, mas eu queria saber como faz em GML. Tem jeito?


Very thanks!

FLWS!
avatar
Ranking : Nota B
Notas recebidas : B-C-A-C
Data de inscrição : 18/09/2008
Número de Mensagens : 2490
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 1 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 2
   : 1
Ver perfil do usuáriohttp://xcreatorgames.weebly.com/

Re: Problema com código de movimentação...

em Ter 12 Maio 2009, 21:19
O place_free() só retorna true se ele "esbarrar" em uma instancia que esteja na lista de colisão. Pelo help do GM ele já deveria estar funcionando apenas para os sólidos.
avatar
Data de inscrição : 03/08/2008
Número de Mensagens : 1156
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 1
   :
   :
Ver perfil do usuáriohttp://www.ciganospictures.hd1.com.br

Re: Problema com código de movimentação...

em Ter 12 Maio 2009, 21:20
ele funciona apenas para o solidos sim, vc deve estar enganado na hora de configurar o objeto
avatar
Ranking : Nota A
Notas recebidas : B A
Data de inscrição : 20/12/2008
Número de Mensagens : 2516
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 177

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://redscreensoft.blogspot.com

Re: Problema com código de movimentação...

em Ter 12 Maio 2009, 21:31
é porque estou com um projeto onde o personagem pega moedas igual o Mario, ai eu passei para o Fokão e ele disse que estava travando na hora de pegar essas moedas e outros objetos na fase, mas aqui não trava esse é o problema!

Desculpa não ter colocado isso!


FLWS!
avatar
Data de inscrição : 03/08/2008
Número de Mensagens : 1156
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 1
   :
   :
Ver perfil do usuáriohttp://www.ciganospictures.hd1.com.br

Re: Problema com código de movimentação...

em Ter 12 Maio 2009, 21:36
sei lah se intendi, mas se ker captar encontros sem serem solidos, pode usar place_meeting
avatar
Ranking : Nota A
Notas recebidas : B A
Data de inscrição : 20/12/2008
Número de Mensagens : 2516
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 177

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://redscreensoft.blogspot.com

Re: Problema com código de movimentação...

em Ter 12 Maio 2009, 21:41
Esta certo então... Acho q o GM do Fokão esta com problemas! Valeu pela atenção e desculpa qualquer coisa....

FLWS!
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum