Problema com quadros de imagem.[RESOLVIDO]

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Problema com quadros de imagem.[RESOLVIDO]

Mensagem por Lukbebalduke em Dom 27 Out 2013, 07:57

Olá pessoal, estou com seguinte problema; Meu personagem não mostra todos os frames na sprite, a sprite tem 6 frames e ele só mostra 2. Verifiquei no debug e percebi que o image_index quando chega em 1.999999... vai direto para 0 de novo. O estranho é que não mecho com a variável image_index em momento algum. Deem uma olhada no código:

Spoiler:

Código:
Information about object: obj_soldado1
Sprite: spr_soldado1_and
Solid: true
Visible: true
Depth: 0
Persistent: false
Parent: obj_soldado_alpha
Mask: spr_mask_soldier

Create Event:

execute code:

//FICHA
vida=100
ataq=21
velo=4
//FICHA
sprite = spr_soldado1_and;
image_speed=0.3;
hspeed=velo;
estado=1; // 1- Andando // 0- Parado // 2- Atacando // 3- Morrendo

Step Event:

execute code:

if place_free(x+1,y)
estado=1;
if place_meeting(x+1,y,obj_soldado_alpha)
estado=0;
if place_meeting(x+1,y,obj_soldado_beta)
estado=2;
//--    --  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --  --
if estado=1{
hspeed=velo
sprite=(spr_soldado1_and)
};
if estado=0{
hspeed=0
sprite=(spr_soldado1_par)
};
if estado=2{
hspeed=0
sprite=(spr_soldado1_ata)
};

Draw Event:

execute code:

draw_sprite(sprite,image_index,x,y);
draw_sprite(spr_alpha_bar,image_index,x,y-180);


Obrigado.


Última edição por pinpi em Dom 27 Out 2013, 18:48, editado 1 vez(es)

Lukbebalduke

Ranking : Nota B
Número de Mensagens : 764
Data de inscrição : 06/07/2011
Notas recebidas : B - B - A - B
Reputação : 30
Insignia 1 x 1 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 2

Voltar ao Topo Ir em baixo

Re: Problema com quadros de imagem.[RESOLVIDO]

Mensagem por Gabreel em Dom 27 Out 2013, 18:15

Solução:
sprite_index = sprite no fim do seu step.

Quando vc dá draw_sprite(sprite,image_index [..] a imagem_index que ele usa é a da sprite index, e não do sprite que está sendo desenhado. Razz

Gabreel

Número de Mensagens : 2227
Idade : 20
Data de inscrição : 02/10/2009
Reputação : 52
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problema com quadros de imagem.[RESOLVIDO]

Mensagem por Lukbebalduke em Dom 27 Out 2013, 18:28

Vlw cara, eu tinha acabado de arrumar e tava passando aqui para deletar o topico, mas é isso mesmo, não tinha um image_index porque eu não tinha uma sprite de 6 frames rodando, mas sim uma de 2.

Lukbebalduke

Ranking : Nota B
Número de Mensagens : 764
Data de inscrição : 06/07/2011
Notas recebidas : B - B - A - B
Reputação : 30
Insignia 1 x 1 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 2

Voltar ao Topo Ir em baixo

Re: Problema com quadros de imagem.[RESOLVIDO]

Mensagem por Conteúdo patrocinado Hoje à(s) 02:25


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum