[Resolvido] Shaders travando o runner

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[Resolvido] Shaders travando o runner

Mensagem por gabrielsch em Sex 13 Set 2013, 06:04

Estou desenvolvendo um jogo para Android, atualmente testo ele em um celular com android 2.3.6 com especificações bem baixas, digamos que é um celular que não foi feito para rodar jogos. Pois bem o jogo que eu estava desenvolvendo rodava sem problemas nesse celular até eu tentar utilizar shaders, tentei utilizar um shader para testes e vi que o celular obviamente não suportava. Sabendo disso retirei o uso dos shaders nos códigos e infelizmente o problema permaneceu, removi todos os shaders e retirei qualquer código que se refiria a algum mesmo esse sendo um comentário mas o problema permanece, ou seja, antes de utilizar um shader o jogo rodava sem problema nenhum e depois o jogo nem ao menos inicia. Seria um problema com o próprio GM?
OBS: O runner está atualizado assim como todos os arquivos da SDK.


RESOLVIDO:
O problema era no próprio GMS, depois de fechar o programa e abrir denovo o erro parou de acontecer, infelizmente de alguma forma ele ainda incluía os arquivos de shaders no projeto e fazia eles serem executados de alguma forma dentro do aparelho. Não é a primeira vez que o GMS mostra esses problemas ridículos e sem explicação... se algum MOD ou ADM quiser podem fechar o tópico!

Flw! sorrindo2

___________


Acesse: http://foxen.com.br/



gabrielsch

Ranking : Nota A
Número de Mensagens : 1229
Idade : 21
Data de inscrição : 06/12/2009
Notas recebidas : D + A + A
Reputação : 28
Insignia 1 x 1 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 2
   : 0

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum