Conectar-se
Quem está conectado
26 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 26 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota A
Notas recebidas : A
Data de inscrição : 30/04/2013
Número de Mensagens : 21
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuáriohttp://www.bluemonster.com.br/

Problema de desempenho no android

em Sex 02 Ago 2013, 22:08
Fala galera,

Estou com um problema ao criar jogos pra android. Se eu usar mais de uma camada como background o jogo fica extremamente lento... já testei em diversos dispositivos e o problema continua. Se eu desativar as camadas de fundo o jogo roda perfeitamente.. Se eu teste o jogo para Pc ou para IOS ele tambem roda perfeito. Acredito que seja algum bug do game maker em relação ao android.. Alguém mais está enfrentando esse problema???
avatar
Ranking : Nota A
Notas recebidas : A - A - A - A - A -A -C
Data de inscrição : 08/12/2011
Número de Mensagens : 1011
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 71

Prêmios
   : 1
   : 2
   : 1
Ver perfil do usuário

Re: Problema de desempenho no android

em Sex 02 Ago 2013, 22:56
Vai depender do aparelho, geralmente os dispositivos mais fracos com CPU de 800 Mhz pra baixo vão apresentar lentidão com mais de um background.
Dá pra usar no máximo 2 a 30 fps.

Em dual cores funciona bem com até uns 5 backgrounds.

Cada camada de background consome mais ou menos 7 fps.

Que resolução você está usando? ( Qual o tamanho da view?)



avatar
Ranking : Nota A
Notas recebidas : A
Data de inscrição : 30/04/2013
Número de Mensagens : 21
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuáriohttp://www.bluemonster.com.br/

Re: Problema de desempenho no android

em Sab 03 Ago 2013, 00:32
Estou usando um motorola Atrix aqui, ele é dual-core e mesmo assim o jogo fica extremamente lento... usando apenas 2 backgrounds..


uso a view com tamanho 800x480

Quando desativo os backgrounds o jogo roda perfeitamente
avatar
Ranking : Nota B
Notas recebidas : B
Data de inscrição : 28/11/2010
Número de Mensagens : 454
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 37

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problema de desempenho no android

em Sab 03 Ago 2013, 09:34
Deve ser algum problema com o compilador do Android, ou seu aparelho tem a GPU fraca, as vezes, ter um bom processador não significa que o jogo vai rodar "liso".
Pense em um computador, não adianta ter um Core i7 sem ter uma boa GPU pra rodar os games da atualidade.
Quando você diz:
evocatistudio escreveu:[...]Quando desativo os backgrounds o jogo roda perfeitamente
Eu já pensei logo na GPU de seu Motorola Atrix.
Se você consegue rodar jogos pesados nele, então já é do compilador mesmo.
avatar
Ranking : Nota A
Notas recebidas : A - A - A - A - A -A -C
Data de inscrição : 08/12/2011
Número de Mensagens : 1011
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 71

Prêmios
   : 1
   : 2
   : 1
Ver perfil do usuário

Re: Problema de desempenho no android

em Sab 03 Ago 2013, 09:44
A resolução está correta, baixa meu jogo Fantastic Rush e testa pra ver se roda com bom desempenho, ele tem dois backgrounds.
Seriam 3, mas tirei um para o jogo rodar acima de 40 fps.
avatar
Ranking : Nota B
Notas recebidas : B
Data de inscrição : 28/11/2010
Número de Mensagens : 454
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 37

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problema de desempenho no android

em Sab 03 Ago 2013, 10:14
Cascavelo, eu baixei seu jogo e ele parece estar rodando a mais de 50 fps, dá umas quedas de fps, mas é pouco notável.
Agora falta saber se no motorola dele vai rodar normal também.
avatar
Ranking : Nota A
Notas recebidas : A
Data de inscrição : 30/04/2013
Número de Mensagens : 21
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuáriohttp://www.bluemonster.com.br/

Re: Problema de desempenho no android

em Sab 03 Ago 2013, 11:15
obrigado pelas respostas

testei o Fantastic Rush e rodou bem aqui

dei uma olhada no forum da yoyogames e outras pessoas estão enfrentando o mesmo problema. Axo que é algum problema do compilador mesmo, pq no iphone 4 que tem praticamente a mesma configuração do atrix o jogo esta rodando liso.
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum