Problema com alarms

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Problema com alarms

Mensagem por Tecnology em Qui 27 Jun 2013, 00:22

Oi pessoal!!!
Bom, estou tentando setar alarms no meu jogo, só que não estão funcionando de forma nenhuma. Basicamente o que eu fiz(ou tentei fazer) foi que quando meu personagem encostassse num dado objeto invisível, aparecesse um balão e após certo tempo trocasse a sprite do balão.

Create do BALÃO
Código:
estado = "none";
alarme = true;

Alarm[0] do balão
Código:
estado = "balao2";
alarme = false;

Alarm[1] do balão
Código:
obj_Perso.pause = false;
visible = 0;
alarme = true;

Step do balão
Código:
if (estado == "balao1") && alarme = true
{
    visible = 1;
    alarm[0] = 4 * room_speed;
}
else if (estado == "balao2") && alarme = false
{
    sprite_index = spr_balaoF1_2;
    image_speed = 0;
    image_index = 0;
    alarm[1] = 4 * room_speed;
}

Tecnology

Número de Mensagens : 10
Data de inscrição : 10/06/2013
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: Problema com alarms

Mensagem por saim em Qui 27 Jun 2013, 09:53

- não existe código mudando o estado de "none" pra "balao1"
- ainda que existisse, o step acontece a cada step, redefinindo o valor de alarm[0] pra "4 * room_speed". Assim, ele nunca chega a zero, nunca executa a ação do alarm.

talvez, se você colocar em cada "if", "&& alarm[0] == -1", seu código funcione. Mas tem que dar um jeito do estado valer "balao1".

saim

Ranking : Nota B
Número de Mensagens : 2964
Idade : 38
Data de inscrição : 14/01/2011
Notas recebidas : C-D-A-B
Reputação : 121
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 3

Voltar ao Topo Ir em baixo

Re: Problema com alarms

Mensagem por Tecnology em Qui 27 Jun 2013, 15:40

Na verdade existe, está contido em outro objeto que quando meu personagem colide com esse objeto, troca para o estado balao1.

Tecnology

Número de Mensagens : 10
Data de inscrição : 10/06/2013
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: Problema com alarms

Mensagem por saim em Qui 27 Jun 2013, 15:59

Ah, tá. É que não apareceu no que você tinha postado.
Então é só o outro problema, mesmo.

saim

Ranking : Nota B
Número de Mensagens : 2964
Idade : 38
Data de inscrição : 14/01/2011
Notas recebidas : C-D-A-B
Reputação : 121
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 3

Voltar ao Topo Ir em baixo

Re: Problema com alarms

Mensagem por Conteúdo patrocinado Hoje à(s) 04:41


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum