Conectar-se
Quem está conectado
31 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 31 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota B
Notas recebidas : A+B+C
Data de inscrição : 25/07/2010
Número de Mensagens : 836
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 5

Prêmios
   : 2
   : 0
   : 0
Ver perfil do usuáriohttp://jotonsn.blogspot.com/

IP address no AVD fica em 0% sem rodar jogo

em Ter 12 Fev 2013, 19:24
Tenho a versão profissional do GMS, após configurar o SDK e JDK do android tentei testar um engine no emulador AVD, mas não rodava por não encontrar o IPv4 da maquina, inseri meu IP, mas a barra de download não sai do 0% não estou conseguindo resolver isso, alguém já passou por isso também??

Tentei testar no meu tablet coby kyros mid7016 com android 2.3 sem conexão a internet, mas a runner não é instalada, nem o GMS detecta o aparelho conectado no notebook, mesmo em modo depurador nada acontece, não sei se por ser um aparelho mais antigo o runner não roda, não consegui muitas informações para isso.

links de algumas coisas que pesquisei:

http://gmc.yoyogames.com/index.php?showtopic=569920&st=0&p=4207770&hl=+gm:s%20+ip%20+address&fromsearch=1&#entry4207770
http://wiki.yoyogames.com/index.php/GameMaker:Studio_FAQ
http://gmc.yoyogames.com/index.php?showtopic=545361&st=0&p=4209076&hl=+gm:s%20+ip%20+address&fromsearch=1&#entry4209076
http://gmc.yoyogames.com/index.php?showtopic=569920&st=0&p=4206563&hl=+gm:s%20+ip%20+address&fromsearch=1&#entry4206563
http://wiki.yoyogames.com/index.php/Troubleshooting_Android_Devices
http://gmc.yoyogames.com/index.php?showtopic=568769&st=0&p=4198677&hl=gm:s%20ip%20address&fromsearch=1&#entry4198677

avatar
Ranking : Sem avaliações
Data de inscrição : 08/06/2008
Número de Mensagens : 2314
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 100

Prêmios
   : 3
   : 0
   : 1
Ver perfil do usuáriohttp://blackcapapps.blogspot.com.br/

Re: IP address no AVD fica em 0% sem rodar jogo

em Qua 13 Fev 2013, 11:54
GMS não da suporte para testes no AVD tento em vista a performance dele.

Tablet Coby Kyros são horríveis para desenvolvedores!
Não estou falando por falar, já tentei rodar meus jogos em dois deles e até a coisa mais simples não passava de 10 fps, parecia que não tinha em um tipo de aceleração de performance, o touch era horrível e além disso tinha o mesmo problema que o seu.
Ele parece ter um problema de drivers que o android sdk não o reconhece.
Eu tentei isso http://androidecia.blogspot.com.br/2011/06/instalando-o-tablet-coby-kyros-mid7015.html
E deu certo.

De qualquer forma, por causa dessa experiência, não recomendo pra ninguém...
avatar
Data de inscrição : 09/07/2011
Número de Mensagens : 646
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 6

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: IP address no AVD fica em 0% sem rodar jogo

em Qua 13 Fev 2013, 13:37
Eu tentei a dica que o Seeker me deu nesse tópico: http://gmc.yoyogames.com/index.php?showtopic=545361&view=findpost&p=4209076
Mas não funcionou, não mudou o comportamento do YoYo runner.
Aí eu penso...
Pô, se hackers conseguem abrir portas pra enviar ou extrair informações de um PC, porque uma equipe tão grande e com tantos recursos não conseguem deixar as configurações do GMS automáticas e sem bugs?

Kabeção escreveu:GMS não da suporte para testes no AVD tento em vista a performance dele.
Antes eu usava, porque agora não funciona mais?
avatar
Ranking : Nota A
Notas recebidas : A - A - A - A - A -A -C
Data de inscrição : 08/12/2011
Número de Mensagens : 1011
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 71

Prêmios
   : 1
   : 2
   : 1
Ver perfil do usuário

Re: IP address no AVD fica em 0% sem rodar jogo

em Qua 13 Fev 2013, 14:17
Joton,
Faz este teste aqui pra saber se seu aparelho esta realmente conectando como PC e o problema não é falta de drivers:
http://wiki.yoyogames.com/index.php/Debugging_Android_Devices

Deve aparece "device" na resposta.
Se aparece "unknown" é porque não está conectando, você vai precisar encontrar os drivers corretos, geralmente estes tablets usam os drivers da HTC.

Seu tablet em WIFI?
Existe uma maneira de instalar o Runner quando não se consegue conexão por cabo. Vou tentar achar em alguma resposta antiga minha, porque a Yoyo apagou esta dica e não me lembro como era.
avatar
Ranking : Nota B
Notas recebidas : A+B+C
Data de inscrição : 25/07/2010
Número de Mensagens : 836
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 5

Prêmios
   : 2
   : 0
   : 0
Ver perfil do usuáriohttp://jotonsn.blogspot.com/

Re: IP address no AVD fica em 0% sem rodar jogo

em Qua 13 Fev 2013, 15:17
@Kabeção

Não é recomentado por causa da performance, mas é possível sim, o GMS detecta o emulador e instala o RUNNER, o que não vai é quando coloco meu IP na IP address da RUNNER do yoyogames, a barra fica em 0% sem progredir, ou é um bug do RUNNER, ou o firewall do meu PC não deixa acontecer a transmissão de dados, uso o norton, ou sei lá!!!!!

Comprei esse tablet em 2011, não tinha muitas pretensões, mas realmente para testar jogos, ele é muito ruim.

Vou olhar o link, flw.

@Super Maker: Talvez seja um bug da RUNNER do atual gms, qual foi a versão que tu usou e conseguiu usar o emulador??

@cascavelo: Talvez seja os drivers antigos do meu tablet, nunca atualizei minha versão 2.3, o tablet conecta de boa no pc, só não é reconhecido pelo GMS, em casa vou tentar fazer o que tu me indicou pra vê se dá sinal de vida.

Não tenho sinal WI-FI em casa nem roteador, vou pegar um celular mais atual com android e ver se consigo testar sem tanta dor de cabeça, flw.

avatar
Data de inscrição : 09/07/2011
Número de Mensagens : 646
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 6

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: IP address no AVD fica em 0% sem rodar jogo

em Qua 13 Fev 2013, 16:09
Joton escreveu:@Super Maker: Talvez seja um bug da RUNNER do atual gms, qual foi a versão que tu usou e conseguiu usar o emulador??
A versão que eu uso é a professional e funcionava maravilhosamente bem até a 1.1.750. De lá pra cá é só decepção.
Não sei se isso pode ser coisa do FireWall, sei que não fiz nenhuma alteração e por isso acredito que possa ser bug no GMS.
avatar
Ranking : Nota A
Notas recebidas : A - A - A - A - A -A -C
Data de inscrição : 08/12/2011
Número de Mensagens : 1011
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 71

Prêmios
   : 1
   : 2
   : 1
Ver perfil do usuário

Re: IP address no AVD fica em 0% sem rodar jogo

em Qua 13 Fev 2013, 16:30
Não tenho sinal WI-FI em casa nem roteador, vou pegar um celular mais atual com android e ver se consigo testar sem tanta dor de cabeça, flw.

O ideal é ter WI-FI , é bem mais rapido pra testar e ficar usando USB acaba destruindo a entrada do celular de tanto conectar e desconectar .



Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum