[RESOLVIDO]Tudo parou de funcionar

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido [RESOLVIDO]Tudo parou de funcionar

Mensagem por Lukbebalduke em Dom 06 Jan 2013, 16:22

Pessoal eu to aqui com um projeto, o projeto ja esta bem perto do final só que de uma hora para outra ela parou de funcionar. O que eu programei parou de funcionar se eu sequer ter feito alguma alteraçao, o personagem parou, as armadilhas pararam e até o menu parou de funcionar, o que pdoe ter acontecido ?


Última edição por pinpi em Seg 07 Jan 2013, 08:52, editado 1 vez(es)

Lukbebalduke

Ranking : Nota B
Número de Mensagens : 764
Data de inscrição : 06/07/2011
Notas recebidas : B - B - A - B
Reputação : 30
Insignia 1 x 1 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 2

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por RafaelCazarotto em Dom 06 Jan 2013, 16:57

isso ja aconteceu comigo, de uma hora para outra meu jogo nao funcionava, dava erro, ai eu fui fazer outra coisa e alguns dias depois tentei de novo e deu certo, experimenta reiniciar o pc, ou abandonar por algun tempo, pod ser erro do proprio gm,

RafaelCazarotto

Ranking : Nota C
Número de Mensagens : 564
Idade : 19
Data de inscrição : 15/03/2012
Notas recebidas : D-D-D-C-C-B
Reputação : 13
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 1

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por PedroX em Dom 06 Jan 2013, 17:20

Você precisa especificar mais o problema. O que realmente acontece? Há erros exibidos? O que funciona? Há algo em comum no que não funciona?

Até mais!

PedroX

Ranking : Nota C
Número de Mensagens : 6034
Idade : 21
Data de inscrição : 26/07/2008
Notas recebidas : C+B
Reputação : 286
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por Lukbebalduke em Dom 06 Jan 2013, 17:25

O jogo roda, mas nenhuma acao funciona , é como se fossem somente objetos parados. Eu tambem percebi que quando eu deleto o objeto obj_challenger tudo volta ao normal. Mas o objeto só tem codigos e mais codigos.

Show information
Spoiler:
Information about object: obj_challenger

Sprite:
Solid: false
Visible: true
Depth: 0
Persistent: true
Parent:
Mask:

Begin Step Event:
execute code:

if chal1=0 and global.mortes=100
{
chal1=1
(instance_create(0,0,obj_desbloqueado)).deskin=1
}
//if chal2=0
//{
//chal1=1
//}
if chal3=0 and global.chal3=1
{
chal3=1
(instance_create(0,0,obj_desbloqueado)).deskin=3
}
if chal4=0 and global.chal4=1
{
chal4=1
(instance_create(0,0,obj_desbloqueado)).deskin=4
}
if chal5=0 and global.chal5=1
{
chal5=1
}
if chal6=0 and global.chal6=1
{
chal6=1
(instance_create(0,0,obj_desbloqueado)).deskin=6
}
if chal7=0 and global.chal7=1
{
chal7=1
}
if chal8=0 and global.mortes=500
{
chal8=1
(instance_create(0,0,obj_desbloqueado)).deskin=8
}
if chal9=0 and global.chal9=1
{
chal9=1
(instance_create(0,0,obj_desbloqueado)).deskin=9
}
//if chal10=0 and global.chal10=1
//{
//chal10=1
//(instance_create(0,0,obj_desbloqueado)).deskin=10
//}
if chal11=0 and global.chal11=1
{
chal11=1
}


Other Event: Game Start:
execute code:

//ficanomenu
chal1=0
chal2=0
chal3=0
chal4=0
chal5=0
chal6=0
chal7=0
chal8=0
chal9=0
chal10=0
chal11=0
chal12=0
//
global.mortes=0
global.chal3=0
global.chal4=0
global.chal6=0
global.chal7=0
global.chal11=0
global.skin=0
global.chal5=0
global.chal10=0
//
global.emfase=0


Other Event: Room Start:
execute code:

if room=room_fase1 or room=room_fase2 or room=room_fase3 or room=room_fase4 or room=room_fase5 or room=room_fase6 or room=room_fase7 or room=room_fase8 or room=room_fase9 or room=room_fase10 or room=room_fase11 or room=room_fase12 or room=room_fase13 or room=room_fase14 or room=room_fase15
global.emfase=1
else
global.emfase=0

execute code:

if room=room_fase1
global.mortes=0

execute code:

chal2m=global.mortes


Other Event: Room End:
execute code:

if chal2=0 and chal2m=global.mortes and global.emfase=1
{
chal2=1
(instance_create(0,0,obj_desbloqueado)).deskin=2}


Draw Event:
execute code:

if global.emfase=1
{
draw_set_font(font0)
draw_set_color(c_white)
draw_text(0,0,string(global.mortes))
}


Lukbebalduke

Ranking : Nota B
Número de Mensagens : 764
Data de inscrição : 06/07/2011
Notas recebidas : B - B - A - B
Reputação : 30
Insignia 1 x 1 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 2

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por PedroX em Dom 06 Jan 2013, 17:51

Está bem complicado assim. Se você quiser me passar o gmk por mp, posso investigar o problema. Você também pode esperar um pouco mais por alguma solução.

Até mais!

PedroX

Ranking : Nota C
Número de Mensagens : 6034
Idade : 21
Data de inscrição : 26/07/2008
Notas recebidas : C+B
Reputação : 286
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por Lukbebalduke em Dom 06 Jan 2013, 18:16

PedroX escreveu:Está bem complicado assim. Se você quiser me passar o gmk por mp, posso investigar o problema. Você também pode esperar um pouco mais por alguma solução.

Até mais!

Nao me importo de deixar aqui nao, quem quiser baixar baixe, (mal intencionados nao faram nada o projeto nao esta terminado). Aqui ta o link do GMK

Código:
http://www.mediafire.com/?vcu1p5zf3hrvqvu

Lukbebalduke

Ranking : Nota B
Número de Mensagens : 764
Data de inscrição : 06/07/2011
Notas recebidas : B - B - A - B
Reputação : 30
Insignia 1 x 1 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 2

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por RafaelCazarotto em Dom 06 Jan 2013, 20:20

muito estranho O_o tentei aqui tbm mas não deu nada, nenhum botão funcionava, sera que existe um codigo para desativar o mouse ???

RafaelCazarotto

Ranking : Nota C
Número de Mensagens : 564
Idade : 19
Data de inscrição : 15/03/2012
Notas recebidas : D-D-D-C-C-B
Reputação : 13
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 1

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por vinians em Dom 06 Jan 2013, 20:50

Amigo, o problema é que vc desabilitou a checagem de erro. Veja:

Error in code at line 38:
if chal9=0 and global.chal9=1
^
at position 24: Unknown variable chal9
Esse erro esta impossibilitando o programa de continuar.
Reabilite a checagem de erro e você poderá debugar o jogo corretamente.
Dica: sempre deixe habilitada essa checagem até que você tenha a versão final do jogo, sem erros.
Flws!

vinians

Ranking : Nota B
Número de Mensagens : 2490
Idade : 27
Data de inscrição : 18/09/2008
Notas recebidas : B-C-A-C
Reputação : 52
Insignia 1 x 0 Insignia 2 x 1 Insignia 3 x 0
Prêmios
   : 0
   : 2
   : 1

http://xcreatorgames.weebly.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por Lukbebalduke em Seg 07 Jan 2013, 08:51

Realmente, nem me liguei nisso. Facepalm*

RESOLVIDO

Lukbebalduke

Ranking : Nota B
Número de Mensagens : 764
Data de inscrição : 06/07/2011
Notas recebidas : B - B - A - B
Reputação : 30
Insignia 1 x 1 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 2

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por Thopson1m em Ter 08 Jan 2013, 00:42

Tópico trancado, pois a dúvida do autor foi resolvida.
Caso necessites, favor se dirigir à mim ou à qualquer outro moderador para destrancar este seu tópico.

Thopson1m

Número de Mensagens : 624
Idade : 26
Data de inscrição : 21/05/2011
Reputação : 16
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://gnbr.forumeiros.com

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Tudo parou de funcionar

Mensagem por Conteúdo patrocinado Hoje à(s) 15:27


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum