Conectar-se
Quem está conectado
23 usuários online :: 2 usuários cadastrados, Nenhum Invisível e 21 Visitantes

CRP-Max, Zero.

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 20/12/2012
Número de Mensagens : 97
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 1

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

[resolvido] O que tem de errado com meu soco ??

em Seg 24 Dez 2012, 17:31
Eu fiz um soco , mas a animação está meio estranha , as veses ela começa de um jeito diferente , as veses começa no fim do sprite as veses no começo , aí fiz um combo e ficou meio estranho , alguem saberia me ajudar ??
Código Step :

Código:
if keyboard_check(vk_right)and soco=false and chute=false and pulo=false{x+=vel sprite_index=spr_char_an direita=true parado=false vel+=0.1 }
if keyboard_check(vk_left)and soco=false and chute=false and pulo=false{x-=vel sprite_index=spr_char_an direita=false parado=false vel+=0.1}
if keyboard_check_released(vk_right){parado=true}
if keyboard_check_released(vk_left){parado=true}
if keyboard_check_released(vk_up){parado=true}
if keyboard_check_released(vk_down){parado=true}
if vel>15{vel=15}
if parado=true and pulo=false
{
vel=7
sprite_index=spr_char_parado}
if direita=true{image_xscale=1}
if direita=false{image_xscale=-1}

if keyboard_check(vk_up) and pulo=false and soco=false and chute=false{y-=8 sprite_index=spr_char_an parado=false}
if keyboard_check(vk_down) and pulo=false and soco=false and chute=false{y+=8 sprite_index=spr_char_an parado=false}

if keyboard_check_pressed(ord("D"))and soco=false and chute=false and pulo=false{soco = true sprite_index=spr_char_socando alarm[0]=10 parado=false instance_create(x,y,obj_hit) combo=1 alarm[4]=40}
if keyboard_check_pressed(ord("W"))and chute=false and soco=false and pulo=false and combo=1{chute = true sprite_index=spr_char_chute alarm[3]=15 parado=false instance_create(x,y,obj_hit_chute) alarm[4]=50 combo=2}
if keyboard_check_pressed(ord("W"))and chute=false and soco=false and pulo=false and combo=0{chute = true sprite_index=spr_char_chute alarm[3]=15 parado=false instance_create(x,y,obj_hit_chute) alarm[4]=50}

if keyboard_check_pressed(vk_shift) and parado=true  and pulo=false{magia=true instance_create(x,y,obj_magia) }
if keyboard_check_pressed(vk_shift) and parado=false and pulo=false{magia=true instance_create(x,y,obj_magia) }
if keyboard_check_released(vk_shift){magia=false}

if parado=false{mask_index=mask_anda}else{mask_index=sprite_index}
if keyboard_check_pressed(vk_space) and pulo = false {fimp=y gravity=1 vspeed = -15 sprite_index=spr_char_pulando alarm[2]=30 pulo=true }
if pulo=true{obj_limite.solid=false}
if pulo = true and keyboard_check(vk_left){x-=vel}
if pulo = true and keyboard_check(vk_right){x+=vel}
if keyboard_check_pressed(ord("W"))and soco=false and chute=false and pulo=false and combo=1{chute = true sprite_index=spr_char_chute alarm[3]=15 parado=false instance_create(x,y,obj_hit_chute) combo=2 alarm[4]=50}
if keyboard_check_pressed(ord("W"))and soco=false and chute=false and pulo=false and combo=2{chute = true sprite_index=spr_char_combo alarm[3]=15 parado=false instance_create(x,y,obj_hit_chute) combo=3 alarm[4]=20}
Alarm 0 :
Código:
image_index=0
soco=false
parado=true
Alarm 1 :
Código:
if parado=false{vel=13}else{vel=7}
Alarm 2 :
Código:
gravity=0
vspeed=0
pulo=false
y=fimp
{obj_limite.solid=true}
Alarm 3 :
Código:
image_index=0
parado=true
chute=false
Alarm 4 :
Código:
combo=0

Obrigado pela ajuda ... Grato!


Última edição por galavernaa em Sex 28 Dez 2012, 12:07, editado 1 vez(es)
avatar
Ranking : Nota C
Notas recebidas : D-D-D-C-C-B
Data de inscrição : 15/03/2012
Número de Mensagens : 564
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 13

Prêmios
   : 1
   : 0
   : 1
Ver perfil do usuário

Re: [resolvido] O que tem de errado com meu soco ??

em Qui 27 Dez 2012, 14:13
cara voce poderia disponibilizar a engine ou o projeto, para dar uma olhada, assim fica mais facil porque talvez o erro esteja no sprite. dai me manda uma mp avisando ok?
avatar
Data de inscrição : 20/12/2012
Número de Mensagens : 97
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 1

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [resolvido] O que tem de errado com meu soco ??

em Sex 28 Dez 2012, 12:07
Opa desculpa pela demora , o problema não era o sprite era que ele não voltava td vez para o image_index 0 , eu ja resolvi , na verdade quem resolveu foi o vinians, mas está resolvido obrigado

Tópico resolvido, tópico trancado para evitar posts desnecessários.
Caso o autor deseje reabrir, contacte um moderador.
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum