Conectar-se
Quem está conectado
30 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 30 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota B
Notas recebidas : B - B - A - B
Data de inscrição : 06/07/2011
Número de Mensagens : 764
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 30

Prêmios
   : 1
   : 0
   : 2
Ver perfil do usuário

[RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 16:24
Galera, eu tenho uma variavel chamada global.dbota. O valor dela é 1. E tenho tres botoes com esse codigo

Código:
if global.dbota = 1  // Aqui no caso cada botao tem um numero , no caso 1,2 ou 3
sprite_index=(spr_d2_botao1)
else
sprite_index=(spr_d_botao1)

Só que todos o botoes ficam com a sprite spr_d2_botao. Se ele colocar para checar se dbota é 50 ele diz q é. Porque isso nao funciona de jeito nenhum ???? O Gm tem algo contra mim ? Simplesmente qualquer valor ele diz que é igual. PQ ?


Última edição por pinpi em Seg 24 Dez 2012, 18:45, editado 1 vez(es)
avatar
Ranking : Nota B
Notas recebidas : B+B
Data de inscrição : 04/03/2012
Número de Mensagens : 1925
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 144

Prêmios
   : 1
   : 2
   : 0
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 16:55
Não entendi direito o que você esta fazendo,deixe mais claro isso.

você quer que esses botoes sejam respondidos com o click do mouse?
avatar
Ranking : Nota B
Notas recebidas : C + C + B
Data de inscrição : 28/07/2012
Número de Mensagens : 1281
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 73

Prêmios
   : 3
   : 1
   : 3
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 16:57
tente ver se vc n colocou um set var igual, ou no step .
qualquer duvida coloque== en vez de = , quando for if.
avatar
Ranking : Nota A
Notas recebidas : A - A - A - A - A -A -C
Data de inscrição : 08/12/2011
Número de Mensagens : 1011
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 71

Prêmios
   : 1
   : 2
   : 1
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 17:01
Não pode colocar comentário após o if , quebra o código, tente sem ele.
Ranking : Nota C
Notas recebidas : C+B
Data de inscrição : 26/07/2008
Número de Mensagens : 6037
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 288

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 17:05
Clique em Show Information no objeto em que isso acontece.
Depois copie e poste aqui.

Obs: Retire os parenteses do nome do sprite.

@Rodrigo Santiago
Isso é o recomendado. Mas não causaria o erro.

@cascavelo
Os comentários são totalmente ignorados. Então isso não atrapalharia o if.

Até mais!
avatar
Ranking : Nota B
Notas recebidas : B+B
Data de inscrição : 04/03/2012
Número de Mensagens : 1925
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 144

Prêmios
   : 1
   : 2
   : 0
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 17:12
testei aqui em casa e coloquei cada botão com um valor diferente como você disse(1..3) todos eles ficaram com seus respectivos valores sem nenhum problema,eu coloquei esse codigo no evento create e a cima eu declarei a variavel com o codigo pra cada um global.dbota=1 e nos outros eu dei valor 2 e 3,nao vi problema algum,como vc fez?
avatar
Ranking : Nota B
Notas recebidas : B - B - A - B
Data de inscrição : 06/07/2011
Número de Mensagens : 764
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 30

Prêmios
   : 1
   : 0
   : 2
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 17:15
Botao 1:

Spoiler:
Information about object: spr_d_botao1

Sprite: spr_d_botao1
Solid: false
Visible: true
Depth: 0
Persistent: false
Parent:
Mask:

Create Event:
execute code:

global.dbota=1


Step Event:
execute code:

if global.dbota == 1
sprite_index=spr_d2_botao1
else
sprite_index=spr_d_botao1


Mouse Event for Left Pressed:
execute code:

global.dbota=1

Botao 2

Spoiler:
Information about object: spr_d_botao2

Sprite: spr_d_botao2
Solid: false
Visible: true
Depth: 0
Persistent: false
Parent:
Mask:

Step Event:
execute code:

if global.dbota == 2
sprite_index=spr_d2_botao2
else
sprite_index=spr_d_botao2;


Mouse Event for Left Pressed:
execute code:

global.dbota=2


Botao 3

Spoiler:
Information about object: spr_d_botao3

Sprite: spr_d_botao3
Solid: false
Visible: true
Depth: 0
Persistent: false
Parent:
Mask:

Step Event:
execute code:

if global.dbota == 3
sprite_index=spr_d2_botao3
else
sprite_index=spr_d_botao3


Mouse Event for Left Pressed:
execute code:

global.dbota=3


Os == e os (sprite) eu removi agora, deu na mesma.
avatar
Ranking : Nota B
Notas recebidas : B+B
Data de inscrição : 04/03/2012
Número de Mensagens : 1925
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 144

Prêmios
   : 1
   : 2
   : 0
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 17:22
testei aqui em casa e acontece o seguinte: quando eu aperto um ele muda de cor quando eu aperto outro ele troca de cor e os outros voltam a sua cor inicial,era isso que vc queria?
avatar
Ranking : Nota B
Notas recebidas : B - B - A - B
Data de inscrição : 06/07/2011
Número de Mensagens : 764
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 30

Prêmios
   : 1
   : 0
   : 2
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 17:23
sim, mas n sei pq nao acontece.
avatar
Ranking : Nota B
Notas recebidas : B+B
Data de inscrição : 04/03/2012
Número de Mensagens : 1925
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 144

Prêmios
   : 1
   : 2
   : 0
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 17:32
tenta a minha engine e ve se ela funciona com vc

http://dl.dropbox.com/u/98340250/engine%20cores.rar
avatar
Ranking : Nota B
Notas recebidas : B - B - A - B
Data de inscrição : 06/07/2011
Número de Mensagens : 764
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 30

Prêmios
   : 1
   : 0
   : 2
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 17:35
Meus codigos sao identicos, nao sei porque os malditos nao funcionam !!!
avatar
Ranking : Nota B
Notas recebidas : B+B
Data de inscrição : 04/03/2012
Número de Mensagens : 1925
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 144

Prêmios
   : 1
   : 2
   : 0
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 17:57
mas o meu funcionou? fiz outro mais detalhado baixa esse

http://dl.dropbox.com/u/98340250/engine%20cores.rar
Ranking : Nota C
Notas recebidas : C+B
Data de inscrição : 26/07/2008
Número de Mensagens : 6037
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 288

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 18:09
Eu já sei o motivo. Você usou nomes de objeto iguais a nomes de sprites.
Nunca faça isso ou poderá gerar conflitos.

Até mais!
avatar
Ranking : Nota B
Notas recebidas : C + C + B
Data de inscrição : 28/07/2012
Número de Mensagens : 1281
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 73

Prêmios
   : 3
   : 1
   : 3
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 18:26
isso mesmo pedrox, o indice retornado e inserto vai ser sempre igual. mas eu acho q isso n resolve, vamos ver
avatar
Ranking : Nota B
Notas recebidas : B - B - A - B
Data de inscrição : 06/07/2011
Número de Mensagens : 764
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 30

Prêmios
   : 1
   : 0
   : 2
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 18:44
*Facepalm , escrevi o prefixo errado, ai meu deus...

TOPICO RESOLVIDO

AAAAAAAAAHHH EU SOU MT BUROOOOO, E FALTA DE ATENCAO
Ranking : Nota C
Notas recebidas : C+B
Data de inscrição : 26/07/2008
Número de Mensagens : 6037
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 288

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: [RESOLVIDO]Bug medonho ?

em Seg 24 Dez 2012, 19:05
Fica a dica. É bom postar o texto do Show Information do objeto. Assim fica muito mais fácil achar o problema.
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum