Conectar-se
Quem está conectado
30 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 30 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota E
Notas recebidas : E+E
Data de inscrição : 20/06/2012
Número de Mensagens : 131
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 1
Ver perfil do usuário

Ajuda urgente! Meu alarm não quer funcionar!

em Qua 14 Nov 2012, 22:43
Gente eu coloquei o alarm, mais ele não tá executando as ações, alguém saberia me ajudar? Happy
avatar
Ranking : Nota B
Notas recebidas : C-D-A-B
Data de inscrição : 14/01/2011
Número de Mensagens : 2964
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 121

Prêmios
   : 1
   : 0
   : 3
Ver perfil do usuário

Re: Ajuda urgente! Meu alarm não quer funcionar!

em Qui 15 Nov 2012, 07:40
Ontem não vi as imagens, pensei num milhão de possibilidades. Agora está mais fácil entender.

A cada step de colisão a árvore vai acionar o alarme só quando a colisão acabar é que o alarme vai conseguir correr.
A cada instante que houver colisão, o alarme volta pra 3 segundos.
avatar
Ranking : Nota A
Notas recebidas : D + A + A
Data de inscrição : 06/12/2009
Número de Mensagens : 1229
Insígnias de JAM :

Insignia 1x 1 Insignia 2x 0 Insignia 3x 0
Reputação : 28

Prêmios
   : 1
   : 2
   : 0
Ver perfil do usuário

Re: Ajuda urgente! Meu alarm não quer funcionar!

em Qui 15 Nov 2012, 08:21
saim escreveu:Ontem não vi as imagens, pensei num milhão de possibilidades. Agora está mais fácil entender.

A cada step de colisão a árvore vai acionar o alarme só quando a colisão acabar é que o alarme vai conseguir correr.
A cada instante que houver colisão, o alarme volta pra 3 segundos.

Digo o mesmo que o saim.

Para resolver esse problema você pode verificar se o alarme ja esta contando, desse jeito:
Código:
if alarm[0] < 1
{alarm[0] = 3*room_speed}
avatar
Ranking : Nota E
Notas recebidas : E+E
Data de inscrição : 20/06/2012
Número de Mensagens : 131
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 1
Ver perfil do usuário

Re: Ajuda urgente! Meu alarm não quer funcionar!

em Qui 15 Nov 2012, 13:43
gabrielsch escreveu:
saim escreveu:Ontem não vi as imagens, pensei num milhão de possibilidades. Agora está mais fácil entender.

A cada step de colisão a árvore vai acionar o alarme só quando a colisão acabar é que o alarme vai conseguir correr.
A cada instante que houver colisão, o alarme volta pra 3 segundos.

Digo o mesmo que o saim.

Para resolver esse problema você pode verificar se o alarme ja esta contando, desse jeito:
Código:
if alarm[0] < 1
{alarm[0] = 3*room_speed}

Muito obrigado pessoal deu certo! Happy
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum