Conectar-se

Esqueci minha senha

Últimos assuntos
» [Enquete] Concursos GMBR
por Willy Ontem à(s) 19:49

» CR - Concurso Relâmpago!!
por Willy Ter 18 Jul 2017, 17:11

» 3D:como rodar a camara em horizontal?
por Cambalinho Ter 18 Jul 2017, 15:09

» [Resolvido] pode explicar a d3d_set_projection()?
por Cambalinho Ter 18 Jul 2017, 11:28

» Escrever a resposta certa muda de room
por PedroX Seg 17 Jul 2017, 21:46

» Nota de esclarecimento - GMBR voltou!
por Mentos e Coca-cola Seg 17 Jul 2017, 17:05

» [CR] Campo Minado
por Katerp Dom 16 Jul 2017, 23:09

» [CR] The Bazooka Cat
por Tedi Ripper Dom 16 Jul 2017, 23:01

» Como melhorar um protótipo(Design)
por lolandoplayer Dom 16 Jul 2017, 22:56

» Diminuir velocidade ao arrastar objeto
por LwysF Dom 16 Jul 2017, 17:33

Quem está conectado
21 usuários online :: 1 usuário cadastrado, Nenhum Invisível e 20 Visitantes

Lighter

[ Ver toda a lista ]


O recorde de usuários online foi de 324 em Ter 05 Out 2010, 13:36
Estatísticas
Temos 12700 usuários registrados
O último usuário registrado atende pelo nome de Eduardo Gomes

Os nossos membros postaram um total de 220919 mensagens em 30412 assuntos

[Resolvido] Problema sério com Ini's

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[Resolvido] Problema sério com Ini's

Mensagem por Rhino em Seg 22 Out 2012, 19:47

Bom, já faz um bom tempo que estou montando uma engine e sempre que tenho tempo, vou adicionando sistemas novos e corrigindo bugs. Desde ontem percebi que meu sistema de salvar qualquer coisa via ini está dando problema: qualquer variável salva, ao iniciar o jogo novamente, não é carregada. Tentei de tudo pra arrumar e não consegui. É até estranho isso, pois estava funcionando anteriormente (e sem bug nenhum).

http://www27.zippyshare.com/v/49488583/file.html

No exemplo, pressione Z e X, respectivamente, para ativar/desativar as opções. Notem que, ao fechar o jogo e o arquivo ini for criado, abram-no e vejam as opções salvas. Porém, ao abrir, independente destas, o jogo vai resetar tudo para zero, não ficando do jeito que o jogador deixou. Eu inclusive já tentei, por exemplo, colocar o comando window_set_fullscreen(global.menu[0,0]) no scr_iniload, mas sem sucesso.
Realmente não sei o que está errado. :S

Eu apenas fiz esse rápido arquivo pra saber o porquê de não estar funcionando, até porque, postar a mina engine inteira, levaria tempo para entendê-la e tudo mais, apesar de que os scripts de salvar e carregar são os mesmos.

EDIT: Nossa, que erro grotesco. Troquei ini_write_real com ini_read_real. Razz
Podem fechar o tópico, já consegui aqui.
avatar
Rhino

Ranking : Nota C
Notas recebidas : C-B
Data de inscrição : 17/04/2010
Número de Mensagens : 136
Insígnias de JAM :

Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Prêmios
   : 0
   : 0
   : 0

Ver perfil do usuário

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum