Problemas com sprites depois da atualização 1.1

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Problemas com sprites depois da atualização 1.1

Mensagem por cascavelo em Dom 23 Set 2012, 21:48

Estou atualizando meu jogo "Mr.Toad" com Ads e arrumando uns pequenos bugs que existiam, no pc o jogo está funcionando numa boa, no Cel aparecem uns quadrados pretos sobre as sprites, dei uma pesquizada e ví que este problema nos antigos GMs era relacionado a placa gráfica do PC que não suportava os gráficos.
Curiosamente o problema aparece rodando em celulares mais potentes, em celulares mais modestos roda normalmente.
Antes da atualização 1.1 não dava este bug.
Alguém já enfrentou algo parecido? Conseguiu contornar?

cascavelo

Ranking : Nota A
Número de Mensagens : 1011
Idade : 46
Data de inscrição : 08/12/2011
Notas recebidas : A - A - A - A - A -A -C
Reputação : 71
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 2
   : 1

Voltar ao Topo Ir em baixo

Re: Problemas com sprites depois da atualização 1.1

Mensagem por Kabeção em Dom 23 Set 2012, 22:57

Não seria a falta de memória livre para carregar as texturas?

Pode ser qualquer coisa então você precisa estar de olho nas ferramentas de debug que não são poucas para o Android.
Além do trace log do GMS tem um aplicativo no SDK chamado Dalvik Debug que da bastante informação.
Aqui tem até uma breve explicação sobre ele: http://wiki.yoyogames.com/index.php/Debugging_Android_Devices

Kabeção

Ranking : Sem avaliações
Número de Mensagens : 2314
Data de inscrição : 08/06/2008
Reputação : 100
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 3
   : 0
   : 1

http://blackcapapps.blogspot.com.br/

Voltar ao Topo Ir em baixo

Re: Problemas com sprites depois da atualização 1.1

Mensagem por cascavelo em Seg 24 Set 2012, 00:30

Não seria a falta de memória livre para carregar as texturas?
Acho que não, reiniciei o cel e reinstalei o runner, a primeira vez executou legal, na segunda vez os blocos voltaram.
O estranho é que se eu sair do jogo e voltar os blocos desaparecem.
No trace log não aparece nada, sinto que isto está ligado as novas funções para exibir ads, mas testando em outro jogo não aconteceu.
Existe alguma função pra limpar a memória de vídeo antes de iniciar a room?

cascavelo

Ranking : Nota A
Número de Mensagens : 1011
Idade : 46
Data de inscrição : 08/12/2011
Notas recebidas : A - A - A - A - A -A -C
Reputação : 71
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 2
   : 1

Voltar ao Topo Ir em baixo

Re: Problemas com sprites depois da atualização 1.1

Mensagem por Kabeção em Seg 24 Set 2012, 10:43

draw_texture_flush().

Se não resolver a unica coisa que pode fazer é relatar o bug no tracker mas como acontece só em um modelo acho difícil ser encontrada a causa.

Kabeção

Ranking : Sem avaliações
Número de Mensagens : 2314
Data de inscrição : 08/06/2008
Reputação : 100
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 3
   : 0
   : 1

http://blackcapapps.blogspot.com.br/

Voltar ao Topo Ir em baixo

Re: Problemas com sprites depois da atualização 1.1

Mensagem por Conteúdo patrocinado Hoje à(s) 21:10


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum