[TOPICO RESOLVIDO] Bug em pulo de plataforma!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido [TOPICO RESOLVIDO] Bug em pulo de plataforma!

Mensagem por AlexBosquin em Sab 22 Set 2012, 19:42

Olá gamers lindos!

Estou com um problema aqui que quando o player pula! e ele esta numa parte como essa:



Como vcs podem ver pela seta vermelha que quando o player esta num lugar plano ele pula noirmal mente

mas pela seta verde vcs nao veem ai mas quando eu pulo e ele colide com a quina da montanha ele pula umas 3x mais alto alguem sabe resolver este problema?

RESOLVIDO


Última edição por AlexBosquin em Dom 23 Set 2012, 11:11, editado 1 vez(es)

AlexBosquin

Ranking : Nota C
Número de Mensagens : 621
Idade : 20
Data de inscrição : 10/07/2012
Notas recebidas : C
Reputação : 35
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 0

http://www.craftstudios.com.br

Voltar ao Topo Ir em baixo

Resolvido Re: [TOPICO RESOLVIDO] Bug em pulo de plataforma!

Mensagem por theguitarmester em Sab 22 Set 2012, 23:15

deixa a Mask do Bloco com a quina em Forma Quadrada, e a do Player tambem, isto evitará diversos Erros no Jogo.

Possível Motivo do Erro:
ele pulo mais alto porque você deve ter colocado o VSPEED no Pulo acumulativo, e ele só passa pela quina somente quando o vspeed é um valor tão alto, que no próximo step não estará mais colidindo com a Quina.

theguitarmester

Ranking : Sem avaliações
Número de Mensagens : 1908
Idade : 21
Data de inscrição : 28/02/2012
Notas recebidas : B
Reputação : 80
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 1
Prêmios
   : 2
   : 2
   : 1

http://guitarmester.no.comunidades.net/index.php?pagina=19362978

Voltar ao Topo Ir em baixo

Resolvido Re: [TOPICO RESOLVIDO] Bug em pulo de plataforma!

Mensagem por AlexBosquin em Dom 23 Set 2012, 11:10

hmmm. a mask dos dois estao quadradas ok! isso eu ja sei que evita varios erros!, vou testar aki os valores do vspeed! e ja te falo...

OPAA cara vlw mesmo funfou!

estava assim:

Código:
vspeed -= 8

ai eu passei pra:

Código:
vspeed = -8

e funfou direitim vlw man!

AlexBosquin

Ranking : Nota C
Número de Mensagens : 621
Idade : 20
Data de inscrição : 10/07/2012
Notas recebidas : C
Reputação : 35
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 0

http://www.craftstudios.com.br

Voltar ao Topo Ir em baixo

Resolvido Re: [TOPICO RESOLVIDO] Bug em pulo de plataforma!

Mensagem por Conteúdo patrocinado Hoje à(s) 18:33


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum