Conectar-se
Quem está conectado
24 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 24 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
Data de inscrição : 29/05/2012
Número de Mensagens : 929
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 33
Ver perfil do usuário

duvida com hspeed no GM-S

em Sex 07 Set 2012, 13:22
Cascavelo essa vai pra vc, estou tendo um probleminha muito chato com o hspeed no GM-S se vc poder baixar esse exemplo e me dar uma luz, pedi especificamente pra vc, pq não conheço mais ninguem que tenha comprado o GM-S,o que ta acontecendo é q tem dois botoes que controlam o player , um botao esta com obj_player.hspeed =+5 no outro botao esta obj_player.hspeed =-5, me parece haver um conflito entre esses dois botoes por causa do mesmo code, parece uma duvida bem simples mais tem um script por traz..

link>> http://dl.dropbox.com/u/4532144/multi_touch_exemple.rar
avatar
Ranking : Nota C
Data de inscrição : 21/08/2012
Número de Mensagens : 97
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuário

Re: duvida com hspeed no GM-S

em Sex 07 Set 2012, 17:43
Esse conflito esta acontecendo quando precisona cada um de forma separada?????? Pq nao tem problema algum usar hspeed para receber dois valores diferentes ao apertar botoes diferentes, desde que voce nao faca essa variavel receber 2 valores diferentes ao mesmo tempo (normalmente eh por isso que da conflito em programacao).
Data de inscrição : 29/05/2012
Número de Mensagens : 929
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 33
Ver perfil do usuário

Re: duvida com hspeed no GM-S

em Sex 07 Set 2012, 18:06
Esse conflito esta acontecendo quando precisona cada um de forma separada
sim, acho q é um bug do GM-S, cara só testando pra vc entender, quem poder desvendar esse erro agradeço investigador
avatar
Ranking : Nota A
Notas recebidas : A - A - A - A - A -A -C
Data de inscrição : 08/12/2011
Número de Mensagens : 1011
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 71

Prêmios
   : 1
   : 2
   : 1
Ver perfil do usuário

Re: duvida com hspeed no GM-S

em Sex 07 Set 2012, 18:18
Você cometeu um errinho, deu trabalho pra achar porque eu não uso estas funções (device_mouse_check_button) prefiro usar virtual_key_add.

É só você retirar o comando: obj_player.hspeed=0; do objeto verde,
pois ele manda parar mesmo que o outro objeto mande seguir. Deixe apenas no objeto azul, pois o ciclo vai ser completo e ele só manda parar uma vez.
Data de inscrição : 29/05/2012
Número de Mensagens : 929
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 33
Ver perfil do usuário

Re: duvida com hspeed no GM-S

em Sex 07 Set 2012, 19:35
aaaa Cascavelo funcionou cara ki legal, sera que vc pose fazer um tuto de como seria com o virtual_key_add

Like a Star @ heaven Like a Star @ heaven Like a Star @ heaven Like a Star @ heaven Like a Star @ heaven

blz
avatar
Ranking : Nota A
Notas recebidas : A - A - A - A - A -A -C
Data de inscrição : 08/12/2011
Número de Mensagens : 1011
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 71

Prêmios
   : 1
   : 2
   : 1
Ver perfil do usuário

Re: duvida com hspeed no GM-S

em Sex 07 Set 2012, 19:53
aaaa Cascavelo funcionou cara ki legal, sera que vc pose fazer um tuto de como seria com o virtual_key_add

é mais fácil do que o que você fez, mas vou esperar um pouco pra começar a postar tutos do gms, acho que vão criar uma sessão específica no fórum pra isto.
Conteúdo patrocinado

Re: duvida com hspeed no GM-S

Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum