[Resolvido]Sprite travando depois de executar animação

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido [Resolvido]Sprite travando depois de executar animação

Mensagem por Need 90 em Sab 16 Jun 2012, 10:53

Bom, vou passar os códigos aqui :
Create
Código:
//Variáveis
tiros=8
no_cartucho=32
no_cartucho_max=64
atirar=true
recarrega=false
current_image=spr_arma
Alarm[1] :
Código:
if current_image=spr_arma {atirar=true}else{alarm[1]=1}
Step :
Código:
if tiros<=0 {recarrega=true atirar=false}
if no_cartucho>no_cartucho_max {no_cartucho=no_cartucho_max}
if recarrega=true {current_image=spr_arma_reload {atirar=true} recarrega=false}
Glob Left Pressed (esse código não é meu, achei na net):
Código:
if atirar = true and image_speed = 0
{
  atirar = false
  image_speed = 0.15
  alarm[1]=30
  sound_play(snd_colt)
  instance_create(objCamera.x,objCamera.y,bullet)
  objCamera.zdirection += 0.02
  tiros -= 1
}
Animation End :
Código:
if current_image=spr_arma {image_speed=0}
if current_image=spr_arma_reload {current_image=spr_arma image_speed=0 recarrega=false}
Draw :
Código:
{
  d3d_set_projection_ortho(0,0,640,480,0);
  draw_sprite(current_image,-1,x+30,y+20)
}

Mas tem algum problema no código que eu não consigo achar, quando o objeto muda a imagem para recarregar, ele executa a animação, volta pra imagem 0 e fica executando a mesma imagem sem parar, alguém poderia ajudar?


Última edição por Need 90 em Dom 17 Jun 2012, 12:53, editado 1 vez(es)

Need 90

Ranking : Nota B
Número de Mensagens : 787
Data de inscrição : 16/01/2012
Notas recebidas : D+A+B
Reputação : 7
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://need90games.blogspot.com.br

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido]Sprite travando depois de executar animação

Mensagem por Witen em Sab 16 Jun 2012, 18:35

Que vergonha!!! rsrsrs, uma duvida simples dessa alguém deveria reponde no minimo 3 horas após a postagem.

Bom. vamos lá! troque:

Código:
if current_image=spr_arma {image_speed=0}
if current_image=spr_arma_reload {current_image=spr_arma image_speed=0 recarrega=false}
Por:
Código:
if current_image=spr_arma {image_speed=0}
if current_image=spr_arma_reload {image_speed=0
{current_image=spr_arma}  {recarrega=false}}
Ve se funciona! sabe por que não deu certo por que o game maker lé comando apos comando se você colocou o comando troca de imagem na frente current_image não executara mais o image_speed. Espero que esteja certa minha teoria XD

Witen

Ranking : Sem avaliações
Número de Mensagens : 515
Idade : 17
Data de inscrição : 23/05/2012
Reputação : 36
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://www.wibix.webs.com

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido]Sprite travando depois de executar animação

Mensagem por Need 90 em Sab 16 Jun 2012, 23:20

Isso não vai mudar nada .-.
Eu não entendo o que está acontecendo, afinal o código tem uma lógica.

Need 90

Ranking : Nota B
Número de Mensagens : 787
Data de inscrição : 16/01/2012
Notas recebidas : D+A+B
Reputação : 7
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://need90games.blogspot.com.br

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido]Sprite travando depois de executar animação

Mensagem por Luan Maia em Dom 17 Jun 2012, 00:44

Cara, sou muito ruim em conseguir entender códigos de outros, porque eu costumo deixar tudo identado ai acabo tendo dificuldades. Mas enfim, eu acho que é os "image_speed=0" no script abaixo.
Need 90 escreveu:
Animation End :
Código:
if current_image=spr_arma {image_speed=0}
if current_image=spr_arma_reload {current_image=spr_arma image_speed=0 recarrega=false}
Tenta explica melhor esse "image_speed=0" se não for, porque eu não entendi seu uso.

Até mais! flw

Luan Maia

Ranking : Sem avaliações
Número de Mensagens : 399
Idade : 20
Data de inscrição : 01/07/2010
Notas recebidas : D+C+C+D
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://blogluanmaia.blogspot.com.br/

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido]Sprite travando depois de executar animação

Mensagem por Witen em Dom 17 Jun 2012, 10:46

Tenta explica melhor esse "image_speed=0" se não for, porque eu não entendi seu uso.
Serio? não sabe o que significa image speed? rsrsrs, esta mal mesmo '-' image speed é a velocidade que o sprite é reproduzido.

Isso não vai mudar nada .-.
Eu não entendo o que está acontecendo, afinal o código tem uma lógica.

Você pelo menos tentou? Um pode ser também o evento! mude a 2° linha para step, irar funcionar só que a animação vai parar em menos de 1 segundo...

Witen

Ranking : Sem avaliações
Número de Mensagens : 515
Idade : 17
Data de inscrição : 23/05/2012
Reputação : 36
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://www.wibix.webs.com

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido]Sprite travando depois de executar animação

Mensagem por Need 90 em Dom 17 Jun 2012, 12:13

a animação de recarga tem 3 imagens apenas, não quero que corte a animação ao meio.

arrumei aqui, só que tive que remover a variável cartucho D=
Podem fechar

Need 90

Ranking : Nota B
Número de Mensagens : 787
Data de inscrição : 16/01/2012
Notas recebidas : D+A+B
Reputação : 7
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://need90games.blogspot.com.br

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido]Sprite travando depois de executar animação

Mensagem por Conteúdo patrocinado Hoje à(s) 04:53


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum