Instance_destroy() erro!!!!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido Instance_destroy() erro!!!!

Mensagem por kadini em Seg 30 Abr 2012, 17:55

Olá boa noite a todos.

Resumindo o meu problema é o seguinte:

Tenho na Room 3 objetos que ao clicar neles ele criao outro objeto (um obj_tranparente) que será colocado na room o "obj_tranparente" segue o rato e ao clicar com o botao esquerdo ele muda para outro obj_final, que é o obj_final que ficara na posiçao correta!, até aqui todo OK.

Mas eu lembreime que o obj_tranparente podia ser cancelado ao clicar com um botao direito, ou seja bastava por right mouse e um instance_destroy().

Corri o jogo e deu todo certinho mas ao fim do obj_tranparente ser destruído, eu ao clicar no objeto que cria o obj_tranparente, cria-o mas fica invisivel ( eu sei que cria pq ao criar o obj_tranparente eu perco recursos )

Por que é que isto acontece??????


kadini

Número de Mensagens : 192
Idade : 20
Data de inscrição : 02/03/2012
Reputação : 4
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: Instance_destroy() erro!!!!

Mensagem por Eudes - Hyo em Seg 30 Abr 2012, 19:32

fala aí, blz.

então..vc clica em um "obj_criador" que criar um "obj_transparente", ...
mas esse "obj_transparente" fica TRANSPARENTE ?

é isso?
mas não era pra ser assim? já que ele é transparente.

Eudes - Hyo

Ranking : Nota B
Número de Mensagens : 513
Idade : 32
Data de inscrição : 02/06/2009
Notas recebidas : E + B+B
Reputação : 27
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: Instance_destroy() erro!!!!

Mensagem por Bruno_7l em Seg 30 Abr 2012, 21:59

nu intendi naum deve ser q o sprite e transparente na 1ª animaction e a image_speed ta 0 + mi isplica direitu c naum foi issu q eu nu intendi

Bruno_7l

Número de Mensagens : 20
Data de inscrição : 04/04/2012
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: Instance_destroy() erro!!!!

Mensagem por kadini em Ter 01 Maio 2012, 10:03

ok vou tentar expressar-me melhor, esqueçam os objectos transparente, esqueçam isso....

Recomeçando: Voces devem conhecer o jogo AGE OF EMPIRE, que para construir as casas, nos 1º clicamos no botão da respectiva casa ( EX: obj_b_castelo ), depois o jogo cria um outro objecto, que é o objeto que vai seguir o rato, e ver em que posiçao vai ficar ( EX: obj_castelo_1 ), e finalmente quando nós clicamos com o botão esquedo ele muda do objeto movel para um objeto fixo, "cria a casa", ( EX:obj_castelo ), mas por exemplo nos engana-mo nos, criamos construir, um castelo e clicamos no botão que cria a casa do lenhador ( um exemplo ), como nos nao queremos criar a casa do lenhador mas sim o castelo, basta clicar com o botao direito do mouse e o objeto destrui-se (lembrando que ao clicar no botao da casa do lenhador, cria o objeto casa lenhador movel, e é esse que é destruido).

eu quero que ao clicar com o botao direito do mouse no objeto ( ex: a casa do lenhador ( que eu nao cria construir )) ele se destruía, para isso fiz right mouse e como codigo pus instance_destroy().

O problema esta depois, ou seja, eu clico no botao, depois botao direito para deletar o objeto que se move com o rato, e depois quando vou clicar em outro botao, o objeto nao se cria

tem de ler com atençao para perseber o meu problema, aguardo ajuda Smile

kadini

Número de Mensagens : 192
Idade : 20
Data de inscrição : 02/03/2012
Reputação : 4
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: Instance_destroy() erro!!!!

Mensagem por Eudes - Hyo em Ter 01 Maio 2012, 10:52

agora eu entendi.
depois que vc destroi , ele não cria mais, o que antes acontecia sem problemas.
tente por o código que usa para criar esse objeto que segue o Mouse e o código que usa para destruir ele quando clica com o botão Direito do mouse.

Eudes - Hyo

Ranking : Nota B
Número de Mensagens : 513
Idade : 32
Data de inscrição : 02/06/2009
Notas recebidas : E + B+B
Reputação : 27
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: Instance_destroy() erro!!!!

Mensagem por .:Allison:. em Ter 01 Maio 2012, 11:25

bom, aonde você está colocando o código é muito importante, você poderia nos passar o código, assim ficaria bem melhor.

.:Allison:.

Ranking : Nota B
Número de Mensagens : 630
Idade : 20
Data de inscrição : 25/07/2010
Notas recebidas : B
Reputação : 4
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

http://clubmaker.forumeiros.com

Voltar ao Topo Ir em baixo

Resolvido Re: Instance_destroy() erro!!!!

Mensagem por kadini em Qua 02 Maio 2012, 14:24

Malta, esta resolvido, quando esta a fazer o que o Allison disse, eu ao mesmo tempo esta a rever o codigo e troquei true com false, foi mal!!!, pensava que tinha posto false, mas afinal tinha posto true, foi mal......

Allison obrigado pela tua ajuda indiretamente

@@edit: e aos outros tb um obrigado

kadini

Número de Mensagens : 192
Idade : 20
Data de inscrição : 02/03/2012
Reputação : 4
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: Instance_destroy() erro!!!!

Mensagem por Conteúdo patrocinado Hoje à(s) 16:25


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum