Conectar-se
Quem está conectado
33 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 33 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 20/01/2009
Número de Mensagens : 9
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuário

[RESOLVIDO] Onde estou errando?

em Qua 21 Jan 2009, 00:17
Olá, eu comecei a usar o Game Maker ontem e já aprendi algumas coisas básicas através de alguns tutoriais. Ainda não comecei a desenvolver nenhum jogo, porém estava tentando fazer com que a tela acompanhasse o personagem seguindo algumas dicas que li aqui mesmo no fórum, mas não consegui. Gostaria que alguém me dissesse onde foi que eu errei.

Criei um sprite, um object e uma room:



Inseri os movimentos "para direita" e "para esquerda" no object:



Aumentei a largura da room de 640 para 2000.



Na aba "views" marquei as opções "Enable the use of Views" e "Visible when room starts" e em "Object following" selecionei o "object0" que é o objeto que eu configurei para se mover:



Quando rodo o jogo não dá certo. Quando o objeto toca a borda direita da janela, ele pára, e a borda esquerda ele atravessa e some da tela.


Última edição por Felipe em Qua 21 Jan 2009, 22:13, editado 1 vez(es) (Razão : Problema resolvido)
avatar
Data de inscrição : 20/11/2008
Número de Mensagens : 350
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuáriohttp://lap1994.deviantart.com/

Re: [RESOLVIDO] Onde estou errando?

em Qua 21 Jan 2009, 00:51
Ele naum para. Q posição dele na view eh a msm mas na room eh diferente.
Pra provar: Coloque esse imagem nos backgrounds . Defina como background da room e teste denovo.
avatar
Data de inscrição : 19/03/2008
Número de Mensagens : 267
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: [RESOLVIDO] Onde estou errando?

em Qua 21 Jan 2009, 01:19
pelo que eu entendi você esta com duvida porque o fantasma não para mesmo a tela segundo ele e a tela chegando ao fim bom se for isso o objeto não para mesmo ele não obedece os limites da room para fazer isso sera necessário fase lo por script

Código:
if x < 0 or y < 0 or x > view_wview or y > view_hview{speed = 0}

este script impede que o objeto que tiver ele dentro não saia dos limites da room.

coloque ele dentro do evento step em um esecute code

a e por favor quando você fizer outo post por favor fale sua pergunta não comente apenas oque você fez, não que isso seja ruim pelo contrario é ótimo porque assim entendemos oque você esta pensando mas é importante saber seu objetivo como por exp.

quero que ele deixe de sair pelo lado esquerdo da tela. ou, como que faz pra ele não sair por lugar nem um???

isto com certeza ajudara a entender o objetivo com sua pergunta obrigado. Very Happy
avatar
Data de inscrição : 20/11/2008
Número de Mensagens : 350
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuáriohttp://lap1994.deviantart.com/

Re: [RESOLVIDO] Onde estou errando?

em Qua 21 Jan 2009, 09:47
Vc cabou de postar como reproduzir o problema q ele descreve naum a solução. A verdade é q o problema dele naum é o código, pois este não existe, é q o objeto se move mas a tela se move junto logo o objeto fica na mesma posição na tela entretanto numa posição diferente na room.
Se você colocar outros objetos na room q fiquem parados como cenario você vai perceber q a tela se move junto com o objeto. Coloque uns objetos "parede" na room e teste denovo.
avatar
Data de inscrição : 20/01/2009
Número de Mensagens : 9
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuário

Re: [RESOLVIDO] Onde estou errando?

em Qua 21 Jan 2009, 09:56
Lap1994
Vc está certo!
Aquele fundo cinza padrão dava a impressão de que o objeto estava parado, mas com o background percebi que ele estava em movimento. Valeu!
avatar
Data de inscrição : 19/03/2008
Número de Mensagens : 267
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: [RESOLVIDO] Onde estou errando?

em Qua 21 Jan 2009, 16:39
bom eu tentei ajudar é q realmente não tinha entendido oque o Felipe queria diser
avatar
Data de inscrição : 20/01/2009
Número de Mensagens : 9
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuário

Re: [RESOLVIDO] Onde estou errando?

em Qua 21 Jan 2009, 22:13
Valeu tbm, reddragon!
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum