Conectar-se
Quem está conectado
35 usuários online :: 4 usuários cadastrados, Nenhum Invisível e 31 Visitantes

gart30, rafaelviodres1, Thiago_o_programador, Willy

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota D
Notas recebidas : C+D+D+D
Data de inscrição : 03/03/2011
Número de Mensagens : 252
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

[Dúvida] com sub-image

em Sex 06 Jan 2012, 19:38
É o seguinte galera ontem assistindo Crhis tive a idéia de criar um jogo Asteroids
E ai surge minha dúvida
Eu tenho um sprite com 3 frames , ou seja , são 3 imagens em um sprite
Então coloquei o o_meteoro com esse sprite e queria que ele escolhesse uma das sub-images
, mas não funiconou.
Eis aqui o código que eu tentei:
Código:
Create event:
image_index=choose(1,2,3)
avatar
Ranking : Nota C
Notas recebidas : C
Data de inscrição : 28/10/2008
Número de Mensagens : 819
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Dúvida] com sub-image

em Sex 06 Jan 2012, 19:41
Deveria funcionar pois sempre uso esta forma quando quero usar imagens diferentes nos sprites, mas leve em conta que começa no 0 e não no 1, então o certo é :
Código:
image_index=choose(0,1,2)
avatar
Ranking : Nota C
Notas recebidas : C
Data de inscrição : 30/07/2011
Número de Mensagens : 928
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 1
Ver perfil do usuáriohttp://luizpontes.tk/

Re: [Dúvida] com sub-image

em Sex 06 Jan 2012, 19:51
Acho que é o image_speed. Sete ele pra 0 antes.
Convidad
Convidado

Re: [Dúvida] com sub-image

em Sex 06 Jan 2012, 20:23
Resumindo tudo,use
Código:
image_speed=0;image_index=irandom(2);
Flws
avatar
Ranking : Nota D
Notas recebidas : C+D+D+D
Data de inscrição : 03/03/2011
Número de Mensagens : 252
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Dúvida] com sub-image

em Sex 06 Jan 2012, 23:28
Era isso aí mesmo TRFN e Luiz ,
Mas mesmo assim obrigado CRP-MAX
Podem trancar
avatar
Ranking : Nota A
Notas recebidas : A+A
Data de inscrição : 20/03/2010
Número de Mensagens : 1134
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 1
   : 0
   : 1
Ver perfil do usuáriohttps://www.facebook.com/seito.washiro.7

Re: [Dúvida] com sub-image

em Sab 07 Jan 2012, 02:17
Vc pode usar image_single tbm,
Código:
image_single=irandom(image_number);
assim n precisadefinir o image_speed para 0
Convidad
Convidado

Re: [Dúvida] com sub-image

em Sab 07 Jan 2012, 09:15
Boa jiraya,essa eu nem conhecia ^.^'
O bom e que nem precisa-se saber numero de sub-images com o image_number.
Agora acho que tá resolvido.
Flwws
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum