Erro acontecendo apos o meu logotipo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Erro acontecendo apos o meu logotipo

Mensagem por GALAXY GAMES em Qui 01 Dez 2011, 08:56

Pessoal, estou fazendo uma nova versão do Super Mario Slot Machine. Eu fiz um logotipo simples meu para colocar na inicialização do jogo fiz assim:

Criei um sprite (com o logo)
Criei um som (com o som do logo)
Criei uma Time Line (com o tempo do logo para mudar de room)
Criei um objeto com com o sprite do logo executando o som e a Time Line no Evento Create

Antes de mim fazer isso, estava tudo bem (funcionando corretamente) depois que eu fiz isso e botei o jogo para rodar gerou esse erro ae:


GALAXY GAMES

Ranking : Nota E
Número de Mensagens : 439
Data de inscrição : 03/10/2011
Notas recebidas : D+E+E
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Erro acontecendo apos o meu logotipo

Mensagem por luiz_eldorado em Qui 01 Dez 2011, 09:27

Então o problema não é esse aí. Tem algum problema, com certeza, em algum script, DLL ou extensão. Talvez seja pois você não usou as funções pra "iniciar" o sistema (algo que muitas DLL usam). Tente colocar alguma coisa, no começo do jogo, scripts que tenham no nome: "init", "define", "create", etc...

luiz_eldorado

Ranking : Nota C
Número de Mensagens : 928
Idade : 17
Data de inscrição : 30/07/2011
Notas recebidas : C
Reputação : 47
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 1

http://luizpontes.tk/

Voltar ao Topo Ir em baixo

Re: Erro acontecendo apos o meu logotipo

Mensagem por Super Games em Qui 01 Dez 2011, 10:26

Olá Galaxy,

Serei rápido agora, por que não tenta usar Alarms?É Bem mais fácil do que usar Time Line, e se quiser eu posso ensinar como se usa caso não saiba, ok?


Espero ter ajudado...

Super Games

Ranking : Nota D
Número de Mensagens : 2704
Idade : 18
Data de inscrição : 10/06/2010
Notas recebidas : D
Reputação : 10
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Erro acontecendo apos o meu logotipo

Mensagem por Klior em Qui 01 Dez 2011, 10:38

O problema é que a variável global.spin_enabled não existe, verifique de declarar essa variável global antes de usar o script Handle.

Klior

Número de Mensagens : 426
Idade : 25
Data de inscrição : 07/03/2010
Reputação : 13
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Erro acontecendo apos o meu logotipo

Mensagem por Super Games em Qui 01 Dez 2011, 11:13

Klior escreveu:O problema é que a variável global.spin_enabled não existe, verifique de declarar essa variável global antes de usar o script Handle.
Para completar o que o Klior disse, é necessário cria-la no Create do objeto, ok?

Super Games

Ranking : Nota D
Número de Mensagens : 2704
Idade : 18
Data de inscrição : 10/06/2010
Notas recebidas : D
Reputação : 10
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Erro acontecendo apos o meu logotipo

Mensagem por irlansn em Qui 01 Dez 2011, 11:36

O erro diz que essa variável: spin_enabled não existe.
Onde você criou ela?
Foi em um evento game start?
Porque se foi, o seu problema é esse. Antes da room com a logo ser criada o jogo se iniciava na room do jogo, não é mesmo? Desta forma o objeto responsável pela criação da variável, esta presente na inicialização do jogo.
Coloque o objeto responsável pela criação da variável na room da logo, ou coloque o evento no create.
Acho que é isso flw


irlansn

Ranking : Nota C
Número de Mensagens : 482
Idade : 18
Data de inscrição : 18/01/2011
Notas recebidas : B+D
Reputação : 5
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Erro acontecendo apos o meu logotipo

Mensagem por CRP-Max em Qui 01 Dez 2011, 12:37

Estou com esse mesmo problema no GM 8.1, eu posso criar a variável onde eu quiser que o erro continua, ja criei ela no create do player, no game start, em um objeto de controle...... Mesmo assim a variável global.dir, continua não existindo...
Como se arruma isto?
Zangado

CRP-Max

Ranking : Nota C
Número de Mensagens : 819
Idade : 41
Data de inscrição : 28/10/2008
Notas recebidas : C
Reputação : 29
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Erro acontecendo apos o meu logotipo

Mensagem por Itibere10 em Qui 01 Dez 2011, 12:52

Não sei certo, mas tente declarar ela no evento create...

Vou dar 1 opção que talvez funcione:

1- Crie um objeto na room do LOGO
2- Adicione um evento Create ao objeto e declare a variável (No caso do amigo acima, a variável se não me engano é spin_enabled)

E veja se funcionou agora, Boa Sorte... Happy

Itibere10

Número de Mensagens : 84
Idade : 18
Data de inscrição : 01/12/2011
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Erro acontecendo apos o meu logotipo

Mensagem por Conteúdo patrocinado Hoje à(s) 09:55


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum