Conectar-se
Quem está conectado
17 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 17 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota A
Notas recebidas : A+A+A+A+A+A+A
Data de inscrição : 06/06/2009
Número de Mensagens : 2264
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 4
   : 2
   : 1
Ver perfil do usuário

[RESOLVIDO] Problemas com tileset

em Sab 06 Ago 2011, 12:09
Olá galera! Como sabem, estou trabalhando num projeto já tem algum tempo, devido a problemas tive que começar a recriar a engine. Porém, um problema que também existia na versão antiga tá me tirando do sério.

Como podem ver o tileset está com inúmeras falhas, ele fica cortado. Não há problema nenhum no tileset em si, o problema provavelmente está na resolução, pois quando alterada ele "corrige" o problema, embora continue torto.

O que pode estar causando isso, e qual poderia ser a maneira mais eficiente de corrigir isso? Valew pessoal!
afro


Última edição por SIGILOSO em Dom 07 Ago 2011, 09:33, editado 1 vez(es)
avatar
Ranking : Sem avaliações
Data de inscrição : 11/10/2009
Número de Mensagens : 2184
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [RESOLVIDO] Problemas com tileset

em Sab 06 Ago 2011, 12:15
Hmmm... Eu suponho que seja a definição "horizontal sep(aration)" e "vertical sep(aration)" nas propriedades do background. Mas pode ser até mesmo a largura e altura definida para cada tile que esteja com problema. As vezes um mínimo pixel não preenchido pelo padrão de largura e altura pode resultar nisso. Veja se na sua tileset não há nenhum tile fora do padrão.
avatar
Ranking : Nota A
Notas recebidas : A+A+A+A+A+A+A
Data de inscrição : 06/06/2009
Número de Mensagens : 2264
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 4
   : 2
   : 1
Ver perfil do usuário

Re: [RESOLVIDO] Problemas com tileset

em Sab 06 Ago 2011, 12:24
Acredito que não haja problemas, pois no editor de roms o tileset não apresenta nenhuma falha.

Tenho quase certeza de que o problema está na resolução, a sprite do player fica "tremendo" algumas vezes, quando ele pula, como se estivesse em dois pontos diferentes na coordenada X.
afro
Data de inscrição : 12/04/2010
Número de Mensagens : 340
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [RESOLVIDO] Problemas com tileset

em Sab 06 Ago 2011, 13:12
Não sei se estou falando bobagem mas pode ser uma diferença nas configurações da view. Veja os valores de "View in room" e de "Port on screem" nas configurações da room. Boa tarde.
avatar
Ranking : Nota D
Notas recebidas : D
Data de inscrição : 19/02/2011
Número de Mensagens : 285
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [RESOLVIDO] Problemas com tileset

em Sab 06 Ago 2011, 13:19


Você Fez Isto nos tilesets igual a imagem????
avatar
Ranking : Nota A
Notas recebidas : A+A+A+A+A+A+A
Data de inscrição : 06/06/2009
Número de Mensagens : 2264
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 4
   : 2
   : 1
Ver perfil do usuário

Re: [RESOLVIDO] Problemas com tileset

em Dom 07 Ago 2011, 09:32
Andei vendo alguns tópicos da GMC, parece que esse é um bug do GM mesmo (outro...) referente a placas de vídeo NVIDIA... Nesse caso resolvi dobrar logo a definição do game, além de resolver meu problema ainda deixo o jogo muito mais bonito visualmente.

Obrigado pela atenção e ajuda, galera! Resolvido Smile
afro
avatar
Ranking : Nota A
Notas recebidas : A+A
Data de inscrição : 20/03/2010
Número de Mensagens : 1134
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 1
   : 0
   : 1
Ver perfil do usuáriohttps://www.facebook.com/seito.washiro.7

Re: [RESOLVIDO] Problemas com tileset

em Dom 07 Ago 2011, 11:25
adicione mais 1 a largura da view, ou seja se for 320x240 entao coloque 321x241, eu ja tive o mesmo problema e resolvi configurando o tamanho da view.
avatar
Ranking : Nota A
Notas recebidas : A+A+A+A+A+A+A
Data de inscrição : 06/06/2009
Número de Mensagens : 2264
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 4
   : 2
   : 1
Ver perfil do usuário

Re: [RESOLVIDO] Problemas com tileset

em Dom 07 Ago 2011, 11:56
Funcionou Jiraya, direitinho... caraca, tão simples, hehe.
Mesmo que 640x480 deixe o jogo mais bonito, prefiro trabalhar com 320x240, faz mais a cara do game. Valew! o/
afro
avatar
Data de inscrição : 07/03/2010
Número de Mensagens : 426
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [RESOLVIDO] Problemas com tileset

em Dom 07 Ago 2011, 15:18
Hmm, muito bom saber disso, já tive o mesmo problema também.
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum