Conectar-se
Quem está conectado
21 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 21 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota E
Notas recebidas : E-D-E-E
Data de inscrição : 18/12/2010
Número de Mensagens : 258
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

O que tem de errado com esse código?

em Qui 28 Jul 2011, 08:09
Código:
correndo=false
parado=true
pulando=false
perdendo=false
atacando=false
image_speed=0.25
alarm[2] = 10 + round(random(15))

Erro:
Código:

___________________________________________
FATAL ERROR in
action number 1
of Create Event
for object obj_Orochimaru:

COMPILATION ERROR in code action
Error in code at line 3:
  pulando=false
          ^
at position 9: Variable name expected.
avatar
Data de inscrição : 26/09/2008
Número de Mensagens : 890
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 11

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: O que tem de errado com esse código?

em Qui 28 Jul 2011, 08:15
Estranho... Não parece ter nada errado.
O código está exatamente assim?
Tem algum outro código além desse?
Você já tentou fechar e reabrir o GM?
avatar
Data de inscrição : 25/03/2010
Número de Mensagens : 666
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 2

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: O que tem de errado com esse código?

em Qui 28 Jul 2011, 08:16
Deleta o code do drag and drop e cria outro, uma vez fiz isso e funcionou.
avatar
Ranking : Nota D
Notas recebidas : D
Data de inscrição : 10/06/2010
Número de Mensagens : 2704
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 10

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: O que tem de errado com esse código?

em Qui 28 Jul 2011, 10:07
Muito estranho, não é para isto está acontecendo não!Eu mesmo não vi erro algum no código, só se for que o GameMaker está com algum erro, porque tenho 95% de certeza que este código está totalmente certo.
Tente passar o código para D&D, mas uma pergunta Lucas, qual outro código você está usando?Será que não é problema a respeito de variáveis globais?
avatar
Ranking : Sem avaliações
Data de inscrição : 11/10/2009
Número de Mensagens : 2184
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 106

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: O que tem de errado com esse código?

em Qui 28 Jul 2011, 10:23
Amigo, tem certeza de que você não tem nenhuma sprite, objeto ou qualquer outro resource que contenha o nome dessa variável? Quando esse tipo de coisa acontece, principalmente no Create event, é de absoluta certeza de que é isso que acontece. É para isso que geralmente se coloca prefixos como spr_, obj_ e afins, para evitar esse tipo de coisa.
avatar
Ranking : Nota A
Notas recebidas : A-A-A-A-B
Data de inscrição : 04/07/2010
Número de Mensagens : 1028
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 42

Prêmios
   : 1
   : 0
   : 1
Ver perfil do usuário

Re: O que tem de errado com esse código?

em Qui 28 Jul 2011, 10:26
Variable name expected.
Esse erro indica que você criou um objeto, sprite, som, ou qualquer outro recurso usando o nome 'pulando' ou o nome 'false', tente renomear os recursos padronizando, por exemplo:

Sprites:
spr_andando
spr_pulando
spr_correndo

Objetos:
obj_jogador
obj_inimigo

Sons:
snd_pulo

E por ai vai.

Outra coisa, olha nos recursos e confere se não tem nenhum com o mesmo nome, isso também pode gerar esse conflito, é só ir em 'Scripts' > 'Check Resource Names', se estiver tudo certo, tem que escrever:
No name conflicts were found
(Não foi encontrado conflitos com os nomes)

Editado: O loco... Praticamente a mesma mensagem do Markituh.
avatar
Ranking : Nota E
Notas recebidas : E-D-E-E
Data de inscrição : 18/12/2010
Número de Mensagens : 258
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: O que tem de errado com esse código?

em Qui 28 Jul 2011, 10:30
@Super Games escreveu:Muito estranho, não é para isto está acontecendo não!Eu mesmo não vi erro algum no código, só se for que o GameMaker está com algum erro, porque tenho 95% de certeza que este código está totalmente certo.
Tente passar o código para D&D, mas uma pergunta Lucas, qual outro código você está usando?Será que não é problema a respeito de variáveis globais?

Os outros códigos que eu to usando é esses:

Create:
Código:
correndo=false
parado=true
pulando=false
perdendo=false
atacando=false
image_speed=0.25
alarm[2] = 10 + round(random(15))

Alarm 0:
Código:
if atacando=false {parado=false
correndo=true}
alarm[2] = 10 + round(random(15))

Alarm 1:
Código:
if atacando=false {correndo=false
parado=true}
alarm[2] = 10 + round(random(15))

Alarm 2:

Código:
if atacando=false {alarm[1] = 10 + round(random(15))}
if atacando=false {alarm[0] = 10 + round(random(15))}

step:
[code]if place_free(x,y+1) {gravity=0.5}else{gravity=0}if vspeed>12 {vspeed=12}
if parado=true {sprite_index=spr_oro_par}
if correndo=true {sprite_index=spr_oro_cor if obj_Naruto.x>x {hspeed=10}else{hspeed=-10}}

Colisão com o chão:

[code]move_contact_solid(direction,12)
vspeed=0
pulando=false
hspeed=0 and atacando=false {parado=true}
if correndo=true and perdendo=false {y-=2}[/code]

Animation End:

[code]if atacando=true
{atacando=false parado=true correndo=false alarm[2] = 10 + round(random(15))}[/code]

Os códigos eu retirei de uma engine, não editei a engine, somente peguei os códigos
avatar
Ranking : Sem avaliações
Data de inscrição : 11/10/2009
Número de Mensagens : 2184
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 106

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: O que tem de errado com esse código?

em Qui 28 Jul 2011, 10:36
Fiuz: Hehehe, isso que dá não olhar as respostas quando o fórum avisa "foi postada uma mensagem antes da sua" tongue. Mas foi boa a sua sugestão de ir em Check Resource Names, nem sabia que esse comando existia, até torna o processo bem mais rápido. De qualquer modo, prefixar os recursos é sempre uma boa pedida Smile

Lucas: A resposta para seu problema pode estar na minha mensagem ou na do Fiuz'en Had(por sinal a do Fiuz'en é bem mais informativa...)
avatar
Data de inscrição : 20/07/2011
Número de Mensagens : 30
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: O que tem de errado com esse código?

em Qui 28 Jul 2011, 10:37
Compare de onde vc obteve esse codigo e onde vc esta usando, ou seja a versão do GM que vc viu esse codigo sendo usado é a mesma no qual vc ta usando?.... eu tive um problema parecido com um codigo que eu estava usando no GM5 quando fui usa-lo no GM6 só que comigo era o seguinte: numa das versões escrevia deativate e em outra tinha que escrever desativate.... ou seja o erro era apenas a letra "s" que uma versão dispensava e outra não....
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum