[Resolvido] Problema com fazer o personhagem atacar

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

[Resolvido] Problema com fazer o personhagem atacar

Mensagem por Renanruan em Ter 19 Jul 2011, 22:46

Oi, eu sou novo no forum e tambem nao sei muito sobre o game maker.
Atualmente estou tentando construir um jogo de plataforma. Ja construi um menu com opções, ja fiz o personagem, inimigo, barras de vida e room. Consegui programar o personagem e o inimigo para andar e pular. Mas quando eu programo o ataque ele nao funciona. Ja estou a tres dias tentando, ja troquei varias vezes o script, peguei o de uns engines ou que encontrei aqui no forum, mas sempre ocorrem os mesmos erros:

1- O personagem tem 5 subimagens no sprite de ataque, quando aperto o botao, ele vai ate alguma outra (a 2, 3 ou 4) muito rapidamente e para sem executar o ataque realmente

OU

2- O personagem fica repitindo o sprite de ataque varias vezes, sem executar o ataque.

Ja tentei de tudo, li apostilas e outros topicos. Nao sei mais o que fazer. Gostaria de saber se alguem tem ideia do que esta acontecendo? Sera que tem um bug no meu programa? Sera que eu nao to achando o erro ou repetindo ele? Ou o erro esta em alguma outra parte de programa?

Muito obrigado pela atenção, e desculpa nao ter sido muito direto.


Última edição por Renanruan em Qui 21 Jul 2011, 17:06, editado 1 vez(es)

Renanruan

Número de Mensagens : 6
Idade : 22
Data de inscrição : 19/07/2011
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: [Resolvido] Problema com fazer o personhagem atacar

Mensagem por Pickler em Ter 19 Jul 2011, 23:00

Bom, você poderia detalhar maiso seu problema? Por exemplo como é o ataque dele...E como é para ser...

Bom, para fazer a sprite se mexer mais devagar é só usar o image_speed
Ex:

image_speed=0.5

Você coloca esse código no código de ataque quando aperta o botão e muda de sprite...

Pickler

Número de Mensagens : 101
Idade : 19
Data de inscrição : 22/06/2011
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: [Resolvido] Problema com fazer o personhagem atacar

Mensagem por Super Games em Qua 20 Jul 2011, 10:10

Bom...existe uma função chamada "image_speed"(Velocidade da imagem), ela simplismente faz que a sprite mova-se devagar, caso tenha problemas para utiliza-la, a executação dela é assim:
Código:
image_speed=tal velocidade

Super Games

Ranking : Nota D
Número de Mensagens : 2704
Idade : 18
Data de inscrição : 10/06/2010
Notas recebidas : D
Reputação : 10
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: [Resolvido] Problema com fazer o personhagem atacar

Mensagem por Renanruan em Qua 20 Jul 2011, 15:38

Ja tentei mudar o image_speed mas nao funcionou.
Olha como fiz:

Código:

if (keyboard_check_pressed(ord("Z"))) && (noar=false)
{
if (andando==false)
{

if (lado==0)
{
sprite_index=NarutoSocoE;
}

if (lado==1)
{
sprite_index=NarutoSocoD;
}

}

Declarei todas as variaveis certinho, mas o personagem fica repetindo o sprite varias vezes mesmo se eu desprecionar (nao existe isso né?) o botao.


mesmo assim obrigado

Renanruan

Número de Mensagens : 6
Idade : 22
Data de inscrição : 19/07/2011
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: [Resolvido] Problema com fazer o personhagem atacar

Mensagem por Pickler em Qua 20 Jul 2011, 16:13

Faça o seguinte crie uma variavel no create:
podeatacar=true

coloque isso no botão de atacar

Código:
if (keyboard_check_pressed(ord("Z"))) && (noar=false)
{
if (andando==false)
{

if (lado==0) and global.podeatacar=true
{
global.podeatacar=false
sprite_index=NarutoSocoE;
}

if (lado==1) and global.podeatacar=true
{
global.podeatacar=false
sprite_index=NarutoSocoD;
}

}

e na colisão com o inimigo coloque
Código:

global.podeatacar=true

Pickler

Número de Mensagens : 101
Idade : 19
Data de inscrição : 22/06/2011
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: [Resolvido] Problema com fazer o personhagem atacar

Mensagem por Convidad em Qua 20 Jul 2011, 16:20

se o problema persistir pode me enviar uma engine deste jogo,sei lah...
e para q eu tenha uma ideia básica do que é seu problema,pois assim ta complicado .

Convidad
Convidado


Voltar ao Topo Ir em baixo

Re: [Resolvido] Problema com fazer o personhagem atacar

Mensagem por Renanruan em Qua 20 Jul 2011, 17:04

Eu acho que consegui identificar o problema, mas nao sei resolve-lo.

Eu coloquei o image_speed=0.1 , e o ataque foi executado certinho ( 1 ciclo, apesar de lento)

Quando coloquei image_speed=0.27, o sprite teve 4 ciclos e depois parou

Quando coloquei image_speed=0.4, o sprite ficou rodando um monte de vezes

Muito obrigado por tentarem mas acho que o problema ta no PC ou sei la. Sad


EDIT:

Eu deixei o image_speed=0.2 , a velocidade ta +-, no entando da 1 ciclo certinho. Vou deixar assim mesmo, nao sei mais o que fazer. OBRIGADO de novo a voces.

Renanruan

Número de Mensagens : 6
Idade : 22
Data de inscrição : 19/07/2011
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: [Resolvido] Problema com fazer o personhagem atacar

Mensagem por Conteúdo patrocinado Hoje à(s) 00:31


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum