[RESOLVIDO]Problema INI

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido [RESOLVIDO]Problema INI

Mensagem por Supersonic933 em Ter 17 Maio 2011, 15:04

Estou estudando save em .INI, e coloquei o code no CREATE de um obj:

Código:

lives=3
global.arma1=true
ini_open("mygame.ini")
ini_write_real("Geral","Vidas",lives)
ini_write_string("Geral","Arma1",global.arma1)
ini_close()

Mas, no ini dá:
Código:

[Geral]
Vidas=3
Arma1=
A pergunta é: Porque não salvou o Arma1?


Última edição por Supersonic933 em Ter 17 Maio 2011, 15:20, editado 1 vez(es)

Supersonic933

Ranking : Nota E
Número de Mensagens : 396
Data de inscrição : 14/02/2011
Notas recebidas : E
Reputação : 13
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://planetaanalisandogames.blogspot.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Problema INI

Mensagem por saim em Ter 17 Maio 2011, 15:18

true não é um valor de texto. tente colocar "true", com aspas e veja se funciona.

saim

Ranking : Nota B
Número de Mensagens : 2964
Idade : 38
Data de inscrição : 14/01/2011
Notas recebidas : C-D-A-B
Reputação : 121
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   : 3

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Problema INI

Mensagem por Supersonic933 em Ter 17 Maio 2011, 15:19

saim escreveu:true não é um valor de texto. tente colocar "true", com aspas e veja se funciona.
FUNCIONOU! Podem fechar!

Supersonic933

Ranking : Nota E
Número de Mensagens : 396
Data de inscrição : 14/02/2011
Notas recebidas : E
Reputação : 13
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://planetaanalisandogames.blogspot.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Problema INI

Mensagem por Conteúdo patrocinado Hoje à(s) 00:27


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum