Conectar-se
Quem está conectado
23 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 23 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
Ranking : Nota C
Notas recebidas : C+B
Data de inscrição : 26/07/2008
Número de Mensagens : 6037
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 288

Prêmios
   :
   :
   :
Ver perfil do usuário

Problema com personagem ao andar rápido

em Seg 09 Maio 2011, 21:08
Eu estou fazendo um jogo para o concurso.
O carinha anda meio rápido, e isso faz com que ele fique meio distorcido ao andar.
Explicando melhor:

Ao andar rápido, ele fica como um vulto, ele distorce um pouco.

Tem como resolver isso?

Até mais!
avatar
Ranking : Nota C
Notas recebidas : C
Data de inscrição : 07/09/2010
Número de Mensagens : 1400
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 21

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problema com personagem ao andar rápido

em Seg 09 Maio 2011, 21:17
Mas isso é problema na sprite, ou em codes?
Se for na sprite, tenta isso:
Código:
draw_set_blend_mode(bm_add) //ou bm_subtract, testa aí.
draw_sprite_ext(sprite,subimg,x,y,xscale,yscale,rot,color,alpha) //troca pelas variaveis.
draw_set_blend_mode(bm_normal)
Ranking : Nota C
Notas recebidas : C+B
Data de inscrição : 26/07/2008
Número de Mensagens : 6037
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 288

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: Problema com personagem ao andar rápido

em Seg 09 Maio 2011, 21:27
Não adiantou.

O problema é esse:

Eu coloco uma sprite no player. Não coloco código para desenhar o sprite. Somente escolho o sprite. Depois adiciono o movimento.
Daí vou testar o jogo e acontece isso.

FLW
avatar
Ranking : Nota A
Notas recebidas : A
Data de inscrição : 09/03/2010
Número de Mensagens : 1035
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 43

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://www.www.ww.www

Re: Problema com personagem ao andar rápido

em Seg 09 Maio 2011, 21:28
tenta escrever isso no create do algum obj
Código:
texture_set_interpolation(true)
ou apenas marca interpolate colors between.... no global game settings

flws
Ranking : Nota C
Notas recebidas : C+B
Data de inscrição : 26/07/2008
Número de Mensagens : 6037
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 288

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: Problema com personagem ao andar rápido

em Seg 09 Maio 2011, 21:50
Já fiz isso também, não resolveu...
Espero que alguem saiba resolver isso.

Se ninguem conseguir, talvez eu poste uma screenshot.

FLW
avatar
Ranking : Nota A
Notas recebidas : A
Data de inscrição : 09/03/2010
Número de Mensagens : 1035
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 43

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://www.www.ww.www

Re: Problema com personagem ao andar rápido

em Seg 09 Maio 2011, 21:59
tipo é um vulto ou objeto fica meio que "cortado" quando anda?
porque se for esse problema de ficar meio cortado que eu saiva é problema do proprio gm mesmo, e no 8.1 nao tem esse problema agora, se for outra coisa ai tem que ver xD

posta uma screen fica mais facil

flws

avatar
Ranking : Nota A
Notas recebidas : C + B + A + A
Data de inscrição : 08/06/2009
Número de Mensagens : 1846
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 254

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://willy-gmbr.blogspot.com/

Re: Problema com personagem ao andar rápido

em Seg 09 Maio 2011, 22:20
Isso é normal.
Experimente aumentar o room speed para 60 ou 90, a qualidade fica muito superior. Talvez, se marcar "Interpolate[...] Pixels" do Global Game Settings fique melhor. Também evite usar valores picados para o movimento (3.5, 4.3, etc), sempre use inteiros.
[EDIT]
Mais uma coisa, as vezes pode ser problema na placa de vídeo. Se você tirar uma screen, o "borrão" não vai aparecer (isso se for o que eu estou pensando).

Espero ter ajudado...
blz
Ranking : Nota C
Notas recebidas : C+B
Data de inscrição : 26/07/2008
Número de Mensagens : 6037
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 288

Prêmios
   :
   :
   :
Ver perfil do usuário

Re: Problema com personagem ao andar rápido

em Seg 09 Maio 2011, 22:26
Testei no game maker 8.1 e ficou um pouco melhor.
Ai eu aumentei o FPS e o problema quase sumiu.
Agora está bem fraquinho, está bom.

Valeu pelas dicas.

Tópico resolvido e trancado.
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum