Conectar-se
Quem está conectado
24 usuários online :: 2 usuários cadastrados, Nenhum Invisível e 22 Visitantes

CRP-Max, Tedi Ripper

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 30/04/2011
Número de Mensagens : 309
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Problemas com bloco

em Dom 08 Maio 2011, 15:46
Ola a todos,venho aqui pq estou com problemas no bloco
obj_falling é o obj que desaparece (como se foce o bloco que cai)
no create eu coloquei
Código:
desfazendo=false
no step
Código:
if desfazendo=true
{
image_alpha-=0.0.5
if image_alpha<0
instance_create (x,y,obj_repor)
}
e colisão cmo player
Código:
desfazendo=true
no obj_repor
Código:
alarm [0] = 30;
alarm 0
Código:
{
instance_create (x,y,obj_falling)
instance_destroy()
alarm[0]=30;
}
quando o player colide ele faz normalmente,cria o obj_repor,o obj_repor faz o alarme e cria o obj_falling,mas quando eu subo no bloco pela 2 vez ele não acontece nd,alguem sabe pq?
avatar
Ranking : Nota D
Notas recebidas : C+D
Data de inscrição : 09/11/2010
Número de Mensagens : 854
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://www.google.com

Re: Problemas com bloco

em Dom 08 Maio 2011, 16:35
veja sed o sprite do obj_repor não é o msm que o do obj_falling e vc confundiu
avatar
Data de inscrição : 30/04/2011
Número de Mensagens : 309
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problemas com bloco

em Dom 08 Maio 2011, 16:48
e a mesma sprite mas oq tenha a ver?
avatar
Ranking : Nota D
Notas recebidas : C+D
Data de inscrição : 09/11/2010
Número de Mensagens : 854
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://www.google.com

Re: Problemas com bloco

em Dom 08 Maio 2011, 16:49
por isso muda a sprite do obj_repor e veja
avatar
Data de inscrição : 30/04/2011
Número de Mensagens : 309
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problemas com bloco

em Dom 08 Maio 2011, 18:44
deu na msm :s
avatar
Ranking : Nota B
Notas recebidas : B
Data de inscrição : 18/02/2011
Número de Mensagens : 346
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problemas com bloco

em Dom 08 Maio 2011, 18:53
substitua o step por:

Código:
if desfazendo=true
{
image_alpha-=0.0.5
if image_alpha<0
{
instance_create (x,y,obj_repor)
instance_destroy()
}
}

Vc esqueceu de destruir o bloco quando ele não aparece
avatar
Data de inscrição : 30/04/2011
Número de Mensagens : 309
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Problemas com bloco

em Dom 08 Maio 2011, 19:44
vlw Nuclear,rep + para você
Podem fechar o topico
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum