Problemas com bloco

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Problemas com bloco

Mensagem por Need_90 em Dom 08 Maio 2011, 15:46

Ola a todos,venho aqui pq estou com problemas no bloco
obj_falling é o obj que desaparece (como se foce o bloco que cai)
no create eu coloquei
Código:
desfazendo=false
no step
Código:
if desfazendo=true
{
image_alpha-=0.0.5
if image_alpha<0
instance_create (x,y,obj_repor)
}
e colisão cmo player
Código:
desfazendo=true
no obj_repor
Código:
alarm [0] = 30;
alarm 0
Código:
{
instance_create (x,y,obj_falling)
instance_destroy()
alarm[0]=30;
}
quando o player colide ele faz normalmente,cria o obj_repor,o obj_repor faz o alarme e cria o obj_falling,mas quando eu subo no bloco pela 2 vez ele não acontece nd,alguem sabe pq?

Need_90

Número de Mensagens : 309
Idade : 17
Data de inscrição : 30/04/2011
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com bloco

Mensagem por Lauro em Dom 08 Maio 2011, 16:35

veja sed o sprite do obj_repor não é o msm que o do obj_falling e vc confundiu

Lauro

Ranking : Nota D
Número de Mensagens : 854
Idade : 19
Data de inscrição : 09/11/2010
Notas recebidas : C+D
Reputação : 11
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://www.google.com

Voltar ao Topo Ir em baixo

Re: Problemas com bloco

Mensagem por Need_90 em Dom 08 Maio 2011, 16:48

e a mesma sprite mas oq tenha a ver?

Need_90

Número de Mensagens : 309
Idade : 17
Data de inscrição : 30/04/2011
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com bloco

Mensagem por Lauro em Dom 08 Maio 2011, 16:49

por isso muda a sprite do obj_repor e veja

Lauro

Ranking : Nota D
Número de Mensagens : 854
Idade : 19
Data de inscrição : 09/11/2010
Notas recebidas : C+D
Reputação : 11
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://www.google.com

Voltar ao Topo Ir em baixo

Re: Problemas com bloco

Mensagem por Need_90 em Dom 08 Maio 2011, 18:44

deu na msm :s

Need_90

Número de Mensagens : 309
Idade : 17
Data de inscrição : 30/04/2011
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com bloco

Mensagem por Nuclear em Dom 08 Maio 2011, 18:53

substitua o step por:

Código:
if desfazendo=true
{
image_alpha-=0.0.5
if image_alpha<0
{
instance_create (x,y,obj_repor)
instance_destroy()
}
}

Vc esqueceu de destruir o bloco quando ele não aparece

Nuclear

Ranking : Nota B
Número de Mensagens : 346
Idade : 18
Data de inscrição : 18/02/2011
Notas recebidas : B
Reputação : 22
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com bloco

Mensagem por Need_90 em Dom 08 Maio 2011, 19:44

vlw Nuclear,rep + para você
Podem fechar o topico

Need_90

Número de Mensagens : 309
Idade : 17
Data de inscrição : 30/04/2011
Reputação : 2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com bloco

Mensagem por Conteúdo patrocinado Hoje à(s) 16:24


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum