Conectar-se
Quem está conectado
23 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 23 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 06/05/2011
Número de Mensagens : 10
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

[Resolvido]Mais uma Pegunta...

em Dom 08 Maio 2011, 14:26
eu tava ageitando um script que fico todo bugado (quando ta bugado apago o script direto me da raiva)!
Alguem me passa um script para um objeto cria a cada 3segundos um outro objeto!
Eu tava criando um objeto que atirava umas bolinha mas o problema é que eu so consigo faze ele atira 1 vez ou 2...


Última edição por alexsander em Seg 09 Maio 2011, 17:00, editado 1 vez(es)
avatar
Ranking : Nota A
Notas recebidas : C + B + A + A
Data de inscrição : 08/06/2009
Número de Mensagens : 1846
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 254

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://willy-gmbr.blogspot.com/

Re: [Resolvido]Mais uma Pegunta...

em Dom 08 Maio 2011, 14:36
No create:

atira=true

No step:

if atira=true{
instance_create(x,y,objeto)
alarm[0]=90
atira=false
}

No alarm[0]:

atira=true


Isso deve resolver.
Se estiver com problemas para entener como funciona um alarm[], dê uma lida no meu tutorial!

Espero ter ajudado!
blz
avatar
Ranking : Nota C
Notas recebidas : C-D-A-C
Data de inscrição : 28/01/2011
Número de Mensagens : 1003
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 18

Prêmios
   : 0
   : 0
   : 1
Ver perfil do usuáriohttp://sonicmaker.forumeiros.com/memberlist

Re: [Resolvido]Mais uma Pegunta...

em Dom 08 Maio 2011, 14:38
no Create do objeto coloca :
Código:

instance_create(x,y,objeto)
alarm[0]=60

no Alarm 0 coloca:
Código:

instance_create(x,y,objeto)
alarm[0]=60

espero ter ajudado
avatar
Data de inscrição : 06/05/2011
Número de Mensagens : 10
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]Mais uma Pegunta...

em Dom 08 Maio 2011, 14:50
Vlw...E tenho mesmo dificuldade com os script de tempo... varios dos meus problemas estao relacionados com script de tempo...

Affe achei outra dificuldade... Criei um script de son para exercutar quando o tiro sair...Mas não sei fazer pro vc escutar o som apenas quando esta vendo o tiro saindo... o script é o seguinte:
Código:
if atira=true{
instance_create(x+8,y+16,tiro1)
alarm[0]=90
atira=false
sound_play(snd3)
}
avatar
Ranking : Nota A
Notas recebidas : C + B + A + A
Data de inscrição : 08/06/2009
Número de Mensagens : 1846
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 254

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://willy-gmbr.blogspot.com/

Re: [Resolvido]Mais uma Pegunta...

em Dom 08 Maio 2011, 15:09
Coloca o sound_play(snd3) no create do tiro. Não tem erro!
avatar
Data de inscrição : 06/05/2011
Número de Mensagens : 10
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]Mais uma Pegunta...

em Dom 08 Maio 2011, 15:23
Mas colocando so isso vc escuta o barulho por toda room e eu quero so que escute quando vc ta vendo o tiro sair da armadilha....Ou seja quando vc esta proximo a armadilha..
avatar
Ranking : Nota A
Notas recebidas : C + B + A + A
Data de inscrição : 08/06/2009
Número de Mensagens : 1846
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 254

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://willy-gmbr.blogspot.com/

Re: [Resolvido]Mais uma Pegunta...

em Dom 08 Maio 2011, 15:55
Código:
if distance_to_object(obj_jogador)<view_xview[0]{
sound_play(snd3)
}
Dessa forma só executa o som quando estiver aparecendo na tela. Se quiser, troque "view_xview[0]" por um valor fixo, como por exemplo, 640 (valor padrão das rooms X).
avatar
Data de inscrição : 06/05/2011
Número de Mensagens : 10
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]Mais uma Pegunta...

em Seg 09 Maio 2011, 15:41
Mas tipo quando eu chego o som começa mas n para mais como faz pra para quando eu me distancio novamente o som para
??


Última edição por alexsander em Seg 09 Maio 2011, 15:44, editado 1 vez(es)
avatar
Ranking : Nota A
Notas recebidas : C + B + A + A
Data de inscrição : 08/06/2009
Número de Mensagens : 1846
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 254

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://willy-gmbr.blogspot.com/

Re: [Resolvido]Mais uma Pegunta...

em Seg 09 Maio 2011, 15:43
Esse code você coloca no create do tiro.
blz
avatar
Ranking : Nota B
Notas recebidas : C-D-A-B
Data de inscrição : 14/01/2011
Número de Mensagens : 2964
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 121

Prêmios
   : 1
   : 0
   : 3
Ver perfil do usuário

Re: [Resolvido]Mais uma Pegunta...

em Seg 09 Maio 2011, 15:54
if distance_to_object(obj_jogador)&& !sound_isplaying (snd3){
sound_play(snd3)
}
avatar
Data de inscrição : 06/05/2011
Número de Mensagens : 10
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]Mais uma Pegunta...

em Seg 09 Maio 2011, 15:57
Vlw funciono... So mudei o x pelo y e fico tudo certo...
Código:
if distance_to_object(ameba)<view_yview[640]{
sound_play(snd3)
}

E tava no create do tiro...
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum