Conectar-se
Quem está conectado
23 usuários online :: 1 usuário cadastrado, Nenhum Invisível e 22 Visitantes

jailson_dante

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 25/04/2011
Número de Mensagens : 398
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 3

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

[AJUDA] Problema com rampa em plataforma

em Sex 29 Abr 2011, 21:03
Bom, ja pesquisei um pouco, mas nao achei nada, entao o problema é que quando o meu player colidi com a minha rampa as vezes ele sobe normalmente e as vezes ele aparece ums 4~5 quadrados(32x32) na frente voando scratch e ai cai, isso só acontece quando ele vem de um bloco reto, quando ele vem de outra rampa nao aconteceu nenhuma vez.

Agradeço desde já

Happy
avatar
Ranking : Nota B
Notas recebidas : B-B
Data de inscrição : 28/02/2010
Número de Mensagens : 559
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 12

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://gsogaming.blogspot.com/

Re: [AJUDA] Problema com rampa em plataforma

em Sex 29 Abr 2011, 21:42
Não tem como eu saber o que é.
Passe a sua engine pra gente ver o que tem de errado.
Flws!
avatar
Data de inscrição : 25/04/2011
Número de Mensagens : 398
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 3

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

Re: [AJUDA] Problema com rampa em plataforma

em Sex 29 Abr 2011, 22:09
eu me basiei ness engine:

Código:
http://forums.yoyogames.com/forums/10/topics/54541

Informaçoes adcionais:
-só acontece subindo
-acontece com rampas da direita e esquerda
-só começou a ocorrer qnd eu adcionei sprites de direita e esquerda, entao pode ser isso(vou tentar arrumar de uma forma que pensei agr e ja do edit EDIT: nao deu certo)((as masks tao iguais))

PS:se precisar que eu coloque algum codigo avisa
avatar
Ranking : Nota B
Notas recebidas : B-B
Data de inscrição : 28/02/2010
Número de Mensagens : 559
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 12

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://gsogaming.blogspot.com/

Re: [AJUDA] Problema com rampa em plataforma

em Sab 30 Abr 2011, 00:02
Deve ser algum problema nessas sprites que você colocou, já que o problema começou depois que você as colocou. Tente colocar uma mask no objeto do jogador.
Crie uma sprite chamada spr_mask, deixe ela do tamanho da sprite do jogador, e pinte ela toda de preto. Vá no objeto do jogador e clique em Mask, e selecione a spr_mask.
Isso deve resolver o problema.
Flws!
avatar
Data de inscrição : 25/04/2011
Número de Mensagens : 398
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 3

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

Re: [AJUDA] Problema com rampa em plataforma

em Sab 30 Abr 2011, 01:05
continua dando o problema mesmo dpois doque vc me falo, vou dar upload no meu gmk e te mandar pro PM ai vc examina ok?

EDIT: PM enviada
avatar
Ranking : Sem avaliações
Data de inscrição : 14/04/2011
Número de Mensagens : 691
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 162

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [AJUDA] Problema com rampa em plataforma

em Sab 30 Abr 2011, 10:20
Amigo, pra vc tratar rampas é um pouco diferente....

da uma olhadinha nessa engine que vai te ajudar bastante

Código:
http://gmc.yoyogames.com/index.php?showtopic=381347
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum