Problemas com sons(sound_play).

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Problemas com sons(sound_play).

Mensagem por Mannoroth em Seg 11 Abr 2011, 21:01

Ao colocar sons no meu jogo estou tendo problemas.
No jogo tem 2 sons, uma música e q toca qd ocorre uma certa açao. Quero que o som da musica fique tocando sem parar durante o jogo, e o outro som eventualmente toque quando a açao seja realizada. Mas o som da açao sempre interrompe o da musica(pára totalmente). Ja tentei marcar o som da musica como background music, e o da ação como normal sound, mas nao adianta.
Há uma terceira musica, uma de 'fase completa', dae qd passa a fase ele tem que tocar, esperar 5 segundos e ir pra outra room. Mas nisso ele sempre trava o jogo, ficando extremamente lento e a musica só se ouvirá qd o jogo voltar ao normal.
Usando tanto os D&D quanto codes mesmo( sound_play(sound0) ), os problemas são os mesmo.Uso o GM8 Pro.

Mannoroth

Ranking : Nota D
Número de Mensagens : 836
Idade : 26
Data de inscrição : 05/10/2010
Notas recebidas : D+D
Reputação : 12
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com sons(sound_play).

Mensagem por Nuclear em Seg 11 Abr 2011, 21:24

coloca isso:

Código:
if !sound_isplaying(som_que_não_para)
{
sound_play(som_que_não_para)
}

Não testei mas ve se funciona.

Nuclear

Ranking : Nota B
Número de Mensagens : 346
Idade : 18
Data de inscrição : 18/02/2011
Notas recebidas : B
Reputação : 22
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com sons(sound_play).

Mensagem por itallo em Seg 11 Abr 2011, 22:22

você tem que definir um "id" para cada som!!!

colocando apenas sound_play(som) o id do som será '0'
ou seja:

0 = sound_play(som)

se você colocar outro sound_play(som) o id será zero, e ele substituirá o som que está tocando!!!
espero que tenha entendido o exemplo Very Happy

então você tem que por assim:

// o som_back é o nome do som de background que você definiu

if !sound_isplaying(som_back)
{
som_de_fundo = sound_play(som_back)
}

detalhe, depois você poderá pausar esse som usando sua 'id' !!!

exemplo: sound_stop(som_de_fundo)

agora é só você fazer o mesmo para os outros sons, mudando apenas o 'id'
boa sorte

itallo

Ranking : Sem avaliações
Número de Mensagens : 969
Idade : 24
Data de inscrição : 26/08/2009
Reputação : 12
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   :
   :

http://www.zuluhotel.com.br

Voltar ao Topo Ir em baixo

Re: Problemas com sons(sound_play).

Mensagem por Mannoroth em Seg 11 Abr 2011, 22:31

CogumeloDoRock escreveu:

então você tem que por assim:

// o som_back é o nome do som de background que você definiu

if !sound_isplaying(som_back)
{
som_de_fundo = sound_play(som_back)
}


Eu botei esse code ae num step de objeto, e o som_de_fundo fica tocando do começo, e por isso durante o jogo a música reinicia toda hora. Alem do mais, nem dá tempo de ouvir o outro som, pois na hora que esse outro som toca(parando a musica do fundo) já corre a musica do fundo instantaneamente.

Mannoroth

Ranking : Nota D
Número de Mensagens : 836
Idade : 26
Data de inscrição : 05/10/2010
Notas recebidas : D+D
Reputação : 12
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com sons(sound_play).

Mensagem por itallo em Seg 11 Abr 2011, 22:36

faz assim:
create:
som_de_fundo = sound_player(música)

step:
if keyboard_check_pressed(ord("K"))
{
som_action = sound_play(som_de_ação)
}

agora sim você vai entender....

arrumei


Última edição por CogumeloDoRock em Seg 11 Abr 2011, 23:09, editado 1 vez(es)

itallo

Ranking : Sem avaliações
Número de Mensagens : 969
Idade : 24
Data de inscrição : 26/08/2009
Reputação : 12
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   :
   :

http://www.zuluhotel.com.br

Voltar ao Topo Ir em baixo

Re: Problemas com sons(sound_play).

Mensagem por Nuclear em Seg 11 Abr 2011, 22:42

Tenta esse:

Código:
if !sound_isplaying(som_que_não_para)
if !sound_isplaying(som2)
{
sound_play(som_que_não_para)
}
if sound_isplayning(som2)
if sound_isplayning(som_que_não_para)
{
sound_discard(som_que_não_para)
}

Nuclear

Ranking : Nota B
Número de Mensagens : 346
Idade : 18
Data de inscrição : 18/02/2011
Notas recebidas : B
Reputação : 22
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com sons(sound_play).

Mensagem por Mannoroth em Seg 11 Abr 2011, 23:02

Os dois codes nao dão certo visto q a musica de fundo sempre toca do começo quando volta. Mas com o código do NUCLEAR, pelo menos o som de açao toca, depois dele é q o da musica toca(do começo).

Mannoroth

Ranking : Nota D
Número de Mensagens : 836
Idade : 26
Data de inscrição : 05/10/2010
Notas recebidas : D+D
Reputação : 12
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com sons(sound_play).

Mensagem por SchatzMan em Seg 11 Abr 2011, 23:39

Que eu saiba esse problema é causado por que o som de fundo e interrompido pelo "media player" ou seja tem que ser ou 3D ou normal... Nem li o topico todo... Mais li as respostas... Espero que de certo...

PS.: Tem que mudar no editor de som.
PS.: O som tem que ser MP3 ou WAV.

SchatzMan

Número de Mensagens : 43
Idade : 18
Data de inscrição : 20/11/2010
Reputação : -2
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas com sons(sound_play).

Mensagem por vinians em Ter 12 Abr 2011, 01:06

Bem, é o seguinte, tente isso:
Para o som de fundo use arquivos MP3 ou MID:
Comando:
Código:

sound_loop(musica_de_fundo); //toca sem parar
Para sons de efeitos especiais use WAV:
Comando normal:
Código:

sound_play(efeito_especial);
Flws

vinians

Ranking : Nota B
Número de Mensagens : 2490
Idade : 27
Data de inscrição : 18/09/2008
Notas recebidas : B-C-A-C
Reputação : 52
Insignia 1 x 0 Insignia 2 x 1 Insignia 3 x 0
Prêmios
   : 0
   : 2
   : 1

http://xcreatorgames.weebly.com/

Voltar ao Topo Ir em baixo

Re: Problemas com sons(sound_play).

Mensagem por Conteúdo patrocinado Hoje à(s) 22:14


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum