[RESOLVIDO]Problema no Sound_add

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido [RESOLVIDO]Problema no Sound_add

Mensagem por Supersonic933 em Qui 31 Mar 2011, 13:45

Olá pessoal.

Coloquei o seguinte código no obj loadingmus1, usando create:

Código:
sound_add("mus1.mp3")

Mas, quando testei o jogo...



O que eu faço para funcionar?


Última edição por Supersonic933 em Qui 31 Mar 2011, 15:07, editado 1 vez(es)

Supersonic933

Ranking : Nota E
Número de Mensagens : 396
Data de inscrição : 14/02/2011
Notas recebidas : E
Reputação : 13
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://planetaanalisandogames.blogspot.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Problema no Sound_add

Mensagem por JV Justino em Qui 31 Mar 2011, 13:55

Você está usando essa função de forma errada.
O certo seria:
Código:
sound_add(fname,kind,preload)

Em fname você coloca o nome do arquivo dentro de aspas.
Em kind você coloca o tipo de som. Os que podem ser usados são:
0- Normal Sound
1- Background Music
2- 3D Sound
Em preload você pode por 1 ou 0, só não sei para que ele serve. Razz

No seu caso ficaria mais ou menos assim:
Código:
Musica=sound_add("mus1.mp3",1,0)

Espero ter ajudado!

JV Justino

Ranking : Nota A
Número de Mensagens : 619
Idade : 19
Data de inscrição : 07/12/2010
Notas recebidas : A+A
Reputação : 20
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Problema no Sound_add

Mensagem por Supersonic933 em Qui 31 Mar 2011, 14:03

joao vitor jv escreveu:Você está usando essa função de forma errada.
O certo seria:
Código:
sound_add(fname,kind,preload)

Em fname você coloca o nome do arquivo dentro de aspas.
Em kind você coloca o tipo de som. Os que podem ser usados são:
0- Normal Sound
1- Background Music
2- 3D Sound
Em preload você pode por 1 ou 0, só não sei para que ele serve. Razz

No seu caso ficaria mais ou menos assim:
Código:
Musica=sound_add("mus1.mp3",1,0)

Espero ter ajudado!

Obrigado!

Mas:

No object mus1 (executa a música)

[code]sound_play("mus1")

E o jogo fica sem música por que, já coloquei mp3 junto e não funcionou.

Supersonic933

Ranking : Nota E
Número de Mensagens : 396
Data de inscrição : 14/02/2011
Notas recebidas : E
Reputação : 13
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://planetaanalisandogames.blogspot.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Problema no Sound_add

Mensagem por JV Justino em Qui 31 Mar 2011, 14:47

Use assim:
Código:
var Musica;
Musica=sound_add("mus1.mp3",1,0);
sound_play(Musica);

Espero ter ajudado!

JV Justino

Ranking : Nota A
Número de Mensagens : 619
Idade : 19
Data de inscrição : 07/12/2010
Notas recebidas : A+A
Reputação : 20
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Problema no Sound_add

Mensagem por Supersonic933 em Qui 31 Mar 2011, 15:06

joao vitor jv escreveu:Use assim:
Código:
var Musica;
Musica=sound_add("mus1.mp3",1,0);
sound_play(Musica);

Espero ter ajudado!

Funcionou! Podem fechar o tópico! Vou colocar que sou seu fã!

Supersonic933

Ranking : Nota E
Número de Mensagens : 396
Data de inscrição : 14/02/2011
Notas recebidas : E
Reputação : 13
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://planetaanalisandogames.blogspot.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [RESOLVIDO]Problema no Sound_add

Mensagem por Conteúdo patrocinado Hoje à(s) 22:25


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum