Conectar-se
Quem está conectado
13 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 13 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
Convidad
Convidado

[Resolvido]molas n funcinam

em Sab 26 Mar 2011, 19:00
o meu jogo ira atrasar mais um pouco pq a ultima fase ta com defeito,a mola q eu criei nela esta com defeito
no player coloquei colission com obj_mola

Código:
if place_meeting(x,y+vspeed,obj_mola) and vspeed>1 vspeed/=2
platform=instance_position(x-sprite_xoffset+sprite_width/2,y-sprite_yoffset+sprite_height,obj_mola)
if position_meeting(x-sprite_xoffset+sprite_width/2,y-sprite_yoffset+sprite_height,obj_mola)
{
 if vspeed>=0
  {                                                              //ESSE CÓDIGO NÃO É MEU,NÃO POSSO DAR CRÉDITO POIS NAO LEMBRO MAIS DE ONDE COPIEI!!
  vspeed=0                                                      //so sei que esse codico serve para colidir com o obj de sprite em movimento.
  gravity=0
  y=platform.y+sprite_yoffset-sprite_height+platform.vspeed+1
  x+=platform.hspeed
  }
}

no obj_mola eu coloquei
create
Código:
image_speed=0.0//velocidade da sprite 0
Begin step
Código:
//para o player atravessar ela por baixo e ficar parado em cima
if instance_exists(obj_bola)
 {
  if (y-1 > obj_bola.y+1)
    {
    solid=true;
    }
      else
          {
          solid=false;
          }
 }
 if instance_exists(obj_bola)
 {
  if (y-1 > obj_bola.y+1)
    {
    solid=true;
    }
      else
          {
          solid=false;
          }
 }
colission com obj_bola (mudei os nome pq tava com preguiça de ver todos os codigo para modifica os nome kk)
Código:
image_speed=1.35//a animação da sprite começa
e Animation End
Código:
image_speed=0.0//a animação da sprite trava
Código:
if place_meeting(x,y+8,obj_mola){vspeed=-15}//se o player estiver encostando em cima da mola ele pula

mas ele n pula so fas o efeito da mola mas ele fica paradao q nem um gay preguisoso :cry: :cry: :cry:


Última edição por vdm842 em Dom 27 Mar 2011, 11:06, editado 1 vez(es)
avatar
Ranking : Nota C
Notas recebidas : C-D-A-C
Data de inscrição : 28/01/2011
Número de Mensagens : 1003
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 1
Ver perfil do usuáriohttp://sonicmaker.forumeiros.com/memberlist

Re: [Resolvido]molas n funcinam

em Sab 26 Mar 2011, 19:13
vou faser uma engine depois eu dou um edit.

edit
promto ja fis : 4shared.com/file/OB0OSMmJ/Engine_-_mola.html

espero ter ajudado ;)
Convidad
Convidado

Re: [Resolvido]molas n funcinam

em Dom 27 Mar 2011, 10:23
vou testala ja dou edit

edit : sonic elas dao muito bug e talz n funciona n
avatar
Ranking : Nota C
Notas recebidas : C+C+C+C
Data de inscrição : 03/12/2010
Número de Mensagens : 470
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]molas n funcinam

em Dom 27 Mar 2011, 10:41
olha eu fiz uma engine super hiper mega simples pra vc espero que te ajude blz
Download
Convidad
Convidado

Re: [Resolvido]molas n funcinam

em Dom 27 Mar 2011, 10:44
perfeito gustavo vai ajudar muito ser quiser creditos no joogo e so fala Very Happy
avatar
Ranking : Nota C
Notas recebidas : C+C+C+C
Data de inscrição : 03/12/2010
Número de Mensagens : 470
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]molas n funcinam

em Dom 27 Mar 2011, 10:48
que bom que te ajudou cara e pode usar tranquilamente e num prescisa dar creditos não blz?! falow blz
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum