Conectar-se
Quem está conectado
37 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 37 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota B
Notas recebidas : A - B
Data de inscrição : 04/02/2009
Número de Mensagens : 1243
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 1
Reputação : 89

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

[Resolvido] View fica "Tremendo" enquanto segue o Player.

em Sex 18 Fev 2011, 18:05
Eai galera belezinha?

To com um problema aqui, ja procurei engines e tópicos no fórum, mas os que encontrei num puderam solucionar o problema.

O que acontece é o seguinte, coloquei Velocidade 6 no Objeto, e a VSPEED dele é a metade da var Velocidade (no caso 3).
Mas conforme a nave (Player) vai seguindo para "cima", ela fica tremendo. No entanto quando volta no começo fica tudo normal! (depois que passa os números no topo da tela, o objeto volta pro começo).

Vejam esse exemplo: Teste.rar
(Setas Movimentam, segurar Z Freia e X Atira)

Criei um Obj_camera que vai 120pxl a "frente" da Nave, mas também não resolveu.

Não sei como resolver isso..
Alguem tem alguma ideia?

Grato
DHarrison


Última edição por dharrison em Sex 18 Fev 2011, 19:09, editado 2 vez(es)
avatar
Ranking : Nota C
Notas recebidas : C+C+C+C
Data de inscrição : 03/12/2010
Número de Mensagens : 470
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 28

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido] View fica "Tremendo" enquanto segue o Player.

em Sex 18 Fev 2011, 18:30
mann tent criar um objeto sem sprite chamado camera ae vc coloca assim
no step
Código:
if instance_exists(obj_Nave)
{
    x = obj_Nave.x;
    y = obj_Nave.y;
}
se num dar certo é so dar um post blz?! falow
avatar
Ranking : Nota B
Notas recebidas : A - B
Data de inscrição : 04/02/2009
Número de Mensagens : 1243
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 1
Reputação : 89

Prêmios
   : 0
   : 1
   : 0
Ver perfil do usuário

Re: [Resolvido] View fica "Tremendo" enquanto segue o Player.

em Sex 18 Fev 2011, 18:32
intao, eu ja fiz isso
tem uma camera invisivel nesse exemplo atual
ela fica a y-120pxl do Player
e num funcionou nem assim, nem com x e y iguais ao player ;/


EDIT:

consegui corrigir o erro
era um problema no código mesmo! silent

o código verificava se a VSPEED era Menor que a Velocidade Vertical, e se fosse, VSPEED ficava igual a Velocidade Vertical (-4).
E Devido a isso ficava dando pau na nave, mas isso só era percepitivel enquanto andava na View.

O código original era:
Código:
if vspeed<=-veloc_vert {vspeed=-veloc_vert}

O código corrigido:
Código:
if vspeed>=-veloc_vert {vspeed=-veloc_vert}


Bem o problema não foi exatamente na View, mas se alguem tiver o mesmo problema futuramente, esta aí uma das possiveis causas e soluções.

Vlw galera
Tópico resolvido.
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum