Conectar-se
Quem está conectado
22 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 22 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 09/06/2008
Número de Mensagens : 51
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuário

Alarme não executa

em Qua 16 Fev 2011, 21:03
Create:
Código:
global.down = 27;
global.delay = 1;

Press enter:
Código:
alarm[0] = 1*30;

Alarm[0]:
Código:
y=y+16;

if (global.down > 0)
{
    alarm[0] = global.delay * room_speed; //room_speed = 30
    global.down = global.down - 1;
}

O alarme nem executa, pois o objeto nem se mexe...
avatar
Ranking : Nota D
Notas recebidas : D
Data de inscrição : 10/06/2010
Número de Mensagens : 2704
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 10

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Alarme não executa

em Qua 16 Fev 2011, 21:05
Creio que o certo seria:
Código:
alarm[0] = 130
Não sou muito de usar Alarm, uso memo variaveis para fazer isto.


Espero ter ajudado...
avatar
Ranking : Nota A
Notas recebidas : B-A-A
Data de inscrição : 13/01/2010
Número de Mensagens : 1087
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 30

Prêmios
   : 2
   : 1
   : 0
Ver perfil do usuáriohttp://www.mathaeuz.deviantart.com

Re: Alarme não executa

em Qua 16 Fev 2011, 21:07
Somas de variavel com ELA MESMA incluida na expressão nao são executadas pelo GM( ex: EU= EU+1);
Entao use:
Código:

//Adicionar à variavel "y" 16
y+=16
avatar
Ranking : Nota D
Notas recebidas : D
Data de inscrição : 10/06/2010
Número de Mensagens : 2704
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 10

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Alarme não executa

em Qua 16 Fev 2011, 21:13
Mathaeuz escreveu:Somas de variavel com ELA MESMA incluida na expressão nao são executadas pelo GM( ex: EU= EU+1);
Entao use:
Código:

//Adicionar à variavel "y" 16
y+=16
Desculpa o Flood, mas você tem razão...Ele colocou y+16, algo que o GM não reconheçe.
avatar
Data de inscrição : 09/06/2008
Número de Mensagens : 51
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuário

Re: Alarme não executa

em Qua 16 Fev 2011, 21:14
Não funcionou pessoal.

Eu coloque para o alarm mostrar o highscores e mesmo assim nem mostra, ou seja, não está executando o alarm.

No press enter eu coloquei:
alarm[0] = 1*30;

Já tentei com o alarm[0] = 130; tmb
AEE eu consegui agora pessoal.

Mas como eu faço para ele inciar o alarma direto, ao invés de eu ter que apertar o enter?

~Fuzenrad
Evite postagens duplas, quando necessário adicionar informações, edite sua mensagem anterior.
avatar
Data de inscrição : 02/10/2009
Número de Mensagens : 2227
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 52

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Alarme não executa

em Qua 16 Fev 2011, 21:20
Step > Step, ou coloca no próprio create.
avatar
Ranking : Nota A
Notas recebidas : B-A-A
Data de inscrição : 13/01/2010
Número de Mensagens : 1087
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 30

Prêmios
   : 2
   : 1
   : 0
Ver perfil do usuáriohttp://www.mathaeuz.deviantart.com

Re: Alarme não executa

em Qua 16 Fev 2011, 21:21
No create mande-o por o alarm[0] para 30*1, e tudo funcionara sozinho.
avatar
Data de inscrição : 09/06/2008
Número de Mensagens : 51
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0
Ver perfil do usuário

Re: Alarme não executa

em Qua 16 Fev 2011, 21:37
Deu certo, flw

Obrigado
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum