visualg e gm

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

visualg e gm

Mensagem por play_sound_games em Qui 10 Fev 2011, 23:41

e assim eu começei curso de tec de info dai la tava falando do visualg dai la tem vaiaveis e comandos...os mesmos tipo de variaçao de la e comandos é tbm igual o do GM?
variavel:(a variavel do escreva e escreval e do programma mesmo ta)
i : inteiro
j : inteiro
l : vetor[1..10] de caractere
c : vetor[1..7] de caractere
agenda :vetor[1..2,1..7]de caractere
x : caractere
inicio
para i de 1 ate 10 passo 1 faca
para j de 1 ate 7 passo 1 faca
escreval("nome: ")
leia (agenda[i,1])
escreval("endereço: ")
leia (agenda[i,2])
escreval("CEP: ")
leia (agenda[i,3])
escreval("cidade: ")
leia (agenda[i,4])
escreval("estado: ")
leia (agenda[i,5])
escreval("fone: ")
leia (agenda[i,6])
escreval("E-mail: ")
leia (agenda[i,7])
fimpara

para i de 1 ate 10 passo 1 faca
para j de 1 ate 7 passo 1 faca
escreval(agenda[i,j])
fimpara
fimpara
para i de 1 ate 10 passo 1 faca
para j de i+1 atee 7 passo 1 faca
se agenda > agenda[j] entao
x<- agenda
agenda <- agenda[j]
agenda[j] <- x
fimse
fimpara
fimpara
fimpara

dai tipo esse codi tbm se tipo to fazendo um game e por ele, ele pode funfar?
com o comando

play_sound_games

Número de Mensagens : 42
Idade : 21
Data de inscrição : 14/01/2011
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: visualg e gm

Mensagem por GameMakerTutoriais em Sex 11 Fev 2011, 00:57

Não. Pelo que eu entendi, isso é lógica de programação. A lógica de programação te ajuda a enxergar o mecanismo, mas você tem que conhecer a linguagem do programa para criar softwares nele.

O Game Maker tem uma linguagem própria, que deve ser estudada, mas também tem outra alternativa mais fácil para iniciantes, que é o mecanismo drag n' drop, onde você dá instruções ao programa arrastando ícones que correspondem à ações predefinidas.

Se você quiser começar a mexer no Game Maker agora, dá uma olhada no fórum de "tutoriais para iniciantes" e "tutoriais da equipe GMBR."

GameMakerTutoriais

Número de Mensagens : 800
Data de inscrição : 29/01/2011
Reputação : 26
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Re: visualg e gm

Mensagem por play_sound_games em Sex 11 Fev 2011, 23:40

nao e que eu sei mexe no GM8 mas e que eu queria saber se tipo essa variavel tbm tipo se eu jogar no GM dava certo
mas ja que é logica de programaçao intao nao posso usar o gm pra estuda
pq eu sei alguns codis do GM e pesnei que podia ser basicamente o mesmo

thank's manolo

play_sound_games

Número de Mensagens : 42
Idade : 21
Data de inscrição : 14/01/2011
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0

Voltar ao Topo Ir em baixo

Re: visualg e gm

Mensagem por Conteúdo patrocinado Hoje à(s) 18:24


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum