[Resolvido] O som não toca quando faço load game

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido [Resolvido] O som não toca quando faço load game

Mensagem por Lucas 5293 em Qua 09 Fev 2011, 10:29

Eu estou fazendo um jogo do mario quando coloco new game o som toca normal
mas quando coloco load game o som não toca


Última edição por Lucas 3952 em Qua 09 Fev 2011, 11:46, editado 2 vez(es)

Lucas 5293

Ranking : Nota C
Número de Mensagens : 695
Idade : 18
Data de inscrição : 10/12/2010
Notas recebidas : C-D-B-B-B-C-C-C
Reputação : 18
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 1
   : 0

http://dopxgames.blogspot.com

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por irlansn em Qua 09 Fev 2011, 10:36

vocé colocou para botar o som no create de um objeto?

irlansn

Ranking : Nota C
Número de Mensagens : 482
Idade : 18
Data de inscrição : 18/01/2011
Notas recebidas : B+D
Reputação : 5
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Lucas 5293 em Qua 09 Fev 2011, 10:40

sim, foi no create do objeto som1

Lucas 5293

Ranking : Nota C
Número de Mensagens : 695
Idade : 18
Data de inscrição : 10/12/2010
Notas recebidas : C-D-B-B-B-C-C-C
Reputação : 18
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 1
   : 0

http://dopxgames.blogspot.com

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por irlansn em Qua 09 Fev 2011, 10:41

então é porcalsa disso !!!

irlansn

Ranking : Nota C
Número de Mensagens : 482
Idade : 18
Data de inscrição : 18/01/2011
Notas recebidas : B+D
Reputação : 5
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Lucas 5293 em Qua 09 Fev 2011, 10:42

é em qual evento

Lucas 5293

Ranking : Nota C
Número de Mensagens : 695
Idade : 18
Data de inscrição : 10/12/2010
Notas recebidas : C-D-B-B-B-C-C-C
Reputação : 18
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 1
   : 0

http://dopxgames.blogspot.com

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Lucas 5293 em Qua 09 Fev 2011, 10:52

....

Lucas 5293

Ranking : Nota C
Número de Mensagens : 695
Idade : 18
Data de inscrição : 10/12/2010
Notas recebidas : C-D-B-B-B-C-C-C
Reputação : 18
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 1
   : 0

http://dopxgames.blogspot.com

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por irlansn em Qua 09 Fev 2011, 10:53

Coloque no start room!

irlansn

Ranking : Nota C
Número de Mensagens : 482
Idade : 18
Data de inscrição : 18/01/2011
Notas recebidas : B+D
Reputação : 5
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Luiz A. Oliveira em Qua 09 Fev 2011, 11:11

vc fez um checkpoint? ou um load para ele voltar do começo da room sempre que o jogo for carregado?

Luiz A. Oliveira

Ranking : Nota C
Número de Mensagens : 914
Idade : 19
Data de inscrição : 08/09/2010
Notas recebidas : D-B-C
Reputação : 5
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://luizgm.blogspot.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Lucas 5293 em Qua 09 Fev 2011, 11:15

eu fiz um load

Lucas 5293

Ranking : Nota C
Número de Mensagens : 695
Idade : 18
Data de inscrição : 10/12/2010
Notas recebidas : C-D-B-B-B-C-C-C
Reputação : 18
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 1
   : 0

http://dopxgames.blogspot.com

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Lucas 5293 em Qua 09 Fev 2011, 11:19

coloquei o som no room start e mesmo assim nao funcionou confused

Lucas 5293

Ranking : Nota C
Número de Mensagens : 695
Idade : 18
Data de inscrição : 10/12/2010
Notas recebidas : C-D-B-B-B-C-C-C
Reputação : 18
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 1
   : 0

http://dopxgames.blogspot.com

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por irlansn em Qua 09 Fev 2011, 11:24

então crie uma sprite com ele sem som e outra com som!
coloque a sprite "sem som" na sprite do obj= som1
e coloque para quanto cliquar em "m" muda para a sprite "com som" e coloque para tocar o som!
depois coloque em outro botão: muda para a sprite "sem som" e coloque para tirar o som!

irlansn

Ranking : Nota C
Número de Mensagens : 482
Idade : 18
Data de inscrição : 18/01/2011
Notas recebidas : B+D
Reputação : 5
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Luiz A. Oliveira em Qua 09 Fev 2011, 11:28

[Mystery]Você não pode responder a uma mensagem sua, isso se chama post duplo.
Como você é novato por aqui, sugiro que leia as Regras Gerais do Fórum.
[/Mystery]
Então vc pode usar uma ini para carregar a room, é melhor... vou procurar um topico que fale sobre isso e ja ja posto
esta ai:
Save e Load com ini's - Clique aqui para exibir:
Alex FC escreveu:Coloque no evento que carrega a fase:

Código:
//Carregar

ini_open(sala.ini)

//vai para a room salva no INI e se não tiver nada salvo, vai para 1ª fase
room=ini_read_real("sala","sala",nome_da_primeira_fase)

ini_close()

No evento que salva:

Código:
ini_open(sala.ini)

//Salva o index da room atual
ini_write_real("sala","sala",room)

ini_close()

FLWS!


Última edição por luiz_100juizo em Qua 09 Fev 2011, 11:32, editado 1 vez(es)

Luiz A. Oliveira

Ranking : Nota C
Número de Mensagens : 914
Idade : 19
Data de inscrição : 08/09/2010
Notas recebidas : D-B-C
Reputação : 5
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://luizgm.blogspot.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Markituh em Qua 09 Fev 2011, 11:31

Eu estou fazendo um jogo do mario quando coloco new game o som toca normal
mas quando coloco load game o som não toca
É um menu certo? Que tipo de sistema você está usando? Pois assim podemos saber como trabalhar com ele. Um modo correto de tocar o som seria quando pressionasse a tecla, mas como não sei como você está fazendo o menu, fica difícil explicar.

___________

"Não deixe para amanhã o que se pode fazer hoje"

Links úteis:
Índice de Tutoriais
Manual online do GMS

Markituh

Ranking : Sem avaliações
Número de Mensagens : 2183
Data de inscrição : 11/10/2009
Reputação : 106
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Lucas 5293 em Qua 09 Fev 2011, 11:44

vlw ja ta resolvido funcionou direitinho
obrigado pela atenção de todos

Lucas 5293

Ranking : Nota C
Número de Mensagens : 695
Idade : 18
Data de inscrição : 10/12/2010
Notas recebidas : C-D-B-B-B-C-C-C
Reputação : 18
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 1
   : 0

http://dopxgames.blogspot.com

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Luiz A. Oliveira em Qua 09 Fev 2011, 11:46

Envie uma mensagem privada para um moderador/administrador, para trancar esse tópico já que foi resolvido.

Luiz A. Oliveira

Ranking : Nota C
Número de Mensagens : 914
Idade : 19
Data de inscrição : 08/09/2010
Notas recebidas : D-B-C
Reputação : 5
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 0
   : 0

http://luizgm.blogspot.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por fonetico em Qua 09 Fev 2011, 12:17

Lucas, sem essa de ficar postando um post embaixo do outro. Leia as regras do fórum e não faça isso novamente ou as devidas precauções serão tomadas.

fonetico

Número de Mensagens : 1830
Idade : 21
Data de inscrição : 05/10/2009
Reputação : 7
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido] O som não toca quando faço load game

Mensagem por Conteúdo patrocinado Hoje à(s) 15:25


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum